Page 20 of 56 FirstFirst ... 10151617181920212223242530 ... LastLast
Results 381 to 400 of 1118
  1.    #381  
    Quote Originally Posted by Leke View Post
    But my pre is even slower than before now, it never speeds up to 800, even though I set the parameters in gvna
    Bummer. If you're able to reproduce it after a fresh webOS Doctor, we'll be happy to investigate further.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  2. #382  
    Quote Originally Posted by PreGk View Post
    Having big problems with Uber Kernel and the camera app. Anything over 600Mhz causes my camera to lock up,stutter, etc. Any fix for this? It didn't happen on the old 720Mhz.sh when I was using that.
    Seems to be related to the DSP turning off/on and hibernating at an inconvenient time. I have noticed with the new kernel Palm has scaled back on some things with IVA2 and DSP timings. I think sbromwich mentioned something about that.
    Live free or DIE!
  3. #383  
    Quote Originally Posted by kalex View Post
    Rod - reading this thread, you seemed to have nailed the reason why i was having one result with SPK and one result with Uber. it looks like LunaSysMgr is not what it suppose to be, which means that SPK didn't uninstall properly. Do you happen to know if there is a package that restores this to original condition like you have a package for the original Pre Kernel?

    here is what i get from md5 stuff:
    Code:
    root@palm-webos-device: grep LunaSysMgr /md5sums
      ce8ab50242283ea66592d5380041de2d *./usr/bin/LunaSysMgr
      194acce643388c8778d689fb259e8752 *./etc/event.d/LunaSysMgr
    root@palm-webos-device: md5sum /usr/bin/LunaSysMgr
      ca6a3981c382b01a559d7186742f1fe5  /usr/bin/LunaSysMgr
    root@palm-webos-device: md5sum /etc/event.d/LunaSysMgr
      cbc4e1c8da94d7c106dd3356d5455714  /etc/event.d/LunaSysMgr
    You can grab the LunaSysMgr file directly from the webosdoctor.jar file in the big tar.gz file, then send it to the Pre.
    Live free or DIE!
  4. #384  
    Quote Originally Posted by rwhitby View Post
    Unfortunately, because LunaSysMgr is a proprietary Palm binary, as opposed to the GPL kernel, we cannot legally distribute that file - so we cannot create a recovery package for it, nor can we include it in the existing recovery package.


    Explained this way makes your "statement" from yesterday make a lot more sense.

    What is legal in this situation, though? Patching the binary with its original 1's and 0's? Was a backup made of that file made at install time that could just be copied back over the exisiting one? What about grabbing the specific file out of Palm's .JAR and patching it that way?

    I mean, there's a hundred different ways to do it, but I'm asking what is legal?


    M.
  5. #385  
    Does screen state now work with the touchstone?
    *Patchers STILL make this phone Perfect!
    Palm Devices Currently Owned: Pre, Pre Plus, Pre 2, Pre 3, Pixi, Veer, Touchpads, and too many touchstones!
  6. #386  
    Quote Originally Posted by stu5797 View Post
    Does screen state now work with the touchstone?
    It works if you dont have the brightness level too low. try it, if it doesnt work then let me know.
    Live free or DIE!
  7.    #387  
    Quote Originally Posted by Xanadu73 View Post
    What is legal in this situation, though?
    WebOS Internals does not have lawyer (and hopes never to need one), so the following is not a legal opinion and you should contact your own lawyer before acting upon this advice.

    With that out of the way, the answers that we use when designed our solutions (e.g. patching, Meta-Doctor, etc) are:

    Quote Originally Posted by Xanadu73 View Post
    Patching the binary with its original 1's and 0's?
    Yes, if done by the end-user (or by a program being executed by the end user).

    Quote Originally Posted by Xanadu73 View Post
    Was a backup made of that file made at install time that could just be copied back over the exisiting one?
    Yes, if the backup is kept on the device and not redistributed in any way.

    Quote Originally Posted by Xanadu73 View Post
    What about grabbing the specific file out of Palm's .JAR and patching it that way?
    Yes, if done by the end user (or by a program being executed by the end user) without redistributing the file in any way.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  8. #388  
    Quote Originally Posted by rwhitby View Post

    Yes, if done by the end-user (or by a program being executed by the end user).



    Yes, if the backup is kept on the device and not redistributed in any way.



    Yes, if done (...) by a program being executed by the end user.



    I'm seeing a comon theme here...

    :-)


    Thank you, Rod. You've cleared everything up for me in your past two or so posts (and yesterday's...).


    Thanx, man.


    M
  9. #389  
    Quote Originally Posted by unixpsycho View Post
    It works if you dont have the brightness level too low. try it, if it doesnt work then let me know.
    Screenstate works with the touchstone!!!!!! 500 when charging...pull it off and back to 800! Great job. My scrren brightness is at 4. All we need are the settings to stick!
    *Patchers STILL make this phone Perfect!
    Palm Devices Currently Owned: Pre, Pre Plus, Pre 2, Pre 3, Pixi, Veer, Touchpads, and too many touchstones!
  10. #390  
    On screen state I tried having the lowest setting at 125 and the highest at 800. But, the lowest reading is 500. Am I doing something wrong? This is fun playing with this and so far the pre is still cool
    *Patchers STILL make this phone Perfect!
    Palm Devices Currently Owned: Pre, Pre Plus, Pre 2, Pre 3, Pixi, Veer, Touchpads, and too many touchstones!
  11. thornev's Avatar
    Posts
    326 Posts
    Global Posts
    329 Global Posts
    #391  
    Quote Originally Posted by stu5797 View Post
    On screen state I tried having the lowest setting at 125 and the highest at 800. But, the lowest reading is 500. Am I doing something wrong? This is fun playing with this and so far the pre is still cool
    Answer is elsewhere. Nothing is wrong. Unless powersave bias = 1, a defect in the kernel does not respect the Min Freq. Since screenstate does not provide a powersave bias setting, you will see the drop to 125. thorne
  12. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #392  
    Quote Originally Posted by unixpsycho View Post
    Seems to be related to the DSP turning off/on and hibernating at an inconvenient time. I have noticed with the new kernel Palm has scaled back on some things with IVA2 and DSP timings. I think sbromwich mentioned something about that.
    Yea, weird thing is that the camera works flawless with 500-600MHz, it only gets jammed up with 720/800Mhz. Do you think in future kernel releases this is addressable? Thanks.
  13. #393  
    It seems I have a problem. In Novnah 0.2.5, I set screenstate. But when I press the power button and turn off the screen, the CPU seems to be still working on 800M because I can not see the drop in the graph. But if I plug in the usb, it seems it works frawlessly.

    My pre is GSM unlock.
  14. #394  
    That is by design. Why? I have absolutely no idea, and I wish there was a way to change it because it makes all the work put into the graphing/logging next to useless (in my eyes). So, no, you don't have a problem. It's supposed to do that.


    M.
  15. kalex's Avatar
    Posts
    253 Posts
    Global Posts
    728 Global Posts
    #395  
    Quote Originally Posted by unixpsycho View Post
    You can grab the LunaSysMgr file directly from the webosdoctor.jar file in the big tar.gz file, then send it to the Pre.
    Thanks unixpsycho. found the file. question though: do i restore just one LunaSysMgr or do i need to restore the libLunaSysMgrIpc.so, event.d/LunaSysMgr?

    thanks

    Alex
  16. #396  
    This is sooo cool!!!
    You know me to be a reasonably smart person, don't you think I would know if I were wrong?
  17. #397  
    Just installed PreWare and Govnah, and set up the TestFeeds. However, the screens on GVN didn't show anything other than userstate....it seems I changed the setting to 600 by accident. Only Userspace and Ondemand are available on the Govnah/Govenor Settings; and the Settings show 125MHz in the Min/500MHz Max/Setsepeed is at 500MHz. In the main Govnah window, it shows frequency of 500, but no temperature.

    I don't know why the Phone would be "offline" but the only things I've changed are the added PreWare Test-Feeds, as outlined in the installation process for the Uberkernal.

    Is there a way I can shift back to factory settings to get the Phone to work and not be Offline...?

    Help would be appreciated as I'm a bit anxious that I screwed up the phone....

    Thanks in advance
  18. #398  
    I don't see the option of making the MAX FREQ to 800mhz! I only see 600!
  19.    #399  
    Quote Originally Posted by jmerkler1 View Post
    Just installed PreWare and Govnah, and set up the TestFeeds. However, the screens on GVN didn't show anything other than userstate....it seems I changed the setting to 600 by accident. Only Userspace and Ondemand are available on the Govnah/Govenor Settings; and the Settings show 125MHz in the Min/500MHz Max/Setsepeed is at 500MHz. In the main Govnah window, it shows frequency of 500, but no temperature.

    I don't know why the Phone would be "offline" but the only things I've changed are the added PreWare Test-Feeds, as outlined in the installation process for the Uberkernal.

    Is there a way I can shift back to factory settings to get the Phone to work and not be Offline...?

    Help would be appreciated as I'm a bit anxious that I screwed up the phone....

    Thanks in advance
    First, you haven't damaged your phone. Worst case, you'll need the doctor.

    How did you install these things? Preware? which version?

    Does the problem persist after a reboot?

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  20. #400  
    @ jmerkler1

    The Doctor really is your friend... you may be nervous about it if you haven't done it, but I like doing it after I have made a bunch of changes to my configuration or after getting everything settled like I like it following a WebOS update.

    It gives me peace of mind that everything is the way it should be.

Posting Permissions