Results 1 to 13 of 13
  1.    #1  
    so I got a warranty replacement Pre from Bell, got it activated today, updated WebOS from 1.3.5.1 to 1.4.1, and the device automatically downloaded all my existing apps.

    Everything is working but the app catalog. I'm getting "The action could not be completed. Try again later" message when I try to run it.

    Anyone run into this before? and is there a solution?
  2. #2  
    This has been a very common issue since 1.4.1(.1) came out. I don't know of any way to resolve it. Search the forums, you might have some luck.
  3.    #3  
    if it's that common, I might just try to doctor it with bell's 1.4.1 and start fresh, since it's a new device and I haven't put any patches on yet anyway. Might give that a try after I'm back from dinner tonight.
  4. #4  
    Quote Originally Posted by wunderbar View Post
    if it's that common, I might just try to doctor it with bell's 1.4.1 and start fresh, since it's a new device and I haven't put any patches on yet anyway. Might give that a try after I'm back from dinner tonight.
    im surprised it came with 1.3.5

    Last one I saw still came with 1.0 lol
  5. #5  
    Quote Originally Posted by kjb86 View Post
    im surprised it came with 1.3.5

    Last one I saw still came with 1.0 lol
    Wow. That one must have been sitting around for about a year
  6. #6  
    Quote Originally Posted by Garrett92C View Post
    Wow. That one must have been sitting around for about a year
    well it was only about a month ago hahaha

    go Bell!
  7.    #7  
    Quote Originally Posted by kjb86 View Post
    im surprised it came with 1.3.5

    Last one I saw still came with 1.0 lol
    Yea, I was honestly expecting it to have 1.1. Maybe this means they are actually moving some inventory.........
  8. #8  
    I doctored to 1.4, and had the same issue. Doing a full erase without doctoring will likely fix it. Erase data and apps.
  9.    #9  
    For the record, I doctored, and all was well after.
  10. #10  
    Yep...did a "Erase Apps and Data" and App Catalog started working again:

    Here is what I did for minimal down time

    1) Use Internalz (or your favorite method) to back up your lastest version of the PalmDatabase.db3 file (this keeps your contacts, messages, memos, emails and accounts, IM chats etc...) I know some use the Palm backup - but this keeps call history, message history etc...)
    2) In Preware update your "saved package list". (this keeps a list of all your patches and homebrew installed)
    3) use Save/Restore app (available in Preware - search under list of everything) to backup your "Saved package list" (i believe it copies the package list to your USB partition which survives the ERASE function)
    4) on the Pre...Goto Device info & Reset options and choose "Erase Apps and Data"
    5) After restart and Palm login verify that App Catalog is working (for some contacts will be back)
    6) Put Pre back into Dev mode (type webos20090606 in Universal search)
    7) Install Preware and Package Manager Service (I used WOSQI,... optional install Internalz and File Manager Service)
    8) Overwrite the new PalmDatabase.db3 file with the one you saved earlier it goes to var/luna/data/dbdata/ on the Pre (i used Internalz) and restart your Pre (all your main data: contacts, message history, emails etc should be back)
    9) Use Preware to install Save/Restore app
    10) Use Save/Restore app to restore your saved package list to Preware's Saved Package list feature.
    11) IMPORTANT - RESTART Preware and goto Saved Package List....now you see what patches and homebrew apps you HAD installed before (from step3). Click on "INSTALL ALL" (DO NOT CLICK "UPDATE" AS IT WILL UNDO WHAT YOU JUST DID WITH SAVE/RESTORE) (BTW patches and Homebrews must be available in Preware to be restored...so you may have to install some patches manually using WOSQI)

    This should put you back to pretty much where you were before you started. It is actually an easy process, it's just the constant LONG Pre restarts that is the time killer. The Save/restore app is GREAT.

    BTW - You could also "Doctor" your Pre - but it takes a LOT longer (and requires a computer) than the Erase function (which is only a minute or so). I was trying to find a way to do all this without a computer but the install Preware part requires it. (I heard there was an OTA way to install Preware but I am not aware of it)


    hope this helps someone

    DT
  11. #11  
    make sure the phone is new. Bell tried to give me two refurbs as new.

    such bs.
  12.    #12  
    also note that erase all apps and data does just that. doing the webos doctor re-installs the operating system, which is kind of what you want to accomplish, without requiring you to re-load your apps or put any files back on the pre. Well worth the 10 mintues it takes to do.
  13. #13  
    I've heard all Sprint replacements are all brand new phones lately.

Posting Permissions