Results 1 to 12 of 12
  1.    #1  
    Hello,

    I just started playing around with scaling and I was hoping to put in a script to enable scaling upon startup. I am using the following script:

    Code:
    # Enables cpu scaling
    
    start on stopped finish
    stop on runlevel [!2]
    
    console none
    
    script
    echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    echo 800000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    echo 125000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    echo 11 > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/up_threshold
    echo 1 > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/powersave_bias
    end script
    I saved it as cpuscaling.sh and placed it in the /etc/event.d folder via webosquickinstall.

    However, It doesn't seem to work. If I go into the command line and type out each of those commands, then check the files and scaling status, it all works fine.

    Can anyone show me what i'm doing wrong with the start up script?

    Thank you for any help
  2.    #2  
    bump
  3. #3  
    Wow...I never knew you can scale start up..interesting...
  4.    #4  
    I meant to enable scaling upon starting up, instead of having to manually input the scaling commands if I reboot the phone.
  5. #5  
    If you install the 720 or 800 Mhz patch, CPU scaling will always be enabled upon startup. You dont have to always enable it via commandline or terminal.
  6.    #6  
    time_in_state shows my pre is always using 800 mhz until I run the commands in the script above. Then it begins scaling from 125 to 800
  7. #7  
    Mine scales from 500 to 800. Delete the patch and reinstall. It dont think its suppose to constantly scale at 800, but i think scaling for 125 is quite abnormal. So delete the patch, restart the Pre and reinstall the patch. Reboot and then check time in state again.
  8.    #8  
    the 800mhz patch is working correctly. I really just need to figure out how to run that script when the phone boots up.

    Thank you for the help though.
  9.    #9  
    Also, you should check out 125mhz scaling, it has had an incredible impact on my battery life and the phones heat output.

    Plus I still get the full power of 800mhz when the phone needs it
  10. #10  
    I really want to stay away from scaling at 125 as much as possible. Its too slow..
  11. #11  
    I used the script at the top of this thread and it worked fine for me. Note that the startup mechanism is really intended to start long-running processes and this script really just runs and exits. The best way to tell if things worked is by looking at the values I bolded below and see if the values match what you expected, noting that I set mine to scaling_min_freq = 500000 instead of 125000.


    In the /sys/devices/system/cpu/cpu0/cpufreq directory, you should see the following values in the files:

    affected_cpus 0
    cpuinfo_cur_freq 500000
    cpuinfo_max_freq 800000
    cpuinfo_min_freq 125000
    scaling_available_frequencies 800000 720000 600000 550000 500000 250000 125000
    scaling_available_governors ondemand userspace
    scaling_cur_freq 500000
    scaling_driver omap
    scaling_governor ondemand
    scaling_max_freq 800000
    scaling_min_freq 500000
  12. #12  
    Quote Originally Posted by Jason Black View Post
    I really want to stay away from scaling at 125 as much as possible. Its too slow..
    I just enabled scaling with the 800MHz kernel from 500MHz to 800MHz and the results have so far been very impressive. In my very small sample size, I've seen a 1%/hour reduction in my battery usage without any noticeable performance or stability hit from 800MHz only by enabling scaling between 500 and 800MHz. Now my battery drain is between 1.5 and 2% drain per hour with WIFI only and the phone sitting idle with multiple calendar and e-mail accounts syncing.

Posting Permissions