Page 1 of 3 123 LastLast
Results 1 to 20 of 45
  1.    #1  
    I experimented with this yesterday, and verified it works. While numer1pete's UberScaler app truly rocks, I wanted the option of always having the scaling on should the phone reboot by itself, as it occasionally does. While I like the app's option to turn scaling on or off, MY PERSONAL PREFERENCE is to always have it on. Why not?

    So. I give all credit to number1pete for his help with this. I just simply created the script (a text file), and placed it in the correct directory. Once you do this, if your phone reboots for whatever reason, the script will execute, and you will be scaling between whatever mhz settings you specify.

    What you will need:
    1) The 800 or 600 mhz patch installed. Whichever you wish to accelerate to.
    2) A way to get to files on the phone. WINSCP, SSH, or even WebOSQI

    Steps to follow:
    1) Create a simple script file. I did it using the file creator within WINSCP. You can use notepad, but save the file with .sh extension, not text.

    2) In this file, place the commands below. Replace the numbers on the first 2 lines with those of your choosing. Some phones freeze at 125, so set it to 250000. At the top line, use 600, 720, or 800. Just remember that you need to have the patch installed to match that number.

    # Enables cpu scaling

    start on stopped finish
    stop on runlevel [!2]

    console none

    script
    echo "800000" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    echo "250000" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    echo "ondemand" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    echo "30" > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/up_threshold
    echo 1 > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/powersave_bias
    end script

    3) Save the file to your desktop with .sh extension.
    4) Copy it to your phone's etc/event.d directory. This should be simple enough with webosqi.
    5) Reboot your phone and test away.

    Good luck, and enjoy those 800 mhz!!!!
    Last edited by NABRIL15; 03/31/2010 at 08:29 AM.
  2. #2  
    does this .sh script require number1pete's uberscaler? if so could you link to it please.
  3. #3  
    Quote Originally Posted by novakry View Post
    does this .sh script require number1pete's uberscaler? if so could you link to it please.
    I believe that script is essentially what enabling number1pete's scaler does.
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  4.    #4  
    correct jason
    Pete's app let's you choose the scaling or speed parameters and force it to run by running the app (or not).
    The steps I indicated, force it to scale from reboot, thus not needing the scaler app.
  5. #5  
    hey,

    I've been trying to make this work for a couple days now. What could I be doing wrong? I created the script and moved it into the event.d folder via webos quickinstall. However, it doesn't seem to be enabling scaling. If I input the commands manually via the command line everything works fine. Any ideas on what I could be doing wrong? I installed terminal and verified that the script is in the proper folder on the phone as well.
  6.    #6  
    is the file's extension .sh? I believe it needs to have that in order to be recognized.
  7. #7  
    Quote Originally Posted by NABRIL15 View Post
    is the file's extension .sh? I believe it needs to have that in order to be recognized.
    Hey nabril,

    I have tried using a script with and without a .sh extension, still wouldn't work.

    Any other ideas?
  8.    #8  
    not sure what else to guide you on. I remember a similar thread about this in which people complained of the script not running. They were told to insert the lines twice.
    I have the script running now, but the powersave bias line apparently doesnt get recorded. I asked number1pete, the scaling master, about it, and he suggested I insert the line again in the script.

    So, it may sound asinine to have the lines twice in the script, but go ahead and try it out. It is a known issue that the echo commands dont take all the time.
  9. #9  
    guys the paid app does this, the free version doesn't. I believe you would still need the scaler app to scale this script would enable it at boot up.
  10. #10  
    Just did it with 250-800, and a time_in_state readout seems to confirm it's working, with big figures for 250 and 800 and just a few cycles in between.

    Am I right in assuming that /etc/event.d is a sort of autostart folder and that scripts inside it are automatically executed at boot?
  11. #11  
    Quote Originally Posted by bodyshop View Post
    guys the paid app does this, the free version doesn't. I believe you would still need the scaler app to scale this script would enable it at boot up.
    not true

    this script does what the scaler app does, but for free.
  12. #12  
    Quote Originally Posted by merkel85 View Post
    Hey nabril,

    I have tried using a script with and without a .sh extension, still wouldn't work.

    Any other ideas?
    Make sure you make the script executable.

    chmod +x name_of_your.sh
  13.    #13  
    thank you onlinesp. I did not know that command.
  14. #14  
    I can't seem to get it scaling

    I made the file "CPUScale.sh" which contains

    # Enables cpu scaling

    start on stopped finish
    stop on runlevel [!2]

    console none

    script
    echo "720000" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    echo "250000" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    echo "ondemand" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    echo "30" > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/up_threshold
    echo 1 > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/powersave_bias
    end script
    and put it into /etc/events.d/

    I then powered down my phone, took battery out for good measure, and powered it back up.

    When I put cat /proc/cpuinfo into command line on WebOSQI I still get readings that resemble about 720mhz even when the phone's screen is off and no apps are running.
  15. VKitty's Avatar
    Posts
    290 Posts
    Global Posts
    521 Global Posts
    #15  
    Quote Originally Posted by -Gamah View Post
    not true

    this script does what the scaler app does, but for free.

    So is this a free version of the scaler app?
  16. #16  
    Quote Originally Posted by Vkitty View Post
    So is this a free version of the scaler app?
    No, this is a script that gets run at startup by your pre to enable CPU scaling in the linux OS...
  17. VKitty's Avatar
    Posts
    290 Posts
    Global Posts
    521 Global Posts
    #17  
    Quote Originally Posted by -Gamah View Post
    No, this is a script that gets run at startup by your pre to enable CPU scaling in the linux OS...
    So I dont have to keep the scaler app installed at all? I can delete it?
  18. #18  
    Supposedly.
  19. #19  
    Quote Originally Posted by -Gamah View Post
    I made the file "CPUScale.sh" which contains


    and put it into /etc/events.d/
    Did you put it into /etc/events.d/ or /etc/event.d/ ? The former, the way you stated above, is incorrect.


    Also, the better way to test if it's working is to cd to
    /sys/devices/system/cpu/cpu0/cpufreq/stats/

    and then

    cat time_in_state

    which will show the amount of time it's spending at each frequency.
  20. #20  
    Quote Originally Posted by jhoff80 View Post
    Did you put it into /etc/events.d/ or /etc/event.d/ ? The former, the way you stated above, is incorrect.


    Also, the better way to test if it's working is to cd to
    /sys/devices/system/cpu/cpu0/cpufreq/stats/

    and then

    cat time_in_state

    which will show the amount of time it's spending at each frequency.
    it was in event.d, not events... My bad on the typo. However with cat time_in_state I see it's spending most it's time in 720... A little in 800 (boot I presume) and a measly 1297 in 500 mhz... It reads 0 for 250. The phone has easily had 4 hours of screeen off, no apps open idle time, why hasn't it scaled to 250?
Page 1 of 3 123 LastLast

Posting Permissions