Page 3 of 4 FirstFirst 1234 LastLast
Results 41 to 60 of 65
  1.    #41  
    Quote Originally Posted by Doug Stearns View Post
    This is very interesting to me. It seems most of you (here and in other threads) to get the "two many cards" error when you have multiple applications running but my problem seems a little different. My problem is when I'm browsing, if I open up multiple windows, and even if I begin closing them, I'll soon get the error and everything bogs down to a crawl or even a hault. To continue browsing, I have to do a Luna restart and begin again. It's driving me nuts and I've even wondered if I switch to a Pre Plus (I've got the original from Sprint) if that would take care of the problem. I've tried clearing the cache but that does nothing. I'd jump on the 720 patch right now to but now Palm is saying, don't do it. I'm having a hard time deciding... Any thoughts or ideas???
    The Pre/Pixi doesn't seem to care if it's a bunch of Web cards or different app cards. Each card opened takes up memory. It further appears that WebOS doesn't release the memory very well after closing a card. Some of us suspect it's closing the card but the process of clearing the memory from that card doesn't run. We're hypothesizing that the bump in CPU speed is allowing that process to run properly.
  2. #42  
    Thanks, Deesurgar. It's nuts that this happens in the first place, whatever the explanation is. I've just downloaded the jspot and will give that a test drive. From the comments in this thread, it will help but won't solve the problem. If TMC errors continue, I guess my next step is to try out one of the overclocking patches. I'm really not all that concerned about the warranty issues, assuming they are real. I really don't have a problem with my Pre's speed as it is. Somehow, using the overclocking patch to get rid of the TMC problem seems like overkill. Nevertheless, I admit to thinking, for the first time after eight months of loving this smartphone, that I'm ready to try something else.

    EDIT: I tried out jstop and it helped a little but not much. I still got the tmc errors but not as quickly as without it. This time I kept on browsing to see how far I could push it. Not long afterword my Pre froze and then reset itself. One thought: I run Brightess Unlinked in the background. Does anyone know if that might contribute to tmc errors?
    Last edited by Doug Stearns; 03/29/2010 at 10:33 PM. Reason: More info
  3. #43  
    jstop seems to work

    i still run into out of memory errors, but if you have jstop on automatic garbage collect, you wont have to open it up(because something u cant even open it up to run garbage collect when the no card error happens, EVEN if no cards are even open)

    u just wait a bit, and when it garbage collects, u can open more cards again
    works for me
  4. #44  
    glad to see i am not imagining things! since the OC, i have not seen the error message. i usually keep 1-3 cards open (if that), and used to see the message at least once a day. its been 4 days of error free, smooth phone bliss!
  5. #45  
    The only time i get the error is when i run 3d games and lets say a txt comes in i get that error.
    Ivan's Themes main thread

    Oklahoma Sooner theme

    If you would like to because you like my work or you just want to buy me a drink I would really appreciate it.
  6. #46  
    Before installing the 800MHz kernel, I didn't get the TMC error too often, but I did get it EVERY time I tried to open Uno without doing a Luna restart first. I thought this was odd since I can open NFS with other cards open no problem. I would think that NFS would be a bigger memory hog than Uno, but I guess not.

    Anyway... after installing the 800MHz kernel, I can now open Uno any old time I want without issue. I've also noticed a great improvement in load time for all the games, but especially the larger ones.

    I don't know exactly how the processor speed helped with what should be memory issues, but I'm glad it does.
    Follow me on teh Twitterz
  7. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #47  
    I've been running the 720 since it was released on the forums last week with similar results,UNTIL yesterday. I'm back to almost always getting the TMC error now when trying to load 3D games....anyone else?
  8.    #48  
    Quote Originally Posted by PreGk View Post
    I've been running the 720 since it was released on the forums last week with similar results,UNTIL yesterday. I'm back to almost always getting the TMC error now when trying to load 3D games....anyone else?
    3D games take up a lot of memory period. The Sprint Pre just doesn't have enough physical memory to deal with 3D games and other cards. The CPU patch will likely not help too much in this area because it's a physical limitation, although some have claimed less memory issues after the patch.
  9. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #49  
    Quote Originally Posted by deesugar View Post
    3D games take up a lot of memory period. The Sprint Pre just doesn't have enough physical memory to deal with 3D games and other cards. The CPU patch will likely not help too much in this area because it's a physical limitation, although some have claimed less memory issues after the patch.
    Right, but the issue went away after installing the patch, I can't understand why I'm having the TMC error again all of a sudden...
  10. #50  
    Quote Originally Posted by xalasten View Post
    I have the Bell Pre and the 800 mhz patch with jstop doing cleanup and was able to open 24 apps before the too many cards error...crazy..i woluld get the error after 5 cards before or sometimes after 1 . Thx again for the great work
    No, you didn't get the error after 1 card. You got it after you had opened about 10 cards or so and some of them didn't properly clear from memory... so it only had the appearance that there was 1 card open.

    Quote Originally Posted by deesugar View Post
    3D games take up a lot of memory period. The Sprint Pre just doesn't have enough physical memory to deal with 3D games and other cards. The CPU patch will likely not help too much in this area because it's a physical limitation, although some have claimed less memory issues after the patch.
    If the CPU is really moving as quick as it looks in the YouTube videos... then, I see no reason why it wouldn't be clearing the data from memory at this quicker rate as well.

    With 1.4, I've gotten the best memory management from webOS yet... but I have to wait until the app closes first. I don't know when that point is... but, basically, after I close a 3D game, I just wait ~10 seconds or so. And then another game will open up, which wouldn't happen w/ 1.3 at all. It was 1 game and then HAD to restart.

    So... since 1.4 seems to be clearing unused cache from RAM properly.... I could only imagine that the 800 MHz patch speeds that process along so that you only have to wait 3 seconds after the 3D game closes, as opposed to >=10 seconds.
  11.    #51  
    Quote Originally Posted by grndslm View Post
    If the CPU is really moving as quick as it looks in the YouTube videos... then, I see no reason why it wouldn't be clearing the data from memory at this quicker rate as well.
    It's not about clearing memory quicker, it's that we think the clearing process is being ignored by the CPU because it's overwhelmed by too many processes and the bump in CPU speed allows it to deal with it better. If you have another idea of why the patch is helping the "too many cards" issue we'd love other ideas to be shared.
  12. xalasten's Avatar
    Posts
    26 Posts
    Global Posts
    82 Global Posts
    #52  
    Quote Originally Posted by grndslm View Post
    No, you didn't get the error after 1 card. You got it after you had opened about 10 cards or so and some of them didn't properly clear from memory... so it only had the appearance that there was 1 card open.
    Hello,

    No , I there was only one card open, Generally streaming internet radio. I would get this error after a fresh restart of the phone and after about 20 minutes of streaming. I would close ( well try to ) the streaming app and if I tried to open anything I would get the error.

    Either way, since the patch I can open many apps, close them and open many more without gett6ing the error. I don't know why but it works better.

    Take Care All,
    Xalasten
  13. #53  
    Whatever happened to diomark's lower swap threshold patch? Is it no longer possible or unnecessary on latest updates?
  14. #54  
    TO EVERYONE STILL GETTING "TOO MANY CARDS ERROR ON 800mhz"

    1) Uninstall 800mhz Patch using WOSQI (/var/home...uninstall line)

    2) Restart phone

    3) Install WebOS Repair Utility in the same directory as WebOS Doctor and do a Scan/Repair.

    4) Have the program replace any changed or corrupted files

    5) After the device does a Luna Restart, Reinstall 800mhz patch using WOSQI.

    6) Shut down and restart phone




    This corrected the issue of the "Too Many Cards" error as I had corrupted/changed files
  15. #55  
    Quote Originally Posted by showmrock View Post
    TO EVERYONE STILL GETTING "TOO MANY CARDS ERROR ON 800mhz"

    1) Uninstall 800mhz Patch using WOSQI (/var/home...uninstall line)

    2) Restart phone

    3) Install WebOS Repair Utility in the same directory as WebOS Doctor and do a Scan/Repair.

    4) Have the program replace any changed or corrupted files

    5) After the device does a Luna Restart, Reinstall 800mhz patch using WOSQI.

    6) Shut down and restart phone




    This corrected the issue of the "Too Many Cards" error as I had corrupted/changed files
    This is pretty good advice except for people with other patches installed. It will eventually overwrite everything you patched. In some cases making your device worse than what it was. Should probably Doctor, and then do repair utility and confirm the doctor didn't load corrupted files.
  16. #56  
    I don't use patches except Flashlite for the Video recorder and there has been no conflict so far.
    Quote Originally Posted by Kyusaku View Post
    This is pretty good advice except for people with other patches installed. It will eventually overwrite everything you patched. In some cases making your device worse than what it was. Should probably Doctor, and then do repair utility and confirm the doctor didn't load corrupted files.
  17. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #57  
    Quote Originally Posted by xalasten View Post
    Hello,

    No , I there was only one card open, Generally streaming internet radio. I would get this error after a fresh restart of the phone and after about 20 minutes of streaming. I would close ( well try to ) the streaming app and if I tried to open anything I would get the error.

    Either way, since the patch I can open many apps, close them and open many more without gett6ing the error. I don't know why but it works better.

    Take Care All,
    Xalasten
    Audio apps will typically spawn 2-3 processes (based on my own observation) *outside* of Luna that are not visible in jstop. Therefore, these processes are consuming CPU cycles and memory,and I don't know how long after an audio app is closed that these processes terminate.

    And the audio processes seem to use a lot of CPU. Even with the 800mHz kernel I notice lag while listening to audio. Not nearly as bad, though.
  18. Minsc's Avatar
    Posts
    967 Posts
    Global Posts
    974 Global Posts
    #58  
    I too have noticed fewer TMC errors since loading the 800mhz patch, though I was chalking it up to a reboot rather than any fundamental change. Nevertheless, it is definitely interesting.

    Count me firmly in the camp that believes that whatever memory usage/leak issues webos has, it's NOT fixed or even abated by forcing garbage collection. I love JSTop, but I've found no difference in TMC errors (pre or post overclocking patch) with regard to utilizing it's automatic GC feature. I know people seem to think this is a magic bullet, but I disagree. I'd be willing to bet a fair amount of marbles that webos is not "forgetting" to GC.
  19. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #59  
    Actually, I am only getting it when I try to load Sandstorm, but the other 3D games load fine (NFSU, Super Ko Boxing 2, NFL2010, etc).
  20. #60  
    For me, the TMC error occurs during Universal search or just searching through my 7000 contacts.
    I still get the TMC error with the 800 MHz patch when performing the search but it seems to autocorrect better and faster. No need to luna reset.
Page 3 of 4 FirstFirst 1234 LastLast

Posting Permissions