Results 1 to 17 of 17
  1.    #1  
    Hi All,

    I recently purchased a Palm Pre Plus and I'm having trouble getting it to hit my home router, a Linksys WRT54G.

    The Palm Pre Plus is running WebOS 1.4 and the router is running the original firmware. I have MAC filtering turned on, but have added the Pre's MAC addy to my router list.

    Router uses WEP encryption.

    When trying to connect to the router, the Pre asks for the SSID, which I enter, and then it asks for a password. This is where it's weird. When I've connected a PC to the wireless, it's asked for the WEP data first.

    In any event, I try to enter the router password and the "connect" button disables itself as I type the last character.

    Any idea what's going on? Is there a tutorial online that I can refer to? Your help is appreciated!
  2. #2  
    I'm fairly certain that's the same router I have at home (i'll check after work). I have had 0 issues connecting my Pre Plus to it, although I don't have MAC filtering enabled (unless it's on by default?).

    Have you tried going into the wireless options and deleting your router from the list? It may be that it saved information about your network from a previous attempt and keeps conflicting with you attempting to reconnect.

    One last thing to try would be to turn off MAC filtering and try to connect your Pre. If it works, it's an issue with your router not filtering properly. If it doesn't work, you may want to doctor your phone (if you have any patches and such).
  3. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #3  
    I think you may need an even passcode, I.e. 8 digits/letters instead of 9. Try that.
  4. japark's Avatar
    Posts
    211 Posts
    Global Posts
    331 Global Posts
    #4  
    Have you tried removing encryption entirely? WEP has been broken for a long time. It really provides no security.
  5. mauro1's Avatar
    Posts
    205 Posts
    Global Posts
    213 Global Posts
    #5  
    WEP keys are of fixed length for each level of encryption. Meaning a lower WEP level requires a shorter key. Unlike WPA, WEP cannot handle variable length keys. WEP40 (whoever uses that anymore) if memory serves uses 8-character hex string or was that 13? WEP128 requires a 26-digit key and WEP256 is hapy with 58-digit keys only.

    By the sound of the description of the problem (greying out of the action button) it appears that you're getting a mismatch in the key length. Doublecheck that you're accurately entering the key in the format expected.
    Palm Pilot -> IBM WorkPad -> Handspring Visor -> Palm VIIx -> Palm T|X -> Palm Pre -> US GSM Palm Pre 2 [shelved] and 16GB HP TouchPad [died] -> (Samsung GNex and 32GB HP Touchpad with CM9)
  6. #6  
    hey,

    I have a WRT54G too and my Pre connects to it without any problem. I use WPA2 for encryption.

    why do you use WEP? It is not safe! And switch off the MAC filter, it really does not provide good security.

    check your WEP key, sonds like this is the problem. But better use WPA!
  7. #7  
    Quote Originally Posted by mauro1 View Post
    By the sound of the description of the problem (greying out of the action button) it appears that you're getting a mismatch in the key length. Doublecheck that you're accurately entering the key in the format expected.
    More accurately, the Pre won't let you enter a key of invalid length, as in not 5, 10, 13, etc. non-WEP key lengths. It doesn't tip you off how long the key is.
  8. #8  
    Quote Originally Posted by JoeyJoeJoeShabbadoo View Post
    I recently purchased a Palm Pre Plus and I'm having trouble getting it to hit my home router, a Linksys WRT54G.
    Get a better brand!

    Quote Originally Posted by JoeyJoeJoeShabbadoo View Post
    The Palm Pre Plus is running WebOS 1.4 and the router is running the original firmware.
    Updating the firmware is good for security's sake.

    Quote Originally Posted by JoeyJoeJoeShabbadoo View Post
    Router uses WEP encryption.
    WPA is better, FYI.

    Quote Originally Posted by JoeyJoeJoeShabbadoo View Post
    When trying to connect to the router, the Pre asks for the SSID, which I enter, and then it asks for a password. This is where it's weird. When I've connected a PC to the wireless, it's asked for the WEP data first.

    In any event, I try to enter the router password and the "connect" button disables itself as I type the last character.
    You don't enter the password to get into your router's set-up area, which it sounds like you might be doing. You enter the WEP password. The only time you need the router set-up password is when you are making changes to the settings on the router via a wired connection with a PC. Otherwise, the only password you need is your WEP password (or WPA password, if you switch to that).
  9. #9  
    Update firmware but look at 3d party firmware options too increase speed & stability over Linksys
  10. #10  
    I have the WRT54GS at home running DD-WRT custom firmware with WPA encryption and have no problems connecting with my Palm Pre Plus.
  11. #11  
    Quote Originally Posted by japark View Post
    Have you tried removing encryption entirely? WEP has been broken for a long time. It really provides no security.
    Sure any script kiddie can hack it and see what they want to see, but there's way more know-nothings in this world than there are script kiddies and hackers, and WEP keeps the know-nothings from casually connecting to your network and browsing those oh-so-easy-to-set-up insecure file shares.

    Locks, even crappy ones, keep honest people honest...
    Yeah, uhh... it's Kevin. (KevinT was already taken.)

    PalmPilot Professional, Palm V, Kyocera 7135, Treo 600, Treo 650, Treo 700p, Palm Prē & Prē 2, HP TouchPad & Veer
  12. #12  
    Actually, all you need to do to break WEP now is do a quick google search, and it takes less than a couple minutes to break. WEP encryption is about as secure as leaving a sticky note beside your keyboard with your logon password.

    honestly, because of how bad WEP encryption is now, and how much of a hassle it is to set up, if I had to choose between WEP and no security at all, I'd pick no security.

    Everyone should be running WPA2, or at the very least, WPA, if you have some devices that don't support WPA2, like I do.
  13. #13  
    Quote Originally Posted by JoeyJoeJoeShabbadoo View Post
    Hi All,

    I recently purchased a Palm Pre Plus and I'm having trouble getting it to hit my home router, a Linksys WRT54G.

    The Palm Pre Plus is running WebOS 1.4 and the router is running the original firmware. I have MAC filtering turned on, but have added the Pre's MAC addy to my router list.

    Router uses WEP encryption.

    When trying to connect to the router, the Pre asks for the SSID, which I enter, and then it asks for a password. This is where it's weird. When I've connected a PC to the wireless, it's asked for the WEP data first.

    In any event, I try to enter the router password and the "connect" button disables itself as I type the last character.

    Any idea what's going on? Is there a tutorial online that I can refer to? Your help is appreciated!
    Just a couple of humble suggestions:
    • Ditch MAC filtering. It provides no real security, and only causes hassle for yourself
    • Use WPA or WPA2, not WEP. Again, WEP adds no real security


    Also, you talk about the router's password. I may be just reading things wrong, but what you need to provide is the 13 or 26 character WEP key, not whatever your router password is.
  14. #14  
    WPA or WPA2 is the only way to go. AES is better than TKIP. Pre will connect to any of these combinations just fine.

    The WPAx use plain text passwords, too, and are therefore much easier to use.

    I would suggest using a longer password, preferably with some non-alpha characters.

    Sprint Pre & Motorola H300 BT headset

    Dead devices: Palm Pro; Palm III; Treo 600, 650, 700p, 755p; Centro
    Yes, I finally updated my tagline!
  15. #15  
    How can you say MAC filtering provides no real security. I realise that you can fake a mac address but you have to know the address you're faking before you can get anywhere. I have wpa2 and mac filtering on at all times.
  16. #16  
    Got a Pre with a WRT54G router here using WPA TKIP and have had no problems. My first guess would be you need to update the firmware as this router is quite a few old, and next I would look into the MAC filtering as taht is usually more a pain in the ***** then it is worth.

    I can definitely say taht it is not a problem with the phone....its on the router end.
  17. #17  
    Quote Originally Posted by stueybuk View Post
    How can you say MAC filtering provides no real security. I realise that you can fake a mac address but you have to know the address you're faking before you can get anywhere. I have wpa2 and mac filtering on at all times.
    Any device connected to an AP broadcasts its MAC in the clear. Kismet will show you this with no effort. Then I just disassociate the 'trusted' device, steal its MAC and connect. .

Tags for this Thread

Posting Permissions