Results 1 to 17 of 17
  1.    #1  
    I am running the Palm webOS 1.4.0. I had numerous issues with my patches and all are now solved, except for two. I tried to update them and tried to remove them but no luck.

    I'm running Preware v.0.9.29.

    The two patches are: "Add Select All and New Message" and "Show Actual Battery Percent".

    I get the same IPKG error messages for both patches with "Update" and "Remove" attempts:

    User consent requested for pre-remove script execution.
    Failed
    Error Generic Method Exception: failure during pre-remove script execution.

    I tried the Emergency Patch Recovery and Emergency Patch Installer from Web OSQuickInstall v.3.2 and all I did was erase ALL of my patches EXCEPT for the above two listed.

    Can anyone tell me how to get rid of these two patches? I'm out of ideas.
    Thanks so much for any help!
    harborgirl
  2. cmoneyct's Avatar
    Posts
    33 Posts
    Global Posts
    39 Global Posts
    #2  
    I had the same issue twice. First time the emergency patch migrator helped, the second was with the 1.4 update and I had to doctor my pre. It was the first time I had to dr, but it fixed it right up
  3. mrkalel's Avatar
    Posts
    739 Posts
    Global Posts
    821 Global Posts
    #3  
    I noticed that on all my Pre's and Pixi's... all I did was go to Quickinstall and delete Preware and Pakage update service, reinstall them and everything seemed fine again...
    Follow me on Twitter : MrKal_El
  4. pansovic's Avatar
    Posts
    57 Posts
    Global Posts
    65 Global Posts
    #4  
    Quote Originally Posted by cmoneyct View Post
    I had the same issue twice. First time the emergency patch migrator helped, the second was with the 1.4 update and I had to doctor my pre. It was the first time I had to dr, but it fixed it right up
    To Doctor your Pre, does that means Webos Doc to reinstall to a previous webos version?
  5.    #5  
    mrkalel (aka Steve) Thanks for the idea. I wondered about doing this. Do you think I can just uninstall Preware and Package Manager Service from my phone or do I have to use the Quick Install on my computer to remove them?

    I really don't want to use Web Doctor if I don't have to. I'm afraid my apps (esp. my paid ones) will go away. Or do the apps really stay?

    Thanks!
    harborgirl
  6. #6  
    Quote Originally Posted by harborgirl View Post
    mrkalel (aka Steve) Thanks for the idea. I wondered about doing this. Do you think I can just uninstall Preware and Package Manager Service from my phone or do I have to use the Quick Install on my computer to remove them?

    I really don't want to use Web Doctor if I don't have to. I'm afraid my apps (esp. my paid ones) will go away. Or do the apps really stay?

    Thanks!
    If you have Preload, you can reinstall Preware right on your phone. If you do have to doctor, you won't lose your paid apps only homebrew apps and your messages.
    "Patience, use the force, think." Obi-Wan


    Ready to try Preware? Get this first: Preware Homebrew Documentation
  7.    #7  
    Hi vza33,

    Thanks for the info on the doctor with apps. I do have Preload on my Pre but apps don't seem to download very well with it (i.e. Reset button). I guess I'll have to give the doctor a try.

    Hi cmoneyct:

    Thanks for your help as well. I guess I will have to go the doctor route after all. I have already done the emergency patch migrator (forgot to list that one in my first post--thanks for the reminder). I don't think there are other options for me at this point.

    Wish me luck with the doctoring! Thanks again everyone for your suggestions!
    harborgirl
  8. #8  
    Quote Originally Posted by harborgirl View Post
    Hi vza33,

    Thanks for the info on the doctor with apps. I do have Preload on my Pre but apps don't seem to download very well with it (i.e. Reset button). I guess I'll have to give the doctor a try.

    Hi cmoneyct:

    Thanks for your help as well. I guess I will have to go the doctor route after all. I have already done the emergency patch migrator (forgot to list that one in my first post--thanks for the reminder). I don't think there are other options for me at this point.

    Wish me luck with the doctoring! Thanks again everyone for your suggestions!
    If it's not too late, to install Preware with Preload just hit the Root button, make sure you're in dev mode.
    "Patience, use the force, think." Obi-Wan


    Ready to try Preware? Get this first: Preware Homebrew Documentation
  9. TJB
    TJB is offline
    TJB's Avatar
    Posts
    140 Posts
    Global Posts
    184 Global Posts
    #9  
    I had the same problem. I uninstalled preware\restarted then using quickinstall the patches downloaded fine.

    Hope this helps
  10. #10  
    Quote Originally Posted by vza33 View Post
    If you have Preload, you can reinstall Preware right on your phone. If you do have to doctor, you won't lose your paid apps only homebrew apps and your messages.
    Note that PreLoad is unable to correctly install the Package Manager Service.

    If you use PreLoad to try and install the Package Manager Service you will end up with a broken installation.

    Same for fileCoaster.

    The correct methods for installing and updating Preware and the Package Manager Service are listed at:

    Application:Preware - WebOS Internals

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  11. #11  
    Quote Originally Posted by rwhitby View Post
    Note that PreLoad is unable to correctly install the Package Manager Service.

    If you use PreLoad to try and install the Package Manager Service you will end up with a broken installation.

    Same for fileCoaster.

    The correct methods for installing and updating Preware and the Package Manager Service are listed at:

    [url= - WebOS Internals[/url]

    -- Rod
    Can't you download the Package Mgr Service with Preware after you've installed it with Preload? I could have sworn it's worked for me in the past.
    "Patience, use the force, think." Obi-Wan


    Ready to try Preware? Get this first: Preware Homebrew Documentation
  12. #12  
    Quote Originally Posted by vza33 View Post
    Can't you download the Package Mgr Service with Preware after you've installed it with Preload? I could have sworn it's worked for me in the past.
    PreLoad uses the Package Manager Service if the Package Manager Service is installed correctly in the first place.

    If you don't already have the Package Manager Service already installed (via WebOS Quick Install, or Preware, or the preware-bootstrap script), then attempting to install it for the first time with any other tool (like PreLoad, or fileCoaster) will fail, since they will not run the post-install script which starts the service running.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  13. mrkalel's Avatar
    Posts
    739 Posts
    Global Posts
    821 Global Posts
    #13  
    Quote Originally Posted by harborgirl View Post
    mrkalel (aka Steve) Thanks for the idea. I wondered about doing this. Do you think I can just uninstall Preware and Package Manager Service from my phone or do I have to use the Quick Install on my computer to remove them?

    I really don't want to use Web Doctor if I don't have to. I'm afraid my apps (esp. my paid ones) will go away. Or do the apps really stay?

    Thanks!
    Sorry I didn't get back to you sooner, but like I was saying earlier... I have done this to 5 devices... pretty much put em in Dev mode... Quickinstall... Uninstalled Package and Preware...
    Reinstalled Pack first, then Preware... (and while I was still hooked up to Quick I just updated whatever needed right away, its quicker)
    And after than I was good to go... didn't need to Dr. any of them...
    Follow me on Twitter : MrKal_El
  14. #14  
    Quote Originally Posted by rwhitby View Post
    PreLoad uses the Package Manager Service if the Package Manager Service is installed correctly in the first place.

    If you don't already have the Package Manager Service already installed (via WebOS Quick Install, or Preware, or the preware-bootstrap script), then attempting to install it for the first time with any other tool (like PreLoad, or fileCoaster) will fail, since they will not run the post-install script which starts the service running.

    -- Rod
    Ok right, I had Preware and the PMS already installed and then I deleted and then reinstalled Preware with Preload. That's what I meant in the first place I've done this three or four times.
    Ah! I did have Optware Bootstrap also.
    Last edited by vza33; 03/07/2010 at 09:18 PM.
    "Patience, use the force, think." Obi-Wan


    Ready to try Preware? Get this first: Preware Homebrew Documentation
  15. #15  
    I am still getting the IPKG error message when I try to either update or remove the SMS tone per contact and Sound Toggle for the camera. Do I need to remove Preware and Package Update Software from both quickinstall and through preware on pre? Does DiffStat have anything to do with the two I mentioned above. I looked at the utility and both are shown as part of the script writing. If I removed and reinstalled that program, would that cause major problems with other applications? Thanks again for any input, I am at a loss.....
  16. dlhughes41's Avatar
    Posts
    1 Posts
    Global Posts
    2 Global Posts
    #16  
    Have not been able to use, delete or update 6 patches since I removed them to download and install webOS 1.4. I thought I had removed them WebOSquickinstall but there must still be part of the patch on the phone. I used Web Doctor at the time and restore my phone and reinstall OS 1.4 but still have the problem
    Last edited by dlhughes41; 03/23/2010 at 10:15 PM.
  17.    #17  
    It has been a long process, but I finally did the instructions for the WebOSDoctor and went back to my "naked" Pre. Before doing this, I made Word documents on my computer of all the apps and patches that I had loaded on my Pre. That way I knew what was recovered and what was lost.

    Surprisingly, it all went pretty smooth but it does take a lot of time. After I set it up with Palm and my data was transferred (lots of stuff) I figured out what was missing. The pesky apps that wouldn't update or remove are finally gone--along with all my other Preware, apps and patches. I put my Pre in Developer Mode the long way (icon was again hidden), connected to my computer and launched the WebOS Quick Install. I did a couple of reboots with the Package Manager and Preware installs. Then, I added as many of the apps from Quick Install as I could--much faster that way! (Thank you for that advice, mrkalel a.k.a. Steve!) My Pre is back to "normal", except for two paid apps that I'm still working on, and all of my patches are installed and running perfectly. It's so nice to not be getting error messages anymore!

    Thanks so much for all of the help and ideas on solving these issues. PreCentral forums are absolutely THE BEST for getting fast, accurate help. I so appreciate everyone for their kind replies and not making me feel stupid with my questions. Learning about Pre issues on the forums is making such a big difference in my Pre ownership satisfaction! Thanks again, everyone!
    harborgirl

Posting Permissions