Page 3 of 8 FirstFirst 12345678 LastLast
Results 41 to 60 of 144
  1.    #41  
    Quote Originally Posted by xadjustx View Post
    Is there anyway to make it stick after an update
    if someone made a patch for WOSQI it would stick. Otherwise you can make a file yourself using vi editor in terminal. Just follow the instructions on this page where it says "making it stick"

    Patch webOS CPU Frequency or Voltage Scaling - WebOS Internals
  2.    #42  
    Quote Originally Posted by angiest View Post
    I couldn't use scaling before, had stability problems. Thus far in 1.4 it seems to be working fine.

    Does anyone know what version(s) of kernel Android is using? The problems with ondemand and smartreflex (which I have confirmed for myself) may be resolved in newer releases of kernel. The 2.6.24 Palm is using is fairly old in terms of Linux kernel development.
    i just pinged the kernel....here is the kernel that webos uses now:

    kernel 2.6.24-palm-joplin
  3. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #43  
    Simply enabling ondemand without any other changes still causes problems with video playback and games, so if you use those heavily the defaults are probably not for you. I would like to split the difference between dropping the CPU speed down when idle and getting good performance on certain tasks. I will review the other settings in the OP to see if any of them suit these particular needs.
  4.    #44  
    Quote Originally Posted by angiest View Post
    I am definitely getting time at 125 and 250 mHz.

    Can anyone get cut and paste to work in novaterm?
    works if you are using mac or linux computer. not on the pc though

    checked the internet for a new novaterm for pc and i couldnt find one. Need a version that supports copy past, up to do previous code etc..
    Last edited by number1pete; 03/04/2010 at 08:04 AM.
  5.    #45  
    Quote Originally Posted by angiest View Post
    Simply enabling ondemand without any other changes still causes problems with video playback and games, so if you use those heavily the defaults are probably not for you. I would like to split the difference between dropping the CPU speed down when idle and getting good performance on certain tasks. I will review the other settings in the OP to see if any of them suit these particular needs.
    yeah most of my research (that i mainly did a year ago) was to find the right settings that the pre liked. You have to up the sampling rate or you will get flicker. And you have to decrease up threshold or you will get stutters in audio.

    My settings are almost perfect. Playing with it more today. Having wierd issue today where it wants to go down to 125mhz even though i told it not too.....sounds like the old days again. Will investigate.
  6.    #46  
    Quote Originally Posted by number1pete View Post
    works if you are using mac or linux computer. not on the pc though

    checked the internet for a new novaterm for pc and i couldn't find one. Need a version that supports copy past, up to do previous code etc..
    i did notice that with the latest WOSQI you can launch linux command line which does support copy and paste! so you can copy and paste the code from the OP.
  7. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #47  
    Quote Originally Posted by number1pete View Post
    i did notice that with the latest WOSQI you can launch linux command line which does support copy and paste! so you can copy and paste the code from the OP.
    I don't like the WOSQI command line though, since it isn't a full terminal.
  8.    #48  
    okay looks like we have a problem. I have know idea what i did yesterday but my phone never went to 125 or 250 mhz......now when i setup everything right it goes down to those lower frequencies.

    this is crazy and i cant make it stop. still trying to find a work around but its not looking good.
  9.    #49  
    here are some other commands that you can copy and paste into the WOSQI terminal.....for the noobs out there...lol

    Palm Pre Hack To Significantly Extend Battery Life | L337Tech


    these commands will let you monitor your cpu's current situation
  10. #50  
    Ok tried, as original OP stated, and this is what I get

    600000 0
    550000 2279
    500000 36781
    250000 0
    125000 0

    This looks correct, but I am not certain...
  11.    #51  
    Quote Originally Posted by PIKCACHU20 View Post
    Ok tried, as original OP stated, and this is what I get

    600000 0
    550000 2279
    500000 36781
    250000 0
    125000 0

    This looks correct, but I am not certain...
    thats what mine looked like with when i first tried it yesterday (except i had more time in 600000).....open up a video or do some scrolling and see if you can get more time in 600000.
  12. #52  
    does anyone know if this works with or replaces unixpsycho's 600mhz patch?
    I have that installed with 1.4, and the phone works fine. I just wonder if this is better or more efficient.
  13. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #53  
    Quote Originally Posted by NABRIL15 View Post
    does anyone know if this works with or replaces unixpsycho's 600mhz patch?
    I have that installed with 1.4, and the phone works fine. I just wonder if this is better or more efficient.
    http://forums.precentral.net/palm-pr...ml#post2280466

    The default governor is userspace, which basically allows applications to set the speed "permanently." Therefore, the LunaSysMgr patch originally from unixpsycho (and which marco and caj2008 were working with) keeps the speed at 600mHz all the time.
  14. navinag's Avatar
    Posts
    455 Posts
    Global Posts
    489 Global Posts
    #54  
    I tried the instructions in the OP and all seemed to work fine....however, the setting do not go away upon reboot. Max scaling freq is still set to 600 upon reboot but the governor gets reset to userspace. Shouldn't the max scalingfreq get reset to 500 upon reboot? How do I put my phone back to all the original setting that the OP changed...
  15. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #55  
    Quote Originally Posted by navinag View Post
    I tried the instructions in the OP and all seemed to work fine....however, the setting do not go away upon reboot. Max scaling freq is still set to 600 upon reboot but the governor gets reset to userspace. Shouldn't the max scalingfreq get reset to 500 upon reboot? How do I put my phone back to all the original setting that the OP changed...
    The phone is allowed to run at 600mHz (hence the max speed is set there) but LunaSysMgr executes a call to cpufreq to set the speed to 500mHz while it is launching. Check to see what you are running at currently.
  16. navinag's Avatar
    Posts
    455 Posts
    Global Posts
    489 Global Posts
    #56  
    so I read in this post that the games bump the freq to 600. Does this mean that anyrhing using the SDL library will bump the freq. If this is the case then "terminus" will always bump thr freq when I use it to see the time in state file. Therefore it would appear that my phone was always in 600.....i will get a pc terminal to verify this.....
  17. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #57  
    Games set the speed to 600mHz when using the userspace governor. With the ondemand governor they will attempt to set to 600mHz, but the ondemand governor will drop it back down, so it really doesn't have an effect. This is why scaling can cause choppiness and why some of these settings are there.
  18. #58  
    ok.
    So I created a cpu-scaling :
    # Enables cpu scaling

    start on stopped finish
    stop on runlevel [!2]

    console none

    script
    echo "ondemand" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    echo "600000" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    echo "125000" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    echo "20" > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/up_threshold
    echo "1000000" > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/sampling_rate
    echo "0" > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/powersave_bias
    end script
    I have it in the /etc/event.d folder as instructed by WebOS internals.

    the problem I have is that it doesn't want to set the scaling_governor to ondemand.
    The only way I can set this is as per the 1st post in this thread.

    Any ideas on how to make this change permanent?
  19. #59  
    <duplicate>
    Last edited by the.teejster; 03/05/2010 at 02:35 PM.
  20. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #60  
    For the settings that aren't sticking you might try setting them twice. I remember seeing a note about that in some of the powersave patches.
Page 3 of 8 FirstFirst 12345678 LastLast

Posting Permissions