Results 1 to 4 of 4
  1.    #1  
    The last couple of days web searches in the browser return results in spanish. I've deleted cookies/chips/cache/release/history/science and still the same issue. Is anyone else having this problem?
  2. #2  
    I get a French google sometimes. This should only be happening on 3G connection. I believe this is because Sprint get some of its IP space from foreign countries. Try doing a traceroute on your current IP and see what country it goes to. You can try going to airplane mode and back and see if you get an "American" IP address. Let me know if this works.
  3.    #3  
    turning airplane mode off/on worked. Thx
  4. #4  
    I had that problem....go to the bottom of the page click on settings then on the top right click on mas opciones the on the next page ull see where it says (espanol) click in there n check for the word ingles(english) then go to the bottom of the page and click on guardar preferencias, means save preference n that changes the setting fr spanish to english

Posting Permissions