Results 1 to 9 of 9
  1.    #1  
    Like quite a few people here, 1.3.5 had great battery life for me, while 1.3.5.1 has drained my battery at 10% per hour or more.

    My problem was not related to Wifi, as I rarely use it.

    After a fair amount of testing, here is the solution: put Gmail on manual retrieval. As soon as I did that, batter drain dropped to 3% per hour or less.

    On my Pre, I have brightness down low, no BT and no Wifi. GPS is on. I'm running a stock build with no doctoring or hacking.

    When I had 1.3.5, I was running one EAS account and Gmail / Google contacts / Google calendar. Polling was set to 15 minutes for both. No major battery problems.

    As soon as 1.3.5.1 installed, the battery went to crap.

    I noticed that when I disabled all Google accounts, battery drain improved dramatically. At first I thought it was a problem with IMAP, so I installed a test IMAP account with a very small mailbox (one message). However, that IMAP account didn't cause any battery problems.

    However, when I reinstalled Gmail and set it to manual retrieval, battery life went back to normal. My theory at this point is that it may have something to do with my Gmail account having 600MB of email on the server and the phone possibly wasting a lot of CPU trying to figure out what to synch.

    On the other hand, I'm not certain about that, since I still had battery problems when I uninstalled Gmail but left Google contacts and calendar on the phone. I do have a lot of contacts (1500+) so maybe its another synching issue? I don't know.

    In any case I spent several days playing around to figure this much out and now my Pre is back to going 24 hours or more on a single charge. Hope this helps some of you for now.
  2. #2  
    it is true, the intense data pulling by either wifi or 3G consumes 20-30%/hr,

    normally standby consume battery about 2-3%/hr, if you set to check email every hr, even if each session lasts about 5 min, it will add extra 2-3%/hr

    I set my main gmail acc to check every 6 hrs, all other 6 accounts check every 24 hrs.

    this is what I have (I have AIM/Gtalk on all day, 3 calls, internet for about an hour)
  3. #3  
    My gmail is set to push on WebOS 1.3.5.1 and my Pre still consumes less than 2% an hour unless I am in a poor reception area without wifi. Admittedly, I don't get a lot of emails through the gmail account. (I also continue to leave wifi, bluetooth and GPS on all the time.)
  4. jmcging's Avatar
    Posts
    28 Posts
    Global Posts
    41 Global Posts
    #4  
    Two nights in a row I've found my Pre dead when I get up; once I put my Pre on the Touchstone not quite right meaning it wasn't actually charging and once I just left it on my desk and both times I've found I've gone from 100% to won't boot dead in less than 8 hours.

    Hopefully adjusting gmail using the above as a model will fix that, because going dead even though the device was unused (by me) overnight just isn't right.

    John
  5.    #5  
    Quote Originally Posted by clevin View Post
    it is true, the intense data pulling by either wifi or 3G consumes 20-30%/hr,


    Very true, though this problem did not exist on 1.3.5 (for me at least).
  6. #6  
    Quote Originally Posted by bevcraw View Post
    My gmail is set to push on WebOS 1.3.5.1 and my Pre still consumes less than 2% an hour unless I am in a poor reception area without wifi. Admittedly, I don't get a lot of emails through the gmail account. (I also continue to leave wifi, bluetooth and GPS on all the time.)
    Mine is also set to push, with GPS on all the time. I don't leave wifi or BT on all the time, but I never have on any (capable) phone -- just turn 'em on as I need em. I always had the same drain regardless of OS release (i.e. there was no change between 1.3.5 and 1.3.5.1)...under 50% by 4:30 p.m. (day starts at 5:30 a.m.) with moderate use.

    However, I got a brand-new Pre (warranty date 12/22/09) a couple of days ago, due to repeated issues with the refurbs, and now my battery is around 70% at 4:30 p.m. with moderate use!!! I still have all the same apps and patches and use patterns and settings, but my battery life has improved dramatically. Don't know if it's an updated battery with the newer build dates or something else, but it's great!
    Blaize, Mistress of Verbosity



    Be nice until it's time to not be nice.--Dalton, "Roadhouse"
  7. #7  
    I'm thinking something else is going on with 1.3.5.1. I too was getting better results with 1.3.5, and at times I'm getting very good results with 1.3.5.1 as well. At other times, though, I've noticed that battery life is terrible, worse than with 1.2.1. And this is in the same general places doing the same general things.

    I've pretty much given up on trying to figure this out, and am waiting (less than patiently) for 1.4.
    Treo 600 > Treo 650 > HTC Mogul (*****!) > HTC Touch Pro (***** squared!) > PRE! > Epic
  8. PreMium's Avatar
    Posts
    236 Posts
    Global Posts
    242 Global Posts
    #8  
    Is there any way to control how often Google syncs to contacts and calendar?
  9. #9  
    Quote Originally Posted by bevcraw View Post
    My gmail is set to push on WebOS 1.3.5.1 and my Pre still consumes less than 2% an hour unless I am in a poor reception area without wifi. Admittedly, I don't get a lot of emails through the gmail account. (I also continue to leave wifi, bluetooth and GPS on all the time.)
    +1 Not all Pre's are created equal as we are all finding out, but i have to agree with the above comment, seems as if your batteries aren't in the majority
    R.I.P Palm Centro (6.5.09)
    New Pre Owner (6.6.09)

Posting Permissions