Results 1 to 8 of 8
  1. eakrish's Avatar
    Posts
    39 Posts
    Global Posts
    133 Global Posts
       #1  
    Please Close Thread......
    Last edited by EAkrish; 01/16/2010 at 05:36 AM.
  2. Helidos's Avatar
    Posts
    791 Posts
    Global Posts
    810 Global Posts
    #2  
    Quote Originally Posted by EAkrish View Post
    I have a problem. I let my pre drain all the way down until it shut off. I put it on the charger and the battery with the red comes on. After a little bit the screen starts flasking on and it has(what i will describe as) a seizure. I have taken the battery out twice already and it still does it. Side note, this is not a pre charger. Just a micro usb charger I happen to have lying around. Thanks in advance!
    Could be the cable. First time using that cable? got another one you could test?
  3. eakrish's Avatar
    Posts
    39 Posts
    Global Posts
    133 Global Posts
       #3  
    tested another one just now. Seems to be working.... It is charging real slow though. It is the first full charge. Maybe that is the reason??
  4. eakrish's Avatar
    Posts
    39 Posts
    Global Posts
    133 Global Posts
       #4  
    it has been on the charger since my last post and it is only at 38%. Do these phones charge really ssslllooowwww? Or is it just the fist charge?
  5. eakrish's Avatar
    Posts
    39 Posts
    Global Posts
    133 Global Posts
       #5  
    it has been on the charger since my last post and it is only at 38%. Do these phones charge really ssslllooowwww? Or is it just the first charge?
  6. eakrish's Avatar
    Posts
    39 Posts
    Global Posts
    133 Global Posts
       #6  
    update, see original post. phone freaks out while charging
  7. #7  
    bad wire imo. Too low in volts to to charge.
  8. Helidos's Avatar
    Posts
    791 Posts
    Global Posts
    810 Global Posts
    #8  
    Quote Originally Posted by blatherdrift View Post
    bad wire imo. Too low in volts to to charge.
    Or something wrong with the phone...

Posting Permissions