Results 1 to 12 of 12
  1. HakanO's Avatar
    Posts
    87 Posts
    Global Posts
    88 Global Posts
       #1  
    I thought it would be interesting to learn if 1.3.5.2 still requires editing the CarrierNetworkSettings.db3 database file in order to get 3G Data working on non O2 networks.

    I am on the Sweden 3 network with 3G Data running on 1.3.1 with a edited database file - will report this evening on results after upgrading to 1.3.5.2
  2. #2  
    3G worked just fine after 1.3.5.2 in Australia with Telstra SIM card.
  3. #3  
    Just use the manually settings under the Phone app
  4. #4  
    Well for me, I'm on Vodafone NL and the APN bug is still there....I had to mod the options-GSM file once again.


    But at least it works
  5. #5  
    Quote Originally Posted by slimmo View Post
    3G worked just fine after 1.3.5.2 in Australia with Telstra SIM card.
    Where did you purchase your Pre?

    Edit: I see from elsewhere that it is a German Pre. I thought that 3G was not possible because of the frequency used by Telstra. Obviously not.
    Last edited by johncc; 01/13/2010 at 06:57 AM.
  6. #6  
    3G works perfectly with WIND in Italy.
    Not tryed MMS.
  7. HakanO's Avatar
    Posts
    87 Posts
    Global Posts
    88 Global Posts
       #7  
    After updating my 3G Data was not working "out of the box" for the Sweden 3 Network.

    Tried entering APN settings manually in phone prefs but still "not able to save changes".

    Back to manually editing the CarrierNetworksSettings.db3 database.

    3G Data (and MMS) working again.

    Happy again...but why don't they update the file...it looked mostly the same as in 1.3.1?
  8. #8  
    Quote Originally Posted by johncc View Post
    Where did you purchase your Pre?

    Edit: I see from elsewhere that it is a German Pre. I thought that 3G was not possible because of the frequency used by Telstra. Obviously not.
    I don't see any reason why they would not have access to the 2100 frequency telstra uses/owns/shares with the 3network, it's just that it's ONLY in the major metropolitan cities.

    It probably shows up as roaming?

    None of the telstra users have chimed in about this so far??
    HP200LX->Treo270->Treo600->Treo650->Treo680->Centro->iPhone3G->
    Treo680->TreoPro->iPhone3GS->PalmPre->HPPre2->HPVeer 2.2.3->HPPre3

  9. #9  
    Working fine on Virgin Mobile UK

    1.3.5.2 on my QWERTZ Pre
  10. #10  
    Quote Originally Posted by johncc View Post
    Where did you purchase your Pre?

    Edit: I see from elsewhere that it is a German Pre. I thought that 3G was not possible because of the frequency used by Telstra. Obviously not.
    I bought an O2 Qwertz Pre (model P100UEU) from Expansys UK (although phone was actually shipped from Expansys Hong Kong). They were fine to deal with.

    Re the frequencies: it's an 850/900MHz thing. With an Optus SIM card (which I needed for activation) I got "3G" with no "R" (roaming) indicator. After changing to the Telstra NextG SIM, I get "3G" WITH an "R" indicator, BUT BUT BUT the charging seems to be normal (no $15/MB typical roaming fees). So it appears that the appearance of "R" is a result of firmware (depending on which freqs used). I suppose for O2 in Germany the 850/900 (cant remember which) is the same as Optus, so thats why Telstra displays "R".

    Cheers
  11. #11  
    I think the R in this situation means you are on the telstra 2100mhz freq. Have a look at their website, they don't have much of it, and it is jointly owned with 3 (hutchison). They both shared it BEFORE Telstra built their nextG network, which is all 850. Your right, there should be no roaming charges, although, I don't believe it is as fast as nextG ie: their 850mhz hardware? Might be wrong though.
    There are some knowledgeable people on whirlpool who can explain this better than me :-)
    HP200LX->Treo270->Treo600->Treo650->Treo680->Centro->iPhone3G->
    Treo680->TreoPro->iPhone3GS->PalmPre->HPPre2->HPVeer 2.2.3->HPPre3

  12. #12  
    I guess I'll be waiting for 1.4 to updated/doctor it all again...manual updated doesn't work since November for me in Germany on a unlocked device...I have patience...

Posting Permissions