Results 1 to 16 of 16
  1.    #1  
    Is this just me? In previous versions the WiFi would disconnect when the screen was off and then reconnect (quickly) when the screen was turned back on. Since 1.3.5.2 it seems the WiFi stays connected when the screen is off...

    Can anyone else confirm this change in behaviour?
  2. #2  
    This is a confirmed addition to the latest firmware. It's not just you
  3. #3  
    but wouldn't this make the battery drain even faster?

    I've found that on 1.3.5.1 the Wireless keeps running when the screen is off, at least keeps answering pings for a while...
  4. Daemon's Avatar
    Posts
    796 Posts
    Global Posts
    809 Global Posts
    #4  
    "for a while" is the key.
    Yes, it appears to now keep the Wifi radio enabled while the phone sleeps,
    but with no activity the radio itself appears to go to sleep after a minute
    or so and it stops answering external pings, and then it uses no more power
    than if it were turned off.
    If it's working properly the wifi radio uses less power than the EVDO radio
    so when background apps wake up the Pre to fetch email, and do
    other sync tasks it uses less juice to use the Wifi radio.

    Problem is, for *some* people following 1.3.5 (at last in 1.3.5 and 1.3.5.1),
    something on their Wifi network appears to keep the Pre awake (or rather
    it wakes up about once per second, continuously) and this is sucking the
    battery down. You can simulate the same behavior if you start pinging the
    Pre continuously and then let it try to sleep. It'll just keep answering
    pings forever. If you have Terminal app running and come back
    to it after a few minutes you'll see that it's been going to sleep and
    waking up again and and again. It's possible that 1.3.5.2 has fixed
    this, but we probably won't know for a few more days.

    ian
  5. #5  
    The potentially bad news is, I don't believe it is fixed. Stock GSM 1.3.5.2.

    It does appear to be router specific, as I have my pre linked to one at work, and one at home.
    Put the pre on the bedside table last night at about 85%. Woke up 2am, tried to check time, it was already dead. No problems all yesterday with the work one (I installed update yesterday morning)

    I'll look up the precise model of my router, but its a 2 year old (or so) belkin one. Decent router signal throughout the house.

    Will do some tests tonight, charge it up, leave it for a couple of hours, inspect battery life, and then turn off pre wifi and test again. Should be obvious if there's a huge difference in drain.
  6. Daemon's Avatar
    Posts
    796 Posts
    Global Posts
    809 Global Posts
    #6  
    Instead of guestimating at the drain, install the Battery Monitor app
    and set it to recording and graphing exact drain rate. As long as it's
    polling at more than a minute interval it doesn't use any noticeable
    juice itself.

    ian
  7. #7  
    I noticed a big drain today as well. I normally leave the wifi off but I left it on this morning as I was getting it connected to a new wifi at work and forgot to turn it off afterwards.

    I lost 30% battery in 2 hours before I noticed and turned the wifi off, it has only lost a further 5% in the 5 hourse since. I don't remember any performance like this with 1.3.1 so I guess it is something keeping the wifi awake.

    EDIT: I should add that there are several wifi networks here at work so it was probably switching between them frequently in those 2 hours and I went for a 3/4 hour walk where there would have been all sorts of transient signals including some BTOpenZone which would have been enabled thanks to my O2 contract.
  8.    #8  
    I'm not having any issues with WiFi draining the battery even with this new "always on" setup. In reality it is not "always on" it just disconnects a little while after you turn the screen off whereas previously it disconnected instantly.

    FWIW: took it off the charger at 8am, now 6pm and I have 90% battery left. WiFi has been on all day, although I haven't really used the phone at all.
  9. #9  
    Quote Originally Posted by BlueC View Post
    I'm not having any issues with WiFi draining the battery even with this new "always on" setup. In reality it is not "always on" it just disconnects a little while after you turn the screen off whereas previously it disconnected instantly.
    The problem is that some of us are not experiencing that behaviour, our WiFi is staying on continuously in our pockets and draining the battery. Clearly there is some configuration issue causing this for some and not for others but don't just dismiss it out of hand.

    Out of interest, is anyone else also getting a lot of failures to connect with an 'IP CONFIGURATION FAILURE'? Switch off for a while and try again and it usually works. Maybe some connection here?
  10. flamand's Avatar
    Posts
    141 Posts
    Global Posts
    159 Global Posts
    #10  
    This subject is being discussed in some other 1.3.5 battery drain threads. At this point, it's pretty widely documented. Clearly, it does not affect some people and their battery life has dramatically improved with 1.3.5.+. For some of us, we're seeing battery drain rates of 18-30% per hour. A lot of suggestions have been put out there and tried. It definitely seems to come down to a wifi issue and probably with some specific routers. Likely culprits are from D-Link and Netgear. Rather than blame the router companies, Palm should try and figure out why this is cropping up in 1.3.5.1/1.3.5.2. It hasn't been an issue before those firmwares.

    In my case, with wifi off, I have idle drain rates of 2-3% per hour. With wifi on, the idle drain rate jumps up to 20-25% per hour!
  11. #11  
    I've found it's not fully on when the phone goes into standby. It may still use wifi for checking mail and such (so much for 'push' being as you configure it, but I digress), but I can't, for example, open connections to the phone any longer until it wakes up. SSH or ICMP echo, for example.
  12. #12  
    I have a Netgear WNR-3500 wireless router and I have noticed very noticeable battery drain since upgrading to 1.3.5.1. I used to be able to go all day from about 8am till about 12:00am on a single charge with some time left. Now by noon, my battery is about 50-60% and that's not doing much. I've been using my bluetooth headset more, but it's gotten to the point, I turn that off and still see the drain....

    Hmmm!!!
  13. #13  
    I have found a possible solution to our problems with WiFi after the 1.3.5 update.
    It has to do with the Beacon and DTIM interval settings. Many people do not experience problems because their routers are configured with a relatively high interval.
    Just read here:
    Optimize Multicasting on Your WLAN - www.enterprisenetworkingplanet.com

    I have changed the settings on my DLink 855 Router and now battery life has improved again. I am still playing with the settings and when I have more information I will post the setup that works best for me
  14. #14  
    I have a Linksys WRT150N, left Wifi on Pre on all night, and it only lost 10% overnight. I'm on Sprint 1351.
  15. #15  
    The solution for this problem is not in router configuration but in 1.3.5 wifi logoff behaviour. Palm, bring back 1.3.1 wifi standby mode, please! That was great for my battery then.
  16. #16  
    Quote Originally Posted by petvas View Post
    I have found a possible solution to our problems with WiFi after the 1.3.5 update.
    It has to do with the Beacon and DTIM interval settings. Many people do not experience problems because their routers are configured with a relatively high interval.
    Just read here:
    Optimize Multicasting on Your WLAN - www.enterprisenetworkingplanet.com

    I have changed the settings on my DLink 855 Router and now battery life has improved again. I am still playing with the settings and when I have more information I will post the setup that works best for me
    And for those of us using public or workplace routers where we can't go in and see, let alone change, these settings?

    I think Palm needs to rethink this a little.

    EDIT: Having read the details of that article, maybe the problem is that there IS multicast traffic on our routers and so that is keeping the Pre awake. Of course, this is likely to be the case on any large public node regardless of the router settings.
    Last edited by andyhurley; 01/15/2010 at 05:43 AM.

Posting Permissions