Results 1 to 19 of 19
  1.    #1  
    I'm getting a restart required error:
    System adjustments must be made before installation can continue.
    Is anyone else getting this error when trying to install new or upgrading existing apps from the Palm app catalog?

    Please let me know if you removed patches before your 1.3.5.1 upgrade.
    Thanks!

    I didn't remove patches by accident and am wondering if this has anything to do with why it doesn't work. I wouldn't think so because I didn't have any tweaks which affected the App Catalog. Unfortunately, it's not like preware where it can provide you a log of the error.
    ===============
    Solution figured out:

    If you have Preware install Emergency Migration Helper.

    If you don't have Preware, then you will need to use WebOS Quick Install to install Preware and Package Manager Service. Run Preware, search list of everything for Emergency Migration Helper. Install it and let it restart Luna. You're fixed. You can update your apps.
    Last edited by bobwonderful; 01/07/2010 at 11:50 AM.
  2. #2  
    This is happening to me too. Darn it, I knew there was a reason I avoided updating apps. It was one of the useful apps I used so I figured I'd do it. Now I can't use it. Blast it.
  3. Kahless2k's Avatar
    Posts
    2 Posts
    Global Posts
    4 Global Posts
    #3  
    I did a partial reset before updating and am running into the same issue. My wife (who had no patches prior to the update) is also unable to install anything from the app catalog.

    We're both getting 'a system change is required please reset' or somthing to that effect. After reseting, we just get 'install failed' messages.

    Seems to be a 1.3.5.1 issue.. 1.3.5.1.1?
  4.    #4  
    The other problem I have is that if I tried to install it there is no way I can get rid of the icons with the ! on the cards view as it doesn't show up in the apps for deletion.
  5. phwelo's Avatar
    Posts
    527 Posts
    Global Posts
    554 Global Posts
    #5  
    i'm having this same issue. you can delete those non-working icons from the launcher using orange+click though. any solution to this? i'm not thrilled about the idea of using webos doc for the... probably the 20th time...
    http://phwelo.mobi
    for any questions or to send a donation: phwelo@gmail.com
  6. #6  
    This started happening for me with the 1.3.5 update, and I was careful before that to remove all my patches. This time I was lazy and wanted to see what happened, so I installed the 1.3.5.1 update with my patches still in place and while everything seems to work just fine, the App Catalog is still failing to install. I guess this thread means no one has a solution yet?
    Developer must watch videos by Douglas Crockford of Yahoo:
    The JavaScript Programming Language part 1/4
    Theory of the DOM 1/3
    Advanced JavaScript 1/3
  7. #7  
    I uninstalled my theme/patches for the 1.3.5.1 update and have had mixed results with app catalog. I downloaded some new apps and updated some with no issues. Just a minute ago I updated 3 apps and 1 worked and 2 didn't. Right now Picassa on Phone and Stopwatch/Timer will not update. I would like to see palm let your version revert to the previous one if the update failed so you can at least use the app. Not sure if that is possible
  8. Ty
    Ty is offline
    Ty's Avatar
    Posts
    19 Posts
    #8  
    I had this issue and just found the solution on this thread, first post:

    forums.precentral.net/palm-pre/221344-official-webos-1-3-5-issues.html

    If you have Preware installed (I did). You need to use WebOS Quick Install to remove Preware and Package Manager Service. Then reinstall them both. Run Preware, search list of everything for Emergency Migration Helper. Install it and let it restart Luna. You're fixed. You can update your apps.

    Worked perfectly for me. Gotta love Preware and the guys at WebOS Internals!
  9. #9  
    worked like a charm THANKS!
  10. #10  
    Okay so got Preware installed, and ran the Emergency Migration Helper and then let the phone sit for an hour. Still can't install any apps from the app catalog.
    Developer must watch videos by Douglas Crockford of Yahoo:
    The JavaScript Programming Language part 1/4
    Theory of the DOM 1/3
    Advanced JavaScript 1/3
  11. #11  
    Quote Originally Posted by Ty View Post
    I had this issue and just found the solution on this thread, first post:

    forums.precentral.net/palm-pre/221344-official-webos-1-3-5-issues.html

    If you have Preware installed (I did). You need to use WebOS Quick Install to remove Preware and Package Manager Service. Then reinstall them both. Run Preware, search list of everything for Emergency Migration Helper. Install it and let it restart Luna. You're fixed. You can update your apps.

    Worked perfectly for me. Gotta love Preware and the guys at WebOS Internals!



    Where do you find the Preware and Package Manager Service to install to the phone?
  12.    #12  
    Quote Originally Posted by CJ3152 View Post
    Where do you find the Preware and Package Manager Service to install to the phone?
    Use WebOS Quick Install to install preware and Package Manager Service.
    Then install Emergency Migration Helper.
  13. #13  
    I thought this board had a search feature, but I get proven wrong daily.
  14. bobwill's Avatar
    Posts
    145 Posts
    Global Posts
    148 Global Posts
    #14  
    Quote Originally Posted by bobwonderful View Post
    The other problem I have is that if I tried to install it there is no way I can get rid of the icons with the ! on the cards view as it doesn't show up in the apps for deletion.
    Hold down the "Orange" key on the keyboard and tap the icon that you want to delete..
    Palm Pre OS 1.4.5 500/1000 MHz--Provider:Sprint
  15. #15  
    Thanks for the info again...as always,
  16. #16  
    I've been having the same trouble as others have reported with the app catalog, since my Pre updated to 1.3.5 without warning me. I've uninstalled and reinstalled PMS, PreWare, Diffstat, GNUpatch, and run EMH (multiple times and in many combinations/orders)- and all of the patches and themes and Preware and all are working fine - but the app catalog still doesn't work. I removed all patches/themes before updating to 1.3.5.1, but I still can't get the app catalog to work. Halp!

    Rebecca
  17. spyre's Avatar
    Posts
    34 Posts
    Global Posts
    43 Global Posts
    #17  
    Emergency Migration Helper did the trick for me! Thanks!
  18. #18  
    I'm trying to reinstall the patch for 4X4 icons V3 and it fails.

    The Postinst contains the following:
    patching file usr/lib/luna/system/luna-applauncher/app/controllers/launcher-assistant.jsjsjs
    Hunk #2 succeeded at 93 (offset -1 lines).
    Hunk #3 FAILED at 341.
    Hunk #4 succeeded at 446 (offset -101 lines).
    1 out of 4 hunks FAILED -- saving rejects to file usr/lib/luna/system/luna-applauncher/appcontrollers/launcher-assistant.jsjsjs.$rej$
    patching file usr/lib/luna/system/luna-applauncher/stylesheets/launcher.css
    Hunk #1 FAILED at 125
    1 out of 1 hunk FAILED -- saving rejects to file usr/lib/luna/system/luna-applauncher/stylesheets/launcher.css.rej
    Removing package org.webosinternals.patches.app-launcher-4x4-icons-v3 from root...

    I'm new to smart phones and updated to 1.3.5.1 without removing the patches and applications I had loaded using preware. I've tried re-installing preware, I've run EPR, I've run Emergency Migration Helper, I've done a Partial Erase and none of these have solved the problem. Has anyone else run into this problem? Does anyone know how to fix this problem?
  19. sayersttu's Avatar
    Posts
    2 Posts
    Global Posts
    3 Global Posts
    #19  
    Emergency Migration Helper worked for me too. Thanks man!

Posting Permissions