Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 46
  1. #21  
    I concur that is the best fix. Hopefully Palm will find the problem. I looked in the calendar files trying to find a reference to 2010 but cant find it yet. Trying to see if that would fix it.
  2. #22  
    Thanks for looking into this. I would not expect any references to a hard-coded value of 2010. My guess is that the problem is something like a bad calculation, for example subtracting two dates without taking into account the year and getting a negative result. This negative result would cause an exception to occur while rendering the calendar entries causing nothing to be displayed.

    I have not used any of the developer tools. Are there any debug logs that would contain exception traces or possibly
  3. mhemmes's Avatar
    Posts
    12 Posts
    Global Posts
    24 Global Posts
    #23  
    This fix does work! Good job community! One note however, once you do this (without rebooting) the network time option seems to be stuck waiting for the network time and time zone if you try to go back to network time. To me this is not that big a deal, although I prefer network time. Just thought I'd let you guys know.

    It also fixes the glitch sliding effect that started with this issue as seen in the screenshot:


    Quoted from my post at Palm.com:
    "One other thing I noticed, is a new bug in the way the calendar slides in day view. Rather then the smooth transition it used to do, it now starts the next day sliding in off frame of the scene, with a big grey space in the header, then (in a glitch like manor) it snaps in to place, with nothing I have scheduled shown."
    Last edited by mhemmes; 01/01/2010 at 06:14 PM.
  4. #24  
    Quote Originally Posted by mhemmes View Post
    This fix does work! Good job community! One note however, once you do this (without rebooting) the network time option seems to be stuck waiting for the network time and time zone if you try to go back to network time. To me this is not that big a deal, although I prefer network time. Just thought I'd let you guys know.
    With Network time turned back on, try and put the phone in Airplane mode for a little bit and then turn Airplane mode back off. That worked for me.
  5. mhemmes's Avatar
    Posts
    12 Posts
    Global Posts
    24 Global Posts
    #25  
    Quote Originally Posted by meandmypre View Post
    With Network time turned back on, try and put the phone in Airplane mode for a little bit and then turn Airplane mode back off. That worked for me.
    Indeed it does, and the issue stays fixed. Thanks meandmypre.

    P.S. Happy New Year!
  6. #26  
    Quote Originally Posted by meandmypre View Post
    I noticed this behavior as well. This seems to be the best workaround for this problem so far.

    1. Go to Date & Time and turn off Network time.
    2. Change the Date to Dec 31 2009 and make sure your calendar entries show up in the calendar
    3. Change the Date to the correct date - Jan 1 2010 and the calendar entries remain in the calendar


    Unfortunately, when you reset/reboot the phone, the entries disappear again.
    Just confirmation that this is what Palm support told me to do when I spoke to them on the phone today. Thanks, meandmypre!
  7. #27  
    Quote Originally Posted by yellow View Post
    I also can confirm this issue and "fix" thanks for the info.
    Yup, same here..... fix of removing Exchange account, then a manual sync and everything pops back up on my calendar. Damn, more Exchange bugs.

    Let's hope a fix is issued with webOS 1.4 + full GPU/OpenGL support! - But as far as ppl needing their calendars, that bug fix should be issued like..Monday.
  8. #28  
    The above work around has also worked for me. Just a heads up, when changing the date to 12/31/09, change to 2009 first. I changed month to December and it immediately tried to process all the alarms through 12/01/10.
  9. ksom's Avatar
    Posts
    355 Posts
    Global Posts
    358 Global Posts
    #29  
    I did the stupid thing, I tried to remove my exchange before I checking this forum.

    Well, it is taking some time to remove the account. Now I have to find my exchange setting again.

    I think for this problem alone, Palm need to put out a 1.3.6 really quick.
    Palm V -> Treo 600 (lost) -> Treo 650 -> Centro -> Pre -> Photon
  10. #30  
    The fix is not working on my Pre. I do not use Exchange. All my info is on the Palm profile or Google. Any other thoughts? Calendar was there and functioning until after 5pm today. As a matter of fact, even when the calendar was blank tonight, I still got my pop up calendar reminders despite the fact the actual calendar was blank. Maybe go to sleep and wake up with a hope and a prayer?
    Last edited by deanandbek; 01/01/2010 at 10:52 PM. Reason: adding to it
  11. ksom's Avatar
    Posts
    355 Posts
    Global Posts
    358 Global Posts
    #31  
    I just tried the fix and it did not work. After changing the date, it seems Pre was trying to pull in more events, but the wrong date upset my other email accounts. I keep getting certification errors. And calendar started keeping sending notifications of a scheduled event.

    I tried to change the date setting back to network, but it never completed. I think the problem there was the notifications took a lot of resources of Pre.

    Eventually I did a reset and looks like the date setting did change and I got the dates back.

    Anyway, I am not sure if this is because I have removed my exchange account once, but I just want to point out there are some risks with the workaround also.
    Palm V -> Treo 600 (lost) -> Treo 650 -> Centro -> Pre -> Photon
  12. #32  
    Quote Originally Posted by ksom View Post
    I just tried the fix and it did not work. After changing the date, it seems Pre was trying to pull in more events, but the wrong date upset my other email accounts. I keep getting certification errors. And calendar started keeping sending notifications of a scheduled event.
    When you change the date, it's recommended to change the year to 2009 first to avoid the flood of calendar notifications. After changing the year, you can change the month to December. The calendar should begin to show Exchange events within a minute, but be patient.

    Quote Originally Posted by ksom View Post
    I tried to change the date setting back to network, but it never completed. I think the problem there was the notifications took a lot of resources of Pre.
    Re-enabling network time does not seem to complete even when the time has not changed. It just gets stuck "waiting for network time..." The same behavior exists when attempting to enable network time zone after disabling it.

    I've been able to get network time (and network time zone) re-enabled successfully by turning on airplane mode, waiting a little bit, and then turning airplane mode off. It appears as though the cell network must transmit the network time information when the phone connects to the network.
  13. PGAv8tor's Avatar
    Posts
    5 Posts
    Global Posts
    7 Global Posts
    #33  
    Quote Originally Posted by mamouton View Post
    It appears to be a bug for today only. I changed date to 12/31/09 and they showed up I then changed date to 1/2/2010 and all my events showed up including exchange. I will do further testing to confirm.

    Edit: The events will show up if you change to the 12/31/09 and then you can go back to today. As long as you don't restart your phone all your events will show. Upon restart the problem shows back up.
    This worked for me!!!
  14. #34  
    I have noticed that a luna restart doesn't re-trigger the bug only a reset.
  15. reissc1's Avatar
    Posts
    46 Posts
    Global Posts
    55 Global Posts
    #35  
    Is anyone able to enter new calendar events? I did the fix and got my events back, but I still can't enter anything new.
  16. #36  
    This is what I found on several threads, and it definitely worked for my EAS calendar:

    1. Go to Date & Time and turn off Network time.
    2. Change the Date to Jan 2 2009 (just change the year)
    3. Launch calendar. Your entries should now be visible
    4. Change the Date to the correct date - Jan 2 2010
    5. Launch calendar again to verify that entries are still showing up
    6. Switch network time back on
    7. When "Waiting for Network" appear, switch to airplane mode
    8. Turn airplane mode off, and network time should connect
    9. Launch calendar again and it should be all good

    Note that if you need to turn off your Pre, you will need to do this all over again.

    Good luck!
  17. #37  
    Quote Originally Posted by dellibedaboss View Post
    Yup, same here..... fix of removing Exchange account, then a manual sync and everything pops back up on my calendar. Damn, more Exchange bugs.

    Let's hope a fix is issued with webOS 1.4 + full GPU/OpenGL support! - But as far as ppl needing their calendars, that bug fix should be issued like..Monday.
    Better not take until 1.4! I expect a patch for this within days. This is an ENORMOUS bug that needs to be dealt with immediately.
    Neopoint 1000, I300, Treo 300, i330, Toshiba 2032, Treo 600, T608/UX50, I500,Treo 600, G1000, Treo 650, PPC-6600, PPC-6700, Treo 650, Blackberry 7250, Treo 700wx, Motorola Q, PPC-6800, 700wx, Motorola Q9c, Sprint Touch, Sprint ACE, 700wx, 800w, Touch Pro, 800w, Touch Diamond, 800w, Treo Pro, Palm Pre, HTC Hero, Palm Pre, EVO 4G warm2.2
  18. #38  
    The work around ultimately brought calendar entries back into view for me this morning. I did notice that with the phone connected to the network turning off "network time" seemed to cause the manual date setting to freeze up and then change erratically. This caused the looping notifications as others have reported. After I removed the battery and put the phone into "Airplane Mode" disabling the "network time" and "network timezone" and resetting the date to 12/31/09 brought calendar entries back into view.

    So I suggest that anyone who has not tried this yet try this modification of the "workaround".

    Turn on "Airplane Mode"
    Go to Date & Time and turn off Network time.
    Change the Date to Dec 31 2009 and make sure your calendar entries show up in the calendar
    Change the Date to the correct date - Jan 1 2010 and the calendar entries remain in the calendar
    Turn off Airplane Mode
    Until Palm offers a real fix you'll need to do this anytime the Pre reboots.
  19. #39  
    FWIW folks, I checked my calendar yesterday, and all of my appointments from EAS show up just fine. Perhaps it was a week 53/1 issue, that "fixed itself" on Saturday?

    To repeat, I did not play w/ my phone's date, just waited until Saturday to look at it and all was well.
  20. #40  
    Quote Originally Posted by insane42 View Post
    FWIW folks, I checked my calendar yesterday, and all of my appointments from EAS show up just fine. Perhaps it was a week 53/1 issue, that "fixed itself" on Saturday?

    To repeat, I did not play w/ my phone's date, just waited until Saturday to look at it and all was well.
    you are a random lucky person. The vast majority of us were leaping back to 2009 to apply this band-aid, and getting many reminders once again. Very annoying, and makes you want to hate palm. The excitement of the possible fixes of 1.3.5 quickly got overshadowed by the royal Exchange screw up.
Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions