Results 1 to 17 of 17
  1.    #1  
    Well 1.3.5 fixed a lot of stuff but still not this problem. Restarted my Pre 1 day 19 hours and 7 minutes ago and the clock is now two minutes ahead.

    I really wish this could get fixed...
  2. #2  
    I know part of the problem was that Network Time only synced on boot-up. I don't know if that's been fixed. But the real problem is that the RTC on the Pre absolutely sucks, and that's unfortunately something that no software update can fix.
    Treo 300 > Hitachi G1000 > PPC-6700 > PPC-6800 (Mogul) > PPC-6850 (Touch Pro) > Palm Pre & HTC EVO Optimus V
  3. #3  
    Mine seems to be ok now.
  4. #4  
    Quote Originally Posted by dbd View Post
    Mine seems to be ok now.
    Interesting. Mikey, do you have Network Time enabled?
    Treo 300 > Hitachi G1000 > PPC-6700 > PPC-6800 (Mogul) > PPC-6850 (Touch Pro) > Palm Pre & HTC EVO Optimus V
  5. #5  
    Before it used to rarely pull network time, but after the update two days ago it set the time. Now it's 3 minutes fast. ***?!? You can buy a junk digital watch at a dollar store that keeps better time than a $200 "smart" phone that's connected to a cell phone and data network. Lame.
  6. a2k
    a2k is offline
    a2k's Avatar
    Posts
    103 Posts
    Global Posts
    111 Global Posts
    #6  
    Same problem here, damn thing is 15 minutes fast on my end!!!!
  7. #7  
    I have never had time issues. Not sure why you guys are having it unless the local network time on the towers is messed up
  8. #8  
    I wonder what area you guys live in and what your tower strengths are like.....cause I have never had this issue with my PRE or any phone I have ever had on Sprint.
  9.    #9  
    Quote Originally Posted by deihmos View Post
    If you don't have network time enabled you could have that problem. Never had an issue like that before.
    Yep have that enabled and I have good signal strength at home and around town.

    The only thing that re-syncs the phone is putting the phone into Airplane Mode for a minute then taking it out. This forces the phone to re-sync the time from Sprint.

    How often should the phone re-sync the time with Sprint as a normal course? I have my laptops setup to do network time and they get it once a day (and log the fact that they got it), I wonder if there is any way this can be done (or perhaps is already done) on the Pre?
  10. #10  
    Quote Originally Posted by FesterTreo View Post
    I have never had time issues. Not sure why you guys are having it unless the local network time on the towers is messed up
    Seems O2 (in the UK anyway) don't support network time zone and not even network time on the 3G network so we never have a reliable clock. No matter what settings we use (1.3.1 only at the moment of course) we get the occasional pop-up 'Network Time Zone unavailable', even with network time zone disabled.

    My clock varies from running fast some days to running slow others (mostly fast though) and is rarely less that 10 minutes out. What we need is an NTP client which can poll the internet and adjust the system clock and completely switch off all attempts to connect to a network clock for time or timezone. Assuming setting the system clock is accessible from the SDK it should be a fairly trivial app for an experienced developer.
  11. a2k
    a2k is offline
    a2k's Avatar
    Posts
    103 Posts
    Global Posts
    111 Global Posts
    #11  
    It's very strange. For me it all began after 1.3.5.
  12. RB26's Avatar
    Posts
    41 Posts
    Global Posts
    52 Global Posts
    #12  
    I had this problem starting with 1.3.1; Still happening now. Currently is 7 minutes off.


    Quote Originally Posted by Mikey47 View Post
    The only thing that re-syncs the phone is putting the phone into Airplane Mode for a minute then taking it out. This forces the phone to re-sync the time from Sprint.
    Thanks for this info, worked for me.
  13. #13  
    Add me to the list of those suffering from inaccurate time on my Pre.
  14. #14  
    The way I deal with this is to periodically open up the Terminal app and execute this command:

    Code:
    ntpdate -u pool.ntp.org
    Even after they fix network time, I'm leaving it disabled. Too much battery drain.
    Treo 300 > Hitachi G1000 > PPC-6700 > PPC-6800 (Mogul) > PPC-6850 (Touch Pro) > Palm Pre & HTC EVO Optimus V
  15. timmo's Avatar
    Posts
    98 Posts
    Global Posts
    167 Global Posts
    #15  
    I'm having this problem as well. I think it started at least a week ago, maybe even longer when 1.3.5 came out. This is messing up my meetings, etc.
  16. #16  
    I checked mine a few minutes ago and it was four minutes off. I tried setting it to my pc's clock at 1:00am. 19 seconds later it was 1:01am...just a tad bit on the ridiculous side.
  17. #17  
    strange....

Posting Permissions