Page 7 of 14 FirstFirst ... 23456789101112 ... LastLast
Results 121 to 140 of 274
  1. rayln's Avatar
    Posts
    215 Posts
    Global Posts
    239 Global Posts
    #121  
    Quote Originally Posted by LittleCZR View Post
    Ok, should i uninstall the patch now? hopefully some one fixes it.
    yes, might as well uninstall it.
    although you might like to modify it to sustain the SmartReflex power saving/voltage monitoring solution.
  2. #122  
    can i just take a minute to say thanks to everyone who has been chiming in here. i've learned a lot since being in this forum, and this thread seems especially enlightening.

    thanks
  3. #123  
    I found a permanent fix for 600. But this is for the brave.

    This new LunaSysMgr binary will instead reset the CPU speed to 600 instead of 500. I found it to be indeed setting the CPU.

    For those with some basic Linux skillz can copy /usr/bin/LunaSysMgr to a safe place the replace it with this new binary. make sure its executable. reboot phone or restart Luna. you should see it stay at 600 forever or until next update from Palm.

    standard disclaimer applies... bla bla bla.
    Last edited by unixpsycho; 12/30/2009 at 02:57 PM. Reason: ooops
    Live free or DIE!
  4. #124  
    Since the sf600 patch was not working i ran webosdoctor (1.3.1)to have a fresh install and decided to check the cpu speed and this is what i got.

    root@palm-webos-device: cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state
    600000 0
    550000 533
    500000 31723
    250000 0
    125000 0
    root@palm-webos-device:

    I then heard that webosdoctor 1.3.5 was out and decided to install sf600 on 1.3.1 and then run the test on the 1.3.1 with sf600 and this is what i got.

    root@palm-webos-device: cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state
    600000 13120
    550000 528
    500000 276
    250000 0
    125000 0
    root@palm-webos-device:

    is this how it has to look like in 1.3.5?
  5. rayln's Avatar
    Posts
    215 Posts
    Global Posts
    239 Global Posts
    #125  
    Quote Originally Posted by LittleCZR View Post
    Since the sf600 patch was not working i ran webosdoctor (1.3.1)to have a fresh install and decided to check the cpu speed and this is what i got.

    root@palm-webos-device: cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state





    root@palm-webos-device:

    I then heard that webosdoctor 1.3.5 was out and decided to install sf600 on 1.3.1 and then run the test on the 1.3.1 with sf600 and this is what i got.

    root@palm-webos-device: cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state





    root@palm-webos-device:

    is this how it has to look like in 1.3.5?
    yes.
  6. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #126  
    Quote Originally Posted by unixpsycho View Post
    I found a permanent fix for 600. But this is for the brave.

    This new LunaSysMgr binary will instead reset the CPU speed to 600 instead of 500. I found it to be indeed setting the CPU.

    For those with some basic Linux skillz can copy /usr/bin/LunaSysMgr to a safe place the replace it with this new binary. make sure its executable. reboot phone or restart Luna. you should see it stay at 600 forever or until next update from Palm.

    standard disclaimer applies... bla bla bla.

    pm me for the file. dont want to make it public yet.
    What did you do? Grag LunaSysMgr from 1.3.1, or do some neat binary editing?
  7. #127  
    Quote Originally Posted by unixpsycho View Post
    I found a permanent fix for 600. But this is for the brave.

    This new LunaSysMgr binary will instead reset the CPU speed to 600 instead of 500. I found it to be indeed setting the CPU.

    For those with some basic Linux skillz can copy /usr/bin/LunaSysMgr to a safe place the replace it with this new binary. make sure its executable. reboot phone or restart Luna. you should see it stay at 600 forever or until next update from Palm.

    standard disclaimer applies... bla bla bla.

    pm me for the file. dont want to make it public yet.
    Are you using it? let us know if you run in to any problems.
  8. #128  
    Quote Originally Posted by angiest View Post
    What did you do? Grag LunaSysMgr from 1.3.1, or do some neat binary editing?
    you know it! hehe binary edit.

    I am using it now. and rebooted quite a few times.

    if you want to use SR as well then you'll have to keep SR patch. This just makes sure Luna keeps the CPU at 600.
    Live free or DIE!
  9. a2k
    a2k is offline
    a2k's Avatar
    Posts
    103 Posts
    Global Posts
    111 Global Posts
    #129  
    Quote Originally Posted by unixpsycho View Post
    you know it! hehe binary edit.

    I am using it now. and rebooted quite a few times.

    if you want to use SR as well then you'll have to keep SR patch. This just makes sure Luna keeps the CPU at 600.
    Thanks, I PM'd you.

    So to make sure I understand. In order to keep it to clock 1.3.5 to 600 with SR, we...

    1. Replace the LunaMgr with your file.
    2. Install the SR600 patch.

    Those two steps should take care of it?
  10. #130  
    Quote Originally Posted by a2k View Post
    Thanks, I PM'd you.

    So to make sure I understand. In order to keep it to clock 1.3.5 to 600 with SR, we...

    1. Replace the LunaMgr with your file.
    2. Install the SR600 patch.

    Those two steps should take care of it?
    Make a copy of the original LunaSysMgr file 1st.

    then just make sure the new LunaSysMgr is executable.

    test it by pkill LunaSysMgr.

    WARNING: I recommend doing this only via novacom within Linux or Windows.

    If you want SR600 then install the patch. I assumed everyone had the patch already installed and was happy at least running at 500 with it.
    Live free or DIE!
  11. #131  
    Quote Originally Posted by unixpsycho View Post
    Make a copy of the original LunaSysMgr file 1st.

    then just make sure the new LunaSysMgr is executable.

    test it by pkill LunaSysMgr.

    WARNING: I recommend doing this only via novacom within Linux or Windows.

    If you want SR600 then install the patch. I assumed everyone had the patch already installed and was happy at least running at 500 with it.
    Maybe you can give a step by step on how to install it once it's polished? And also will it work with Smartflex 600? is that what SR600 means?
  12. #132  
    Quote Originally Posted by LittleCZR View Post
    Maybe you can give a step by step on how to install it once it's polished? And also will it work with Smartflex 600? is that what SR600 means?
    I have to reiterate this can hose up your phone if done wrong.

    Also to be safe do this from within novacom in Windows or Linux so you still have access to the CLI in the event something is missed, and you can test without worry.

    Yes this works with the Smartreflex patch (SR600). I am using it now.

    Send the file to the phone to /tmp/LunaSysMgr.new via WebOS Quick Install, scp, ftpget or whatever method.

    Get to a command line (use noacomm in Windows/Linux instead of CLI from Pre):
    mount -o remount,rw /
    cd /usr/bin/
    mv LunaSysMgr LunaSysMgr.orig
    mv /tmp/LunaSysMgr.new LunaSysMgr
    chmod +x LunaSysMgr
    sync
    mount -o remount,ro /
    pkill LunaSysMgr

    you should see your Pre cycle and the UI comes up, if not then something is wrong.

    since you are still at the command line check /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state or /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
    both should indicate 600 is being used.
    Live free or DIE!
  13. #133  
    Don't forget that distributing modified Palm binaries is a copyright violation.

    You should distribute the instructions for an end user to modify their own copy of the file instead.

    (Note that I take no position on the safety, stability or efficacy of the modification in question)

    -- Rod
  14. #134  
    Quote Originally Posted by rwhitby View Post
    Don't forget that distributing modofied Palm binaries is a copyright violation.

    You should distribute the instructions for an end user to modify their own copy of the file instead.

    (Note that I take no position on the safety, stability or efficacy of the modification in question)

    -- Rod
    good point.
    Live free or DIE!
  15. #135  
    this is unrelated to the thread, but I can't get novaterm to work with 1.3.5, I have no idea why... Novacomd/webosQI work fine, but novaterm refuses to work
  16. #136  
    Quote Originally Posted by xstaticxgpx View Post
    this is unrelated to the thread, but I can't get novaterm to work with 1.3.5, I have no idea why... Novacomd/webosQI work fine, but novaterm refuses to work
    what error do you get?

    i use /opt/Palm/novacom/novacom -t open tty://
    Live free or DIE!
  17. #137  
    Quote Originally Posted by rayln View Post
    yes, might as well uninstall it.
    although you might like to modify it to sustain the SmartReflex power saving/voltage monitoring solution.
    How does one truly uninstall the patch? I'm not seeing it in WebOS QI or Preware.
    Palm Pre | WebOS 1.4.1.1 | Sprint
    My CarDomain - 5/30/09
  18. #138  
    Quote Originally Posted by unixpsycho View Post
    what error do you get?

    i use /opt/Palm/novacom/novacom -t open tty://
    Ok, well when I run novaterm (as su ofcourse), i get the following:

    Code:
    $  sudo /opt/Palm/novacom/novaterm 
    Novacom found: bulk_ep_in: 0x82 bulk_ep_out: 0x02
    
    Read 96 bytes - success!
    Got announcement
    Sending announcement
    Writing packet of 72 bytes
    Opening terminal
    Writing packet of 60 bytes
    Read 96 bytes - success!
    Got announcement
    Sending announcement
    Writing packet of 72 bytes
    Opening terminal
    Writing packet of 60 bytes
    Read 96 bytes - success!
    Got announcement
    Sending announcement
    Writing packet of 72 bytes
    Opening terminal
    Writing packet of 60 bytes
    Read 48 bytes - success!
    Processing PMUX packet
    Got ack for 1
    Sending -t
    Writing packet of 55 bytes
    Read 48 bytes - success!
    Processing PMUX packet
    Got ack for 1
    Going to wait ok state
    Read 48 bytes - success!
    Processing PMUX packet
    Got ack for 1
    Read 48 bytes - success!
    Processing PMUX packet
    Got ack for 1
    Read 70 bytes - success!
    Processing PMUX packet
    Got response: 'unrecognized command
    '
    Sending ack
    Writing packet of 48 bytes
    Closing terminal
    Writing packet of 60 bytes
    Writing packet of 60 bytes
    Closing
    Read 48 bytes - success!
    Processing PMUX packet
    Got ack for 2
    Read 48 bytes - success!
    Processing PMUX packet
    Got ack for 3
    I'm guessing the part in bold is where it's bombing out, but I seem to remember always seeing that even when it did work.

    with the command you're using...

    Code:
    $  sudo /opt/Palm/novacom/novacom -t open tty://
    failed to connect to server
    DevMode is enabled.

    **EDIT

    I tried using a novacom binary that I compiled myself from git, and I get a different output than the Palm compiled novacom binary - It still doesn't work though :/

    Code:
    $  sudo ./novacom -t open tty://
    Novacom found: bulk_ep_in: 0x82 bulk_ep_out: 0x02
    
    Read 61 bytes - success!
    Got NOP: id_tx=4542adfd, id_rx=4ae1
    Not sending NOP reply -- waiting for announce
    Read 61 bytes - success!
    Got NOP: id_tx=4542adfd, id_rx=4ae1
    Not sending NOP reply -- waiting for announce
    Read 96 bytes - success!
    Got announcement
    Sending announcement
    Writing packet of 72 bytes
    Opening terminal
    Writing packet of 60 bytes
    Read 96 bytes - success!
    Got announcement
    Sending announcement
    Writing packet of 72 bytes
    Opening terminal
    Writing packet of 60 bytes
    Read 48 bytes - success!
    Processing PMUX packet
    Got ack for 1
    Sending -t
    Writing packet of 55 bytes
    Read 48 bytes - success!
    Processing PMUX packet
    Got ack for 1
    Going to wait ok state
    Read 70 bytes - success!
    Processing PMUX packet
    Got response: 'unrecognized command
    '
    Sending ack
    Writing packet of 48 bytes
    Closing terminal
    Writing packet of 60 bytes
    Writing packet of 60 bytes
    Closing
    Read 48 bytes - success!
    Processing PMUX packet
    Got ack for 3
  19. #139  
    Quote Originally Posted by xstaticxgpx View Post
    Ok, well when I run novaterm (as su ofcourse), i get the following:

    Code:
    $  sudo /opt/Palm/novacom/novaterm 
    Novacom found: bulk_ep_in: 0x82 bulk_ep_out: 0x02
    I dont use sudo or root to use novaterm. not sure that it matters?

    Is novacomd running on your system?
    Live free or DIE!
  20. #140  
    Quote Originally Posted by unixpsycho View Post
    I dont use sudo or root to use novaterm. not sure that it matters?

    Is novacomd running on your system?
    You're removable device permissions must be different (or something) for you not to run it as root, I get permission errors if I don't. When novacomd is running it gives me...
    Code:
    Error claiming interface 1: -16
    Like i said, novacomd and webOSQI work fine - but I can no longer get to the phones linux shell except through the Terminal app on the phone (i dont have ssh setup either because I cant novacom/novaterm)
Page 7 of 14 FirstFirst ... 23456789101112 ... LastLast

Posting Permissions