Results 1 to 8 of 8
  1.    #1  
    1. Because Google Maps on the pre is fully web based (as if you'd browse to maps.google.com) it does no caching whatsoever. so every time i start it, it takes at least 10 seconds to load the interface and map - when i have a decent connection! Even with my really old WM-Smartphone, i could see the last map section and even the cached map data around and i could access the interface.

    2. The map does not follow my location when driving

    Both issues are really really annoying...besides already mentioned issues like no favorites, no latitude etc.

    Sorry, just wanted to complain...
  2. #2  
    Hmm... Google maps follows my location quite nicely when I'm driving. Almost like it better than Sprint Navigation.

    jim
  3. #3  
    Quote Originally Posted by claude View Post
    1. Because Google Maps on the pre is fully web based (as if you'd browse to maps.google.com) it does no caching whatsoever. so every time i start it, it takes at least 10 seconds to load the interface and map - when i have a decent connection! Even with my really old WM-Smartphone, i could see the last map section and even the cached map data around and i could access the interface.

    2. The map does not follow my location when driving

    Both issues are really really annoying...besides already mentioned issues like no favorites, no latitude etc.

    Sorry, just wanted to complain...
    i agree
  4. #4  
    Google Maps on the Pre is inexcusable. Google seemed at first to be fully supportive of the Pre. It was going to be so easy to program for this phone they said. BS. The google maps on this phone SUCKS. Flat out sucks. There are NO features like what you would find on WinMo, iPhone, Android, even Blackberry. And why not? Its SO GOSH DARN EASY to write an app for this phone, right? All we have for google maps is a stupid web interface for an app. Google apparently isn't going to change this, they have android to care about now. I wouldn't count on it changing anytime soon, if ever. And this is probably one of my biggest complaints about this phone. Its stupid, it sucks, it really really really ****es me off that google has done not a damn thing for webos since it launched. Too bad I use almost every other service they have I guess.....
  5. #5  
    I am not having the same issues you are with Google maps. But, I also use Sprint Nav too.

    Since I have never had an iPhone, Blackberry or Android phone, what exactly is the WebOS version missing other than being a web based app?
  6. ipixel's Avatar
    Posts
    9 Posts
    Global Posts
    11 Global Posts
    #6  
    I have a problem with my google maps, when I'm at my house the location it has me at is like 7 blocks away and when in the car moving it doesn't follow, it used to, but idk what's wrong.
  7. #7  
    Quote Originally Posted by ipixel View Post
    I have a problem with my google maps, when I'm at my house the location it has me at is like 7 blocks away and when in the car moving it doesn't follow, it used to, but idk what's wrong.
    Have you tried Tapping the Button bottom right, after it turns Blue, to get it to 'follow' you?

    Go to the 'Location Services' app and make sure to set it to ask first to use GPS. That way, when you launch Google Maps you can make sure it is using GPS to locate you. It sounds from your problem that it is using Phone Masts to work out your location ?
    Thought of the day :
    No sense being pessimistic, it probably wouldn't work anyway
  8. japark's Avatar
    Posts
    211 Posts
    Global Posts
    331 Global Posts
    #8  
    Use GPS only. Turn off "Use Google Services" in location services.

    I get a precise location when using GPS. With Google services on, google maps thinks I am in Oxford, Miss. instead of Jackson, TN.

Posting Permissions