Results 1 to 4 of 4
  1. Dew
    Dew is offline
    Dew's Avatar
    Posts
    69 Posts
    Global Posts
    72 Global Posts
       #1  
    Last night when loading the camera on my Pre, I got a black screen with lots of weird looking lines in different colours.

    So I Googled the problem and came up with a solution to fix it by restarting the phone by turning the ringer switch on and off three times while holding down the power button. It did the trick. I loaded up the camera, took some photos and went to bed.

    When I woke up today and checked the camera again, I discovered that the camera won't load at all. This time, instead of displaying the black screen with coloured lines, I simply get the grey loading screen with the camera icon in the middle. Occassionally the black screen will pop up, which perhaps suggests that the app is trying to load but is unable to for some reason.

    I Googled again and discovered a lot of people have this problem (appearantly dubbed the "grey screen of death"). Unfortunately I couldn't find any solution that I haven't already tried short of resetting my phone, which a lot of the people say doesn't work anyway.

    I really, really do not want to get another replacement. My store (o2 UK) said that I would first have to send it for repair, which can take 2-3 weeks and if they can't fix it, they will replace it depending on whether the problem falls under my warranty or insurance. Having already replaced my Pre last month (after only a week of getting it) for a touchscreen problem, I cannot accept that I have to wait this long just because of a stupid camera. I just want my damn phone which I'm so much money for to work like it was meant to.

    So I would really appreciate if someone could kindly offer a possible solution to fix this camera problem and perhaps explain why it's occurred and whether it's a hardware or software problem.

    Thanks and I look forward to your answers.
    Staff Writer, Top10
    Twitter @Dew_Top10
  2. timo123451's Avatar
    Posts
    9 Posts
    Global Posts
    18 Global Posts
    #2  
    I had the same thing happen to mine. I ended up having to use the webos doctor to reload everything, its worked perfectly since then.
  3. Dic Doc's Avatar
    Posts
    50 Posts
    Global Posts
    52 Global Posts
    #3  
    I had a very similar problem, think I might have posted about it previously. In the end, there was no fix for it. Try removing the battery, waiting a minute, and then replacing it. That causes more of a hard reset. Next, try the Palm support webpage, although I am not sure if it is available in the UK.
    Regarding your concern with having to go without the phone for 3 weeks, that is not Palm's fault, that must be an O2 UK policy. Sprint in the US made me wait 2 days for a replacement refurbished phone, and I thought that was a long time. I had purchased insurance on the phone, but Sprint considered it a manufacturer's defect and replaced it without cost. So press your phone company more.
  4. Dew
    Dew is offline
    Dew's Avatar
    Posts
    69 Posts
    Global Posts
    72 Global Posts
       #4  
    Well regardless of O2 UK's ridiculous replacement policy, it doesn't stop Palm from sharing their part of the blame for the problem occurring in the first place. I've never had to replace a phone before and I'm potentially looking at a 2nd replacement for my Pre. I've heard of Pre owners in their 6th or 7th handsets, which is absolutely unacceptable.

    That said, I've already tried the battery trick and have restarted my phone countless times. I guess the only option left is to reset the phone with webOS Doctor. However, if anyone knows another fix for this problem, please let me know.
    Staff Writer, Top10
    Twitter @Dew_Top10

Tags for this Thread

Posting Permissions