Page 2 of 2 FirstFirst 12
Results 21 to 36 of 36
  1.    #21  
    but I just have another couple questions

    Here is what is happening and I am not sure if this has anything to do with the phone not working.

    Once it finishes the install, my pc reports a message that install not copleted. I tried to get another file, in case there were problems with the one I had but same thing. Also, under change settings there is only three ptions, Internet APN, net.bm and username and password. Is there anything else I could try. I really think there is hope, but of course, I am a dreamer.

    thanks in advance for your help.
  2. #22  
    Quote Originally Posted by bdagirl View Post
    but I just have another couple questions

    Here is what is happening and I am not sure if this has anything to do with the phone not working.

    Once it finishes the install, my pc reports a message that install not copleted. I tried to get another file, in case there were problems with the one I had but same thing. Also, under change settings there is only three ptions, Internet APN, net.bm and username and password. Is there anything else I could try. I really think there is hope, but of course, I am a dreamer.

    thanks in advance for your help.
    I'd try again if the non-doctored webos restore gave you an error, just to make sure...

    About the APN, yes, at this point it only allows for APN, User, Password. Try entering the stuff that tomi posted,
    APN:net.bm
    User: blank
    Pass: blank

    If this doesnt work, try (for some reason my pre only finds data if i use the wap gateway)

    APN: wap.bm
    User: blank
    pass: blank

    if it still doesnt show an E or 3G next to the signal bars, then these settings arent valid... i dunno where tomi got them from, but maybe your carrier can supply you a more current setting? (ask them for "EDGE or GPRS or 3G data connection settings - specifically APN and user/password)

    PS: i assume your account is provisioned for data... you had a working phone that could access the internet before? you could always switch back to that phone and check its connection settings...
  3. #23  
    Quote Originally Posted by tomi666 View Post
    Yes I know, so your location isn't in CarrierNetworkSettings.db3 either (what is your location and carrier) or is it? If it is, there's a simple trick of replacing your App Catalog with a previous one, and you'll at least have the free apps.
    Actually, from some threads on here, as well as that dump of the carriernetwork that was around it should be in there... and correctly too...

    Carrier: VIVO
    APN (correct for othe rphones): zap.vivo.com.br
    APN (only one that worked on pre - old wap gateway): wap.vivo.com.br
    U:vivo
    P:vivo

    (in my case, the difference with wap and zap is that zap gives you a public ip address on the net, and wap gives you a private nat'd or whatever address... In most uses it doesnt make a difference, but some stuff like voip, and some client/server stuff can fail... havent had any problems with the pre though)

    Can you point me to the trick for the free apps? Is it the one about getting the spring image and replacing the app catalog?
  4.    #24  
    thanks again
  5.    #25  
    Thanks Tomi,

    I keep getting cant write the settings. I am prepared to try it. Anything! We can always run webos doctor to reset it right?
    but I can manage it.
  6.    #26  
    Well, first you need root access and a working telnet client (e.g. Putty.


    heres instructions on how to root the pre..


    Download the WebOS image
    Rename this file to .zip, and extract it
    set the Konami code on your pre (upupdowndownleftrightleftrightbastart), and put it into dev mode. Plug it into your windows laptop after it's booted
    Run the driver installer from the extracted file, it is: webosdoctorp100ewwsprint/resources/NovacomInstaller_x86.msi
    Install Python 2.6
    Get the rooter from subversion: webos-dev - Revision 3: /trunk/rooter
    Run talk.py inside of the rooter in subversion, it'll output a bunch of lines. If you see an error, join the irc (irc.freenode.net #webos-internals)
    Turn on the wifi on your pre. Get your pre's IP address, and you can telnet into it (username: root)
    Run these commands in the shell

    Makes phone writeable.

    mount -o remount,rw /
    Creates file to run the backdoor to open telnet on boot.
    //irix edited the iptables to only allow on eth0 thanks irix.
    //eth0 is the WIFI link

    cat > /etc/event.d/backdoorscreen << EOF
    # -*- mode: shell-script; -*-
    # backdoorscreen

    description "backdoorscreen"

    start on stopped configure
    stop on runlevel [!2]

    exec screen -d -m /home/backdoorscreen.sh
    EOF
    Bash file to open up the iptables firewall to telnet and start telnet

    cat > /home/backdoorscreen.sh << EOF
    #!/bin/sh
    while `true`; do
    sleep 120
    /usr/sbin/telnetd
    iptables -i eth0 -D INPUT -p tcp --dport 23 -j ACCEPT
    iptables -i eth0 -I INPUT -p tcp --dport 23 -j ACCEPT

    done
    EOF
    Set permissions on the bash file

    chmod 755 /home/backdoorscreen.sh
    Make the file system read only again.

    mount -o remount,ro /
    Source:Portal:Accessing Linux - WebOS Internals via precentral.

    Thanks to irix also..
    __________________


    Hi Tomi,

    Can you please explain some of this for me:

    Download the WebOS image
    Rename this file to .zip, and extract it
    set the Konami code on your pre (upupdowndownleftrightleftrightbastart), and put it into dev mode. Plug it into your windows laptop after it's booted
    Run the driver installer from the extracted file, it is: webosdoctorp100ewwsprint/resources/NovacomInstaller_x86.msi
    Install Python 2.6
    Get the rooter from subversion: webos-dev - Revision 3: /trunk/rooter


    and when you say back up the files, will this command cover it. Sorry to be a bug?

    Once you are connected to your Pre using Putty, type
    cp /usr/lib/luna/CarrierNetworkSettings.db3 /media/internal. This will copy the database file to the internal storage.
    Put your Pre into USB disk mode and copy the database file to your machine.
  7.    #27  
    Tomi,

    I have not been able to pass the profile creation, so I am not able to get to the launcher, or card view. unless you can tell me how. If so, I would appreciate it. Once in there, I may get to preferences, and be in a position to set up my internet connection. Is this possible? Thanks again.
  8. Joene's Avatar
    Posts
    19 Posts
    Global Posts
    35 Global Posts
    #28  
    Hallo,

    Would it be possible to activate the german pre using manually entered settings in WebOS 1.3.1? (I mean: buy pre, flash it with the recovery tool to 1.3.1, enter APN settings and activate/create Palm profile)?

    I'm thinking about buying a german Pre, but before I take that 200 KM drive, I taught I figured out first if I would get it to work

    Thanks
  9. Joene's Avatar
    Posts
    19 Posts
    Global Posts
    35 Global Posts
    #29  
    I live in Belgium and my Carrier is Mobile Vikings (a small MVO that operates on the BASE network [they give you 1GB of free data per 15 euros of prepaid credit, best deal on the market]; has its own APN settings though). I still got a valid Proximus SIM laying around, so I could use that if needed to activate the pre. Nevertheless, the PRE's settings for Proximus I saw in the database file, are'nt correct.
  10. Joene's Avatar
    Posts
    19 Posts
    Global Posts
    35 Global Posts
    #30  
    Thanks for your help. I prefer going to a store and buy one myself, so I can ask things concerning warranty and stuff. I think I'll just wait a bit longer till the pre pops up in Belgium (if ever )
  11.    #31  
    I had a pc tech look at my phone, and with my luck I have been able to register my profile and get into the phone. I can put the phone into developer mode, etc, make calls and operate most things with the exception of data services. I even was able to get into the carrier database on my pc and note that M3Wireless is not in the list. Can you confirm what I need to get this information on my phone again. I will need to go back in, but if you could assist, it would be really appreciated.
  12.    #32  
    sorry still saying unable to write settings
  13. #33  
    My Carrier is also Mobile Vikings and I bought a second hand Pre in Germany who was already activated by the first user with the O2 operator...
    After putting my SIM card in the Pre I was able to make calls and send SMS without any problem (same thing with a Mobistar SIM) but I had to manually change the APN settings for DATA services.

    When you are in 1.3.1 changing the APN settings is easy, simply open the dialer app, click on your network on the top left for the menu, and choose preferences...here you can change network settings, scroll down and you will see an option "manual settings"...save and your done. Works like a charm

    So no need to recover/flash or whatever and why do you need to create a profile when you can sync with your PC or Mac ?

    Greetz,

    Quote Originally Posted by Joene View Post
    Hallo,

    Would it be possible to activate the german pre using manually entered settings in WebOS 1.3.1? (I mean: buy pre, flash it with the recovery tool to 1.3.1, enter APN settings and activate/create Palm profile)?

    I'm thinking about buying a german Pre, but before I take that 200 KM drive, I taught I figured out first if I would get it to work

    Thanks
    Quote Originally Posted by Joene View Post
    I live in Belgium and my Carrier is Mobile Vikings (a small MVO that operates on the BASE network [they give you 1GB of free data per 15 euros of prepaid credit, best deal on the market]; has its own APN settings though). I still got a valid Proximus SIM laying around, so I could use that if needed to activate the pre. Nevertheless, the PRE's settings for Proximus I saw in the database file, are'nt correct.
  14. Joene's Avatar
    Posts
    19 Posts
    Global Posts
    35 Global Posts
    #34  
    To get access to the app catalog?

    By the way, how's built quality on your pre?
  15. c_man's Avatar
    Posts
    392 Posts
    Global Posts
    393 Global Posts
    #35  
    Quote Originally Posted by Joene View Post
    To get access to the app catalog?

    By the way, how's built quality on your pre?
    There is a thread for this topic: http://forums.precentral.net/gsm-pre...d-quality.html
  16. Joene's Avatar
    Posts
    19 Posts
    Global Posts
    35 Global Posts
    #36  
    Quote Originally Posted by c_man View Post
    I know and I have read it.
Page 2 of 2 FirstFirst 12

Posting Permissions