I can't remember whether this was true before I upgraded to Web OS 1.3.1, but it appears to be the case now.

When I mute my Pre, calendar alerts still pop up on the screen, but they don't cause the phone to vibrate (so I usually miss them given that my phone is in my pocket). Incoming calls and messages still cause the phone to vibrate as expected.

When the phone is not muted, calendar alerts sound off as expected.

Is this a problem for anyone else?

My relevant settings are as follows:

Sounds & Ringtones > Ringer Switch Off > Rings & Alerts > Vibrate
Calendar > Preferences & Accounts > Event Reminders > Play sound > On