Results 1 to 18 of 18
  1. edtim48's Avatar
    Posts
    22 Posts
    Global Posts
    23 Global Posts
       #1  
    I had a standard Pre without any homebrew apps until the 1.3.1 update. After the update I installed the preware and started installing some homebrew apps and patches. Now I can sit and watch my battery drain within a couple hours and when I place it on the standard charger it takes longer to reach 100% if it does. Is there any particular patches that would cause this? What should I do or check?
  2. #2  
    You probably have a memory leak, restart the pre and see if it continues. If it does then you'll have to remove everything and try again.

    Chances are though it will stop, then you simply open one app at a time and see if it starts the drain, if it does restart and delete that app.

    I had a homebrew flashlight app which drained my phone really bad when I closed it.
  3. #3  
    I had experienced a similar problem. I'm guessing after installing patches some processes/tasks don't get terminated properly, if at all.

    For instance after installing about 16 patches on my pre I noticed that my wifi would not turn off by itself. If I don't shut it down manually my wifi connection stays on.

    What I would recommend is removing every single patch with Emergency Patch Removal and try installing one patch at a time and do a battery test to try to single out the patch which causes this.
  4. #4  
    Quote Originally Posted by Ayasinskiy View Post
    I had experienced a similar problem. I'm guessing after installing patches some processes/tasks don't get terminated properly, if at all.

    For instance after installing about 16 patches on my pre I noticed that my wifi would not turn off by itself. If I don't shut it down manually my wifi connection stays on.

    What I would recommend is removing every single patch with Emergency Patch Removal and try installing one patch at a time and do a battery test to try to single out the patch which causes this.
    Patches are less likely to contain an alteration which could cause a memory leak. It sounds like in your case you installed one of the Patches which keeps your wifi on by design, but this wouldn't be his problem anyway since he said he watches it drain, the wifi doesn't drain that fast and would always be on while the phone is active anyway.
  5. #5  
    Did you add a Yahoo account to your contacts? Many of us found that Yahoo was the culprit to serious battery drain in 1.3.1. Try removing the Yahoo account if you have one added.
  6. #6  
    Not necessarily. If you turn your wifi on and you are around a network that your pre is familiar with it will connect to that wireless signal. Then when the screen will go off if there is no active download/upload taking place the wifi radio will turn off. My wifi doesn't shut off automatically. It stays on.
  7. #7  
    correct, wifi turns OFF when screen is off. (switches to EV or 1X)

    if you want to leave it always on, only solution at the moment is hombrew app nodoze
  8. #8  
    I am having the same issue where wifi stays on even when the screen is asleep. Something seems to be preventing the Pre from going to sleep.
  9. edtim48's Avatar
    Posts
    22 Posts
    Global Posts
    23 Global Posts
       #9  
    I am trying the yahoo account delete, but I understand it is only the contact account that causes the drain. I am reinstalling the yahoo email accounts to see if there are any improvements.
  10. #10  
    this happened to me, too. I let it completely drain then charged it to 100. Doing this twicr recalibrated the phone and fixed things. My battery runs much better now too!
  11. #11  
    Quote Originally Posted by blatherdrift View Post
    this happened to me, too. I let it completely drain then charged it to 100. Doing this twicr recalibrated the phone and fixed things. My battery runs much better now too!
    That's bad for the battery. Recalibration hasn't been needed for cell phone and laptop batteries for quite some time.
  12. #12  
    blatherdrift:

    So, do you still have yahoo installed as one of your accounts? I find that with yahoo, my battery is draining exponentially faster than ever before!
  13. #13  
    I'm right there with you EdTim - other than I don't have any patches, just a bone stock Pre! My battery would go for two days and now i get no more than 3 hours, and I constantly get the too many cards open when there are none! And regarding the speedier apps opening - doesn't exist on mine. Prior to 1.3.1 I was about 2.8 seconds for any app to open, not i'm hovering right around the 5.0 - 5.3 seconds per app.........first time i've been disappointed!
    "The democracy will cease to exist when you take away from those who are willing to work and give to those who would not" Thomas Jefferson
  14. #14  
    Quote Originally Posted by trim81 View Post
    correct, wifi turns OFF when screen is off. (switches to EV or 1X)

    if you want to leave it always on, only solution at the moment is hombrew app nodoze
    Actually, you don't need nodoze. You can install the patch to turn off phone data. If phone data is off with wifi up, the wifi will stay up when the screen turns off.

    It would be a cool patch if switching data on/off were automatic based on whether wifi was up, or alternatively just don't turn off the wifi radio if you are connected to an AP. that should be the behavior in webos, IMHO.
  15. #15  
    Quote Originally Posted by KallDrexx View Post
    That's bad for the battery. Recalibration hasn't been needed for cell phone and laptop batteries for quite some time.
    I beg to differ. After the update, my battery was only lasting half as long as normal. I let it drain until the phone shut off twice, always fully charging the phone . After the second recharge, the battery drain stabilized and returned to normal. Not been an issue since.
  16. #16  
    I have a stock Pre and having battery issues. I've only had the phone a week but so far I have turned off location services, enabled wifi (at home and work), and use push exchange email.

    My battery around lunch time or shortly after is around 30% after leaving in the morning with a full charge. I can't explain it.
  17. #17  
    its not bad for the battery. It was something my phone needed to do. Ow it works fine again. Stop spreading misinformation. A drained battery is onlty bad if you let it stay drained for an extended period of time. Then your reserve charge can drain. You would see damage then.


    I don't use yim for anything. Im or synergy.
  18. #18  
    I just noticed my Pre kept switching back and forth between "searching...." and Spint for service.

Posting Permissions