webOS Nation Forums >  webOS Devices >  Palm Pre and Pre Plus > Confirmed manual Carrier/APN settings in webOS 1.3
Confirmed manual Carrier/APN settings in webOS 1.3
  Reply
 
Thread Tools Display Modes
Old 11/14/2009, 03:29 AM   #1 (permalink)
Member
 
Posts: 472
Just upgraded my German unlocked GSM Pre to webOS 1.3.1 (US) from webOS 1.2-Sprint, 'over the air'. 1.2 just said update available, and I clicked on update now. Device info now mentions: Palm webOS 1.3.1. , configuration Sprint 2.0. The phone preferences now has a Manual Settings entry. If enabled an Edit Network Settings entry appears. From that one, a form for an Internet APN and a MMS APN can be filled out.

After the update I did not have a 2G/3G data connection. I upgraded the manual settings for Tmobile-NL: APN internet Username tmobile Password tmobile . And it worked (have to 'save' these setting though, by going back to settings!) . I have 3G data again.

This leaves the question whether activation also has a opportunity for changing these setting . I don't know since the upgrade did not require a new activation.

Last edited by Dick99999; 11/14/2009 at 03:37 AM. Reason: Device config entry.
Dick99999 is offline   Reply With Quote
Old 11/14/2009, 04:49 AM   #2 (permalink)
Member
 
Tuborgmann's Avatar
 
Posts: 32
Quote:
Originally Posted by Dick99999 View Post
Just upgraded my German unlocked GSM Pre to webOS 1.3.1 (US) from webOS 1.2-Sprint, 'over the air'. 1.2 just said update available, and I clicked on update now. Device info now mentions: Palm webOS 1.3.1. , configuration Sprint 2.0. The phone preferences now has a Manual Settings entry. If enabled an Edit Network Settings entry appears. From that one, a form for an Internet APN and a MMS APN can be filled out.

After the update I did not have a 2G/3G data connection. I upgraded the manual settings for Tmobile-NL: APN internet Username tmobile Password tmobile . And it worked (have to 'save' these setting though, by going back to settings!) . I have 3G data again.

This leaves the question whether activation also has a opportunity for changing these setting . I don't know since the upgrade did not require a new activation.
Doesent work for me though, when i dial in my internet apn and pusk change settings i get "unable to write settings" error. And its not because the apn info is wrong, if you put in wrong info you get "invalid internet apn settings" error.
Tuborgmann is offline   Reply With Quote
Old 11/14/2009, 10:15 AM   #3 (permalink)
Member
 
Posts: 472
I'd think it would not make a difference, so just for recording the case, is your Pre Sim locked or unlocked? The only trouble I had on the first day is that the manual settings switched to OFF when changing form 3G to 2G only. But the APN setting were still there when switching it on again.
Dick99999 is offline   Reply With Quote
Old 11/14/2009, 10:56 AM   #4 (permalink)
Member
 
Tuborgmann's Avatar
 
Posts: 32
Quote:
Originally Posted by Dick99999 View Post
I'd think it would not make a difference, so just for recording the case, is your Pre Sim locked or unlocked? The only trouble I had on the first day is that the manual settings switched to OFF when changing form 3G to 2G only. But the APN setting were still there when switching it on again.
It is unlocked.
Tuborgmann is offline   Reply With Quote
Old 11/16/2009, 03:49 AM   #5 (permalink)
Member
 
Posts: 743
It's not working for me. When I manually input the settings it says "Invalid Internet APN settings."

Did anybody manage to manually set their data connection?
bruba is offline   Reply With Quote
Old 11/16/2009, 09:38 AM   #6 (permalink)
Member
 
Posts: 472
Quote:
Originally Posted by bruba View Post
It's not working for me. When I manually input the settings it says "Invalid Internet APN settings."

Did anybody manage to manually set their data connection?
Yes, mine worked right away after upgrading. I looked into the code. I think "Invalid Internet APN settings." means that the provider's setting (manually entered) are not the right ones. I think they are checked before saving, over the air by logging on to your provider.

@Tuborgmann: I could not completely trace "unable to write settings" , could it be that the provider is not mentioned at all in the provider database? If you cannot access that,I could have a look (provider/country needed)

Just for the record. There are many parts in the code to address a first run. That perhaps means that activation also gives access to the telephone preferences menu, to activate over not-automatically-supported networks
Dick99999 is offline   Reply With Quote
Old 11/16/2009, 12:53 PM   #7 (permalink)
Member
 
Tuborgmann's Avatar
 
Posts: 32
Quote:
Originally Posted by Dick99999 View Post

@Tuborgmann: I could not completely trace "unable to write settings" , could it be that the provider is not mentioned at all in the provider database? If you cannot access that,I could have a look (provider/country needed)

Just for the record. There are many parts in the code to address a first run. That perhaps means that activation also gives access to the telephone preferences menu, to activate over not-automatically-supported networks
I am using 3 DK (denmark), thats the one i would like to use i mean. At the moment i use a Telenor SIM card and that one works fine, 3G coverage just isnt as good as with 3.
Tuborgmann is offline   Reply With Quote
Old 11/16/2009, 01:07 PM   #8 (permalink)
Member
 
Posts: 743
Quote:
Originally Posted by Dick99999 View Post
Yes, mine worked right away after upgrading. I looked into the code. I think "Invalid Internet APN settings." means that the provider's setting (manually entered) are not the right ones. I think they are checked before saving, over the air by logging on to your provider.
Well, the check should be milliseconds, that's how fast the invalid message comes up. I'm sure the settings are right. I tried changing the db file as well. Didn't work either..
bruba is offline   Reply With Quote
Old 11/16/2009, 01:46 PM   #9 (permalink)
Member
 
Posts: 472
Quote:
Originally Posted by Tuborgmann View Post
I am using 3 DK (denmark), thats the one i would like to use i mean. At the moment i use a Telenor SIM card and that one works fine, 3G coverage just isnt as good as with 3.
The following providers are in the network part of the database. If 3 DK is different then it is not listed.
You could try to use one of the provider's entries form Denmark and change it to 3 DK. Have to check all (some 60) fields though and then change the corresponding (= same ID number) data subtable with some 10 fields.

Denmark
mcc mnc qOperatorShortName useThisOverrideRecord maxTransitUnit maxSegmentSize qOperatorLongName ...som 50 more .... ID

238 2 0 0 0 SONOFON 2199023255554
238 30 Telia 0 0 0 Telia 2199023255686
238 1 TDC 0 0 0 TDC 2199023255720

Following from Norway?
242 1 0 0 0 Telenor Mobil 2199023255570
242 2 0 0 0 NetCom 2199023255560
Dick99999 is offline   Reply With Quote
Old 11/16/2009, 01:54 PM   #10 (permalink)
Member
 
Posts: 472
Quote:
Originally Posted by bruba View Post
Well, the check should be milliseconds, that's how fast the invalid message comes up. I'm sure the settings are right. I tried changing the db file as well. Didn't work either..
There are more reports that the 'old' DB change method did not work for some. What I could test is changing one letter in the manual setting under 1.3.1 (APN: internep in stead of internet. I got the same error message, after about 1 second.

And strangely after reentering the right value, I had to save twice before the error disappeared. I recall reading in the code there is also an error message telling people to wait for 15 min before trying again, if they were sure the settings were OK.
Dick99999 is offline   Reply With Quote
Old 11/16/2009, 01:58 PM   #11 (permalink)
Member
 
Posts: 138
Can APN settings be entered before activation? In the activation screen?
pman_lt is offline   Reply With Quote
Old 11/16/2009, 02:05 PM   #12 (permalink)
Member
 
Tuborgmann's Avatar
 
Posts: 32
Quote:
Originally Posted by Dick99999 View Post
The following providers are in the network part of the database. If 3 DK is different then it is not listed.
You could try to use one of the provider's entries form Denmark and change it to 3 DK. Have to check all (some 60) fields though and then change the corresponding (= same ID number) data subtable with some 10 fields.

Denmark
mcc mnc qOperatorShortName useThisOverrideRecord maxTransitUnit maxSegmentSize qOperatorLongName ...som 50 more .... ID

238 2 0 0 0 SONOFON 2199023255554
238 30 Telia 0 0 0 Telia 2199023255686
238 1 TDC 0 0 0 TDC 2199023255720

Following from Norway?
242 1 0 0 0 Telenor Mobil 2199023255570
242 2 0 0 0 NetCom 2199023255560
Yes 3 is different from those, Sonofon is Telenor now in Denmark. What i dont understand though is that you only can manually edit carriers already in the database.
Tuborgmann is offline   Reply With Quote
Old 11/16/2009, 02:15 PM   #13 (permalink)
Member
 
Posts: 472
Quote:
Originally Posted by pman_lt View Post
Can APN settings be entered before activation? In the activation screen?
I don't know. However, I noticed 'first run' tests in the code of the phone prefs, it looks promising. The only way to be sure it works already in 1.3.1. is to try it.
And I recall prefs is available on the special (colored) phone screen that is available besides the activation screen.Those prefs could not be activated under 1.2 if I remember well.

Last edited by Dick99999; 11/16/2009 at 02:25 PM.
Dick99999 is offline   Reply With Quote
Old 11/16/2009, 02:20 PM   #14 (permalink)
Member
 
Posts: 472
Quote:
Originally Posted by Tuborgmann View Post
............. What i dont understand though is that you only can manually edit carriers already in the database.
Well I am not sure of that. However, I noticed that only a few parameters are changed by the code (and I could not find where the change is stored), certainly not all 60 are being setup. So if those 60 are needed for the logic, it makes sense the must be in de DB already.
Dick99999 is offline   Reply With Quote
Old 11/17/2009, 03:46 AM   #15 (permalink)
Member
 
Posts: 472
The manual settings are stored in /var/luna/data/dbdata/PalmDatabase.db3 (or DB?). In my case there is a copy of my providers' entry in the original carrier database. That PalmDB contains the overwritten entries, in the records:
- com_palm_data_carriernetworksettings_CarrierNetworkSettings
- com_palm_data_carriernetworksettings_DataConnectionSettings

Given this complication, I think the best is to wait for the GSM webOS 1.3 version. Since it's release is later than the US 3.1, I presume Palm is working on the items that are especially important for GSM countries. I'd expect:
- an updated carrier database,
- international dialing support for GSM countries (I don't have an entry in the phone prefs on my GSM/Sprint 3.1.1., while US models have an entry. That enables to call with automatically supplied right number prefixes/deletions when calling out of a foreign country, if the numbers stored have a local format)
- activation with support for a carrier network override/setup
Would be nice/a must, I think

Last edited by Dick99999; 11/17/2009 at 03:54 AM.
Dick99999 is offline   Reply With Quote
Old 11/17/2009, 11:32 PM   #16 (permalink)
Member
 
Posts: 743
It seems that roaming ('R') was causing my data to not work at all. After fixing the roaming problem, the CarrierNetworkSettings.db3 hack worked on 1.2.0.

Sadly, after upgrading to 1.3.1, the db hack didn't work. Manually setting 3G didn't work either, although it seemed to do a real check now (taking seconds).

Couldn't find anything in PalmDatabase.db3. So if anybody knows how to get data working on 1.3.1 please let me know.
bruba is offline   Reply With Quote
Old 11/18/2009, 02:54 AM   #17 (permalink)
Member
 
Posts: 472
Do you by any chance use a Rebel card, since you mentioned a roaming setting?
Dick99999 is offline   Reply With Quote
Old 11/18/2009, 05:30 AM   #18 (permalink)
Member
 
Posts: 743
Quote:
Originally Posted by Dick99999 View Post
Do you by any chance use a Rebel card, since you mentioned a roaming setting?
Yeah..
bruba is offline   Reply With Quote
Old 11/18/2009, 10:16 AM   #19 (permalink)
Member
 
Posts: 472
Then likely, the DB entries of the provider that Rebel impersonates should be changed, not the DB entries of your current provider. Dis you try that?
Dick99999 is offline   Reply With Quote
Old 11/18/2009, 10:31 AM   #20 (permalink)
Member
 
Posts: 743
Quote:
Originally Posted by Dick99999 View Post
Then likely, the DB entries of the provider that Rebel impersonates should be changed, not the DB entries of your current provider. Dis you try that?
Are you sure rebel impersonates another provider? I don't think it does, because the Pre says I'm on vodafone NL, which I am. In 1.3.1 it recognizes vodafone NL for calling, but when I change vodafone in the db (like I did with 1.2) data doesn't start working like with 1.2.

BTW, I'm Cheeky on GoT, so we won't have the same conversation on two boards..
bruba is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0