Results 1 to 4 of 4
  1.    #1  
    Ok, the animated gif issue has been covered. (I still consider it absurd to build a new, modern browser that can't display one of the oldest and most prevalent graphics formats on the web, but whatever, moving on...)

    Today I discovered something new: I can't log on to a certain section of our company website using my Pre. I've been able to do this on my old Treo 650, my Treo 755p, and my wife's Centro. But the Pre throws a Java error.

    Now... I mean... seriously. This is supposed to be a pretty cutting-edge device, Sprint's flagship phone, and probably Palm's last chance. It's true that most websites load quickly and display beautifully, but WHAT'S THE DEAL WITH THE CRIPPLES? This kind of thing is worse than using IE!!! IE may not render CSS correctly but at least it shows you SOMETHING!

    I was pretty aggravated that I couldn't loop my old standby NWS weather radar. But this absolutely astonished me: I can't access a simple ASPX page through a java login form, that WORKS ON A 3 YEAR OLD PALM DEVICE!!!

    Does anyone know anything about these massive steps backwards and when they might be corrected? I love the phone but for god's sake, this is almost a deal breaker... accessing a simple webpage is about as basic of a function for a "smartphone" as, well, making calls.
  2. #2  
    No steps backwards, just starting from scratch. The Pre's web browser is based on webkit which overall is a pretty compliant browser as far as web standards go.

    Did the site you were trying to access throw back a javascript error or a java error? I don't believe there is currently a JVM running on webOS for java applets.
    Palm Vx -> Treo 600 -> Treo 700p -> Centro -> Pre (Launch Phone 06/06/09) -> AT&T Pre Plus with Sprint EVDO swap -> Samsung Epic 4G w/ Froyo
  3.    #3  
    I know, I know, you're right, sorry... I was just surprised and mad.

    I was actually stoked when I first heard the browser was webkit based... I do some developing myself and I like webkit browsers. I'm java illiterate though, and javascript only slightly less so, so I apologize if I'm not wording things correctly when talking about them.

    Here's the error returned:
    java.lang.nullpointerexception

    Googling tells me that the java is angry that it's receiving a null value where there ought not to be one. (The way I'm reading it, this is java and not javascript). So here's a question: did the Treo browsers contain any kind of JVM? I didn't think they did, but if not how could they have run this page? And if so, any guess on when (or if) it might be coming to WebOS?

    Thanks, and sorry for the negativity... I really DO like the device, but DAMN it's a bummer to lose this ability!
  4. #4  
    Quote Originally Posted by Stearmandriver View Post
    I know, I know, you're right, sorry... I was just surprised and mad.

    I was actually stoked when I first heard the browser was webkit based... I do some developing myself and I like webkit browsers. I'm java illiterate though, and javascript only slightly less so, so I apologize if I'm not wording things correctly when talking about them.

    Here's the error returned:
    java.lang.nullpointerexception

    Googling tells me that the java is angry that it's receiving a null value where there ought not to be one. (The way I'm reading it, this is java and not javascript). So here's a question: did the Treo browsers contain any kind of JVM? I didn't think they did, but if not how could they have run this page? And if so, any guess on when (or if) it might be coming to WebOS?

    Thanks, and sorry for the negativity... I really DO like the device, but DAMN it's a bummer to lose this ability!
    No problem you can speak your mind here. I don't mind people venting their frustrations it's just when facts are skewed that I have problems.

    PalmOS did have a JVM available (IBM Websphere) but it wasn't installed by default, so you would have installed it if it was on there.
    Palm Vx -> Treo 600 -> Treo 700p -> Centro -> Pre (Launch Phone 06/06/09) -> AT&T Pre Plus with Sprint EVDO swap -> Samsung Epic 4G w/ Froyo

Posting Permissions