Results 1 to 18 of 18
  1. johndoeii's Avatar
    Posts
    44 Posts
    Global Posts
    45 Global Posts
       #1  
    Like many other Pre users, I have been using the push feature through Gmail for email on the Pre/WebOS. In addition, I had the option selected so that only the last 2 week's email is being shown.

    However, I soon realized that when the "as items arrive" option is selected, the "2 weeks" (or however other length) feature doesn't do anything to keep your inbox from continuously growing in size. Without clearing your inbox, every additional email you receive will add onto the size of your inbox.

    Similarly, since I got my Pre I noticed that switching pages on the launcher, application launch speed, and the email application in particular (especially scrolling up and down) were getting slower and slower.

    The solution? CLEAN YOUR INBOX!

    The simplest way for me to do this was to switch the "2 week" setting to manual, resync, then go back to the account and set it to 2 weeks (or 1 week, or 1 month whatever you want) again. You'll have to manually resync every gmail folder (sent, starred, etc.) but it's worth the time.

    Now that I've done that, my Pre is running much more smoothly... switching pages in the launcher is more slick, and the email program is much much faster.

    let me know if any of you experience similar results.
  2. #2  
    I only sync the last 3 days email. Mine is always fast.
  3. johndoeii's Avatar
    Posts
    44 Posts
    Global Posts
    45 Global Posts
       #3  
    how do you make it to always just have 3 days of email on there? or do you go through the settings every few days and redo it?
  4. KJ78's Avatar
    Posts
    838 Posts
    Global Posts
    1,113 Global Posts
    #4  
    it only syncs the first 1000 msgs no matter how many you have
  5. #5  
    that def. seems to work. I just did that and it looks like it fixed the speed issue.
  6. #6  
    odd that email woudl cause this issue
  7. johndoeii's Avatar
    Posts
    44 Posts
    Global Posts
    45 Global Posts
       #7  
    1000 is too many messages. the feature of old email making the email application (and perhaps the OS at large) slow is not unique to WebOS. It's the same thing on the iPhone, and especially on Blackberry's (alas, anyone who has used a blackberry is all too familiar with the "PURGE" feature).

    keeping the email at a level of 200-300 messages makes it so when you scroll through the messages there is really no delay in loading.... also, launching the EMail program is mcuh faster and for some reason swiping through the launcher is faster as well. Hope this helps.
  8. #8  
    They still need to fix emptying the trash. My email trash folders never seem to empty ever and I have to manually do it every couple days to keep up.
  9. lrhf97's Avatar
    Posts
    14 Posts
    Global Posts
    17 Global Posts
    #9  
    it would be nice if they fixed the trash issue it but in the meantime....

    "There's a tweak for that...." read all delete all
  10. #10  
    Maybe I am still missing something. I went to my gmail on the PC and made sure everything was organized and deleted from there that I didnt want on the Pre sync. On my Pre I have 200 emails, I have it set to only show 3 days, but can still see like 2 weeks back..hmm.

    I want to be able to just delete the ones I dont want on the Pre, BUT I want to leave them on the Gmail server/PC side. Currently, if I delete them off my Pre they are deleted off Gmail totally. Is there a way to fix this?
  11. #11  
    Quote Originally Posted by DJeremyC View Post
    Maybe I am still missing something. I went to my gmail on the PC and made sure everything was organized and deleted from there that I didnt want on the Pre sync. On my Pre I have 200 emails, I have it set to only show 3 days, but can still see like 2 weeks back..hmm.

    I want to be able to just delete the ones I dont want on the Pre, BUT I want to leave them on the Gmail server/PC side. Currently, if I delete them off my Pre they are deleted off Gmail totally. Is there a way to fix this?
    I use the filter system in Gmail, i set it up this way, email come into my inbox, are labled to another box, but also remain in the in box, i then can read, in either box, and the other is automaticly marked as read as well, however, when i delete from the inbox the email stays in the other inbox, it does not delete it. the secondary box is used for back up for me, as i need info that i send and recieve from and for clients. the filter system in gmail is a little tedious to set up, but once done does what i need it to do. presently running 6 additional inboxes all set up this way, i also have several filters setup to just label incoming email.
  12. chichi's Avatar
    Posts
    256 Posts
    Global Posts
    259 Global Posts
    #12  
    How about if I just frequently use the Delete all emails patch and delete emails from all my boxes including the trash? I can always go to the mobile site if I need to pull up and email since it only deletes from my pre.

    I only use email on the pre to read emails as they come in while im on the go and if i need to respond to them at that moment. no need for them to be saved to my pre's memory. but the delete all patch should work right?
  13. #13  
    This sounds like a bug; it should only keep the last N days of email in there, where N is what you specified in the settings.

    I was wondering why mail was getting so slow; this explains it. The rest of the phone feels faster too but I think it's because I just did a Luna Restart while messing with some patches. It's always speedy after a Luna restart.
  14. #14  
    Can't you just delete individual emails as your read them. I don't have the phone yet and use yahoo email on a Samsung Instinct which I plan on replacing?
  15. #15  
    This was completely the case for me as well.

    Another issue is having too many Contacts. I had 2,000 at the beginning and everything in the Pre was so slow. After many tech support calls someone finally asked how many emails and how many contacts I had.

    The issue is that with every sync the Pre has to go through your entire list of contacts and emails and check to see if anything has changed on the Pre or the other end and then make updates.

    Even if no updates need to be made, the Pre is still constantly checking through each contract or email.

    And while the Pre is syncing, it is like you are stuck in glue.

    I paired my contacts down to 400 and keep my emails to under 100 and my Pre is very fast now.

    - Craig
  16. #16  
    doesnt do much for me.

    is mine not correct or is it this way for everyone? mine delete and go to my trash.

    so its either loose my email or leave them on pre forever.. i dont want to keep them on my pre forever but would like them online.

    olny other solution i guess is to keep going in and deleting the account and readding it???
  17. flashpass's Avatar
    Posts
    12 Posts
    Global Posts
    14 Global Posts
    #17  
    What worked for me was changing the "show email" value to something else (like 3 days), sync and make sure you see the older emails removed, then change it back to the original value.

    If you do the change and the sync doesn't appear to work, try yet another setting until you do see it work, then proceed to goto your original setting.

    Only question is whether it continues to properly remove items older than 7 days moving forward, but this is a quick way to clean it without removing accounts or installing patches or anything.
  18. cobra977's Avatar
    Posts
    32 Posts
    Global Posts
    35 Global Posts
    #18  
    Hmm... I had not noticed this, but none of of my older gmail has been purged since I got the device in early Aug. I have it set to keep 7 days and 'as items arrive.' All my other accounts are purging correctly including 2 POP accounts and my corp exchange acct. I was able to force it to purge by changing the setting and rebooting the phone. Just changing the settings and manually syncing did not work for me. Why is this not working correctly? Is this a known bug?

Posting Permissions