Page 3 of 4 FirstFirst 1234 LastLast
Results 41 to 60 of 80
Like Tree2Likes
  1. #41  
    Yes, I'll do that too... The funny thing is that parenthesis "(" is moved along with the Z and is now located down and left ... Minor problem since you don't use parenthesis every 2 - 3 words, but I have to mention it. If i find the way to alter the keymap table then this will be solved too... But no one points me to the right direction yet... I hope I'll find the way in the end, but given my limited time, I don't know when!
  2. s4l
    s4l is offline
    s4l's Avatar
    Posts
    68 Posts
    Global Posts
    104 Global Posts
    #42  
    By when will the Qwertz to Qwerty fix be updated ? Cause I see that their is a parenthesis bug, is it being fixed anytime soon?
  3.    #43  
    Quote Originally Posted by Ozymandias View Post
    By when will the Qwertz to Qwerty fix be updated ? Cause I see that their is a parenthesis bug, is it being fixed anytime soon?
    The method outlined in the original posts in this thread does not have that problem, and is persistent across OTA updates and normal webOS Doctors.

    It's now automated as part of the WebOS Internals Meta-Doctor.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  4. #44  
    I have no idea how to follow the instructions, I guess I will have to keep mistaking the y for the z
  5. #45  
    Quote Originally Posted by erapalo View Post
    I have no idea how to follow the instructions, I guess I will have to keep mistaking the y for the z
    Did you see my post, one page before this one? It is pretty easy if you have rooted your palm (rooting is pretty easy too...)
  6. kresom's Avatar
    Posts
    193 Posts
    Global Posts
    194 Global Posts
    #46  
    Quote Originally Posted by czechdev View Post
    The modification is pretty simple, you have to change the keyboard special chars file, it's located at /usr/palm/frameworks/mojo/submissions/200.47/resources/en_us/alternatechars_fulltable.json in the newest 1.3.1. The verson number "200.47" may change with a new fw version.

    You also have to change all keyboard files in that directory (or, at least the files for your kb variant QWERTY/QWERTZ/AZERTY) to get it working.
    I've done it and I finally can get all Croatian characters. As a consequence, I have two additional questions :

    1. how to start searching (either universal search or phone search) with SYM (accented) character ? It seems to me that Pre simply ignores first SYM? It is specially annoying when you are searching for person whose first and last name begin with accented character

    2. searching doesn't recognize properly upper and lower case variant for accented characters. ie. I am searching for Marko Čerić
    when I type mČ it works fine, but if I type mč than it doesn't find Marko Čerić. Obviously, it doesn't recognize that č and Č are the same letter

    Kreso
  7. #47  
    That's probably an internationalization bug (both the Universal search and not knowing that č/Č are the same characters). I can't search for "Šorm" from the Universal search but it works fine directly in the Contacts app. The workaround is to search for the person's name "milan" instead of surname "šorm" or use the shortcut "mŠ" for "Milan Šorm" in the Universal search.

    But what's really weird -- it actually does good job on sorting the "CH" character (which is special to some European languages and belongs between H a I in the alphabet). It's shown as "C" but sorted correctly in the Contacts app.

    Since O2 is planning to bring the Pre to the Czech market, I hope they'll fix these bugs before (and publish a full Czech localisation).
  8. kresom's Avatar
    Posts
    193 Posts
    Global Posts
    194 Global Posts
    #48  
    Quote Originally Posted by czechdev View Post
    That's probably an internationalization bug (both the Universal search and not knowing that č/Č are the same characters). I can't search for "Šorm" from the Universal search but it works fine directly in the Contacts app. The workaround is to search for the person's name "milan" instead of surname "šorm" or use the shortcut "mŠ" for "Milan Šorm" in the Universal search.
    it works until I need to find a person whose both first name and last name begins with accented character, like Đurđica Čerić.

    It would be nice (or it should be normal) that search work like Google - it treats accented characters as they are the same character like base characters - if you type "citam knjigu" it also finds "čitam knjigu". My dearly missed ThakePhone@PalmOS did it also the same way.

    Quote Originally Posted by czechdev View Post
    But what's really weird -- it actually does good job on sorting the "CH" character (which is special to some European languages and belongs between H a I in the alphabet). It's shown as "C" but sorted correctly in the Contacts app.
    The weird thing is that it does sort (within contacts app) C, Č and Ć as those three are the same letter, but it displays it like separated letters.

    Quote Originally Posted by czechdev View Post
    Since O2 is planning to bring the Pre to the Czech market, I hope they'll fix these bugs before (and publish a full Czech localisation).
    What happened to that announcement ? It was announced for January, if I remember correctly ?

    Kreso
  9. #49  
    Sure, that's really a problem. But since I don't have many "accented" friends, the current state don't bother me much.

    I think the sorting depends on the Linux libraries inside. And since there's a good i18n support in Linux, the sorting works as it's supposed to.

    Yup, in January. I should call at the Czech Telefonica to get some info Hope their plans hasn't changed since the anouncement...
  10.    #50  
    I'd just like to note that this thread has strayed quite a bit away from the original topic that I posted.

    Perhaps a new thread might be best for discussing other means to change the keyboard mapping that are different from the permanent means to change qwerty/qwertz/azerty that this thread was originally about.

    -- Rod (the person who started the thread)
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  11. #51  
    Quote Originally Posted by diosif View Post
    Hello,
    I'd like to throw a little idea. I suppose you are aware of the fact that the setkeycodes command works in Palm Pre... If you run:

    setkeycodes 07 44
    setkeycodes 14 21

    from novaterm you're done, Y is Z and Z is Y ...
    All you have to make is a bash script that does this thing during boot because this change only lasts untill reboot..
    This is perfect for me. Thanks! Do you know which startup script I could add these commands to, or where one could add an init script so that even over boots it just works?
  12. #52  
    Just like to bring this up again, if anyone knows which init script to add it too that would be great.

    Quote Originally Posted by zapgadget View Post
    This is perfect for me. Thanks! Do you know which startup script I could add these commands to, or where one could add an init script so that even over boots it just works?
  13. #53  
    Quote Originally Posted by czechdev View Post
    Great work! Now just gotta transform it to a patch and load it to Preware :-)
    CzechDev (or anyone really), is it possible to request a patch build for the setkeycode process to simply swap the shift and symbol keys? I'd greatly appreciate it.

    I made a request here as well: http://forums.precentral.net/webos-p...hift-keys.html
  14. #54  
    anyone know how to change € to $? This is important when I use the LINUX Terminal - the $ has special meaning.

    another question I have when using the termial is that when typing in an ip address, you need the '.' between address octets. The '.' key cannot be accessed without going out of 'numlock'. This means hitting that orange key alot. Is there anyway of getting the '.' in 'numlock' in the terminal ?
  15. #55  
    Hi, does method from first page (editing with metadoctor) work for webOS 2.1?
    Thx for reply
  16.    #56  
    Quote Originally Posted by tr47 View Post
    Hi, does method from first page (editing with metadoctor) work for webOS 2.1?
    Thx for reply
    Yes.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  17. #57  
    is there a way to read the current setting of the token? because my pre- has the pre+ keyboard layout. and i like this layout!
    i want to change the layout of another pre- to the pre+ version.
  18. #58  
    Hi, has anyone been able to do this with the HP Veer? i tried the steps in the original post but keep getting errors, i tried to modify the steps to mirror some of the results i was seeing, but no success. I also tried the setkeycodes but that didn't work. anyone have any ideas?
  19.    #59  
    The Meta-Doctor solution will work on a Veer.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  20. #60  
    Quote Originally Posted by rwhitby View Post
    The Meta-Doctor solution will work on a Veer.

    -- Rod
    I get different results.

    First, the meta doctor location is under my username's home folder, but that's fine.

    It also didn't recognize the make command, so i had to sudo. Once done, this is my log.


    root@ubuntu:~/meta-doctor# make clobber
    rm -rf build
    root@ubuntu:~/meta-doctor# rm -rf build
    root@ubuntu:~/meta-doctor# make CARRIER=wr unpack patch
    mkdir -p downloads
    Please download the correct version of the webOS Doctor .jar file
    and then move it to downloads/webosdoctor-wr-.jar (i.e. the downloads directory that was just created under the current directory).
    make: *** [downloads/webosdoctor-wr-.jar] Error 1
    root@ubuntu:~/meta-doctor# make CARRIER=wr unpack patch
    rm -rf build/undefined--wr-
    mkdir -p build/undefined--wr-
    cp downloads/webosdoctor-wr-.jar build/undefined--wr-/webosdoctor-wr-.jar
    ( cd build/undefined--wr- ; \
    unzip -q webosdoctor-wr-.jar META-INF/MANIFEST.MF com/* \
    resources/webOS.tar resources/recoverytool.config )
    ( cd build/undefined--wr- ; \
    unzip -q webosdoctor-wr-.jar resources/wr.tar )
    mkdir -p build/undefined--wr-/webOS
    tar -C build/undefined--wr-/webOS \
    -f build/undefined--wr-/resources/webOS.tar -x
    cp scripts/WebOS-Internals.tga build/undefined--wr-/webOS/BootLogo.tga
    mkdir -p build/undefined--wr-/carrier
    tar -f build/undefined--wr-/resources/wr.tar -t \
    > build/undefined--wr-/carrier-file-list.txt
    tar -C build/undefined--wr-/carrier \
    -f build/undefined--wr-/resources/wr.tar -x
    gunzip -f build/undefined--wr-/webOS/nova-cust-image-.rootfs.tar.gz
    gzip: build/undefined--wr-/webOS/nova-cust-image-.rootfs.tar.gz: No such file or directory
    make: *** [build/undefined--wr-/.unpacked] Error 1
    root@ubuntu:~/meta-doctor# make CARRIER=wr unpack patch
    rm -rf build/undefined--wr-
    mkdir -p build/undefined--wr-
    cp downloads/webosdoctor-wr-.jar build/undefined--wr-/webosdoctor-wr-.jar
    ( cd build/undefined--wr- ; \
    unzip -q webosdoctor-wr-.jar META-INF/MANIFEST.MF com/* \
    resources/webOS.tar resources/recoverytool.config )
    ( cd build/undefined--wr- ; \
    unzip -q webosdoctor-wr-.jar resources/wr.tar )
    mkdir -p build/undefined--wr-/webOS
    tar -C build/undefined--wr-/webOS \
    -f build/undefined--wr-/resources/webOS.tar -x
    cp scripts/WebOS-Internals.tga build/undefined--wr-/webOS/BootLogo.tga
    mkdir -p build/undefined--wr-/carrier
    tar -f build/undefined--wr-/resources/wr.tar -t \
    > build/undefined--wr-/carrier-file-list.txt
    tar -C build/undefined--wr-/carrier \
    -f build/undefined--wr-/resources/wr.tar -x
    gunzip -f build/undefined--wr-/webOS/nova-cust-image-.rootfs.tar.gz
    gzip: build/undefined--wr-/webOS/nova-cust-image-.rootfs.tar.gz: No such file or directory
    make: *** [build/undefined--wr-/.unpacked] Error 1
Page 3 of 4 FirstFirst 1234 LastLast

Posting Permissions