Page 5 of 7 FirstFirst 1234567 LastLast
Results 81 to 100 of 124
  1. #81  
    do you have an original orange sim card? Please give the exact record num or content of the db record. Do you get any error?
  2. bruba's Avatar
    Posts
    743 Posts
    Global Posts
    752 Global Posts
    #82  
    Quote Originally Posted by amjz View Post
    I noticed that the Orange settings for GPRS and WAP and MMS for my country are listed in both 1.1.3 and 1.3.1 CarrierNetworkSettings.db3 ... and all settings are correct. but why Data not working i dont know?!!

    anybody has a solution or facing same problem?
    In 1.3.1 there seems to be a new problem where the right settings (manual or in CarrierNetworkSettings.db3) don't work for some providers. It's probably related to a change in how 1.3.1 connects to the network, compared to 1.1.3 and 1.2.

    The only solution right now is downgrading, waiting, hoping and praying for a fix in the next update.

    See: http://forums.precentral.net/gsm-pre...-1-3-1-uk.html
  3. amjz's Avatar
    Posts
    451 Posts
    Global Posts
    453 Global Posts
    #83  
    Quote Originally Posted by Dick99999 View Post
    do you have an original orange sim card? Please give the exact record num or content of the db record. Do you get any error?
    Yes i do have original Orange SIM card and its pre configured to work on EDGE/GPRS/MMS/WAP and works very well when i put it on Palm Centro and was working perfectly when i was using Palm Pre 1.1.3 ROM!

    Record No. in SQLite is 139
    and content of the db record is:
    ""
    "416","77","Orange Jo","0","0","0","Orange Jordan","1","1","","160","1","","173","10","20","1","1","7","","","0","0","144","1","1","1","1",""," ","0","0","0","0","290","172.16.1.2","http://172.16.1.96/servlets/mms","9201","300","300","5000","307200","480","640","20","","1","1","11","0","1","1","1","1","1","21 99023255691","2","1558"

    and i combared the db record in CarrierNetworkSettings.db3 in both 1.1.3 and 1.3.1 ROMs and its same record with same Data and MMS settings.

    any idea?
  4. amjz's Avatar
    Posts
    451 Posts
    Global Posts
    453 Global Posts
    #84  
    Quote Originally Posted by bruba View Post
    In 1.3.1 there seems to be a new problem where the right settings (manual or in CarrierNetworkSettings.db3) don't work for some providers. It's probably related to a change in how 1.3.1 connects to the network, compared to 1.1.3 and 1.2.

    The only solution right now is downgrading, waiting, hoping and praying for a fix in the next update.

    See: http://forums.precentral.net/gsm-pre...-1-3-1-uk.html

    I think ill be waiting for fix, 1.3.1 firmware works great and the data problem the only problem that i had
  5. #85  
    could you look in another DB the palmDB and see whether that has an entry for the 2 carrier tables and if the settings are ok. I am travelling so please find my posting about the PalmDB. If wrong I think you cannot simply change that DB by copying it to a PC. That might result in a inconsistant DB since other progs might write to it. If there is no entry please.switch on manual carrier sttings and change them. That will create these entries in the palmDB. Are these created ones the right ones?
  6. amjz's Avatar
    Posts
    451 Posts
    Global Posts
    453 Global Posts
    #86  
    I found that it has 2 entries, one for Orange and its settings correct, and one is an empty.

    When going to my Palm Pre and choose to manula edit my Data settings i got this error: "Invalid Internet APN settings."

    could you look in another DB the palmDB and see whether that has an entry for the 2 carrier tables and if the settings are ok. I am travelling so please find my posting about the PalmDB. If wrong I think you cannot simply change that DB by copying it to a PC. That might result in a inconsistant DB since other progs might write to it. If there is no entry please.switch on manual carrier sttings and change them. That will create these entries in the palmDB. Are these created ones the right ones?
  7. #87  
    We are on to something here for all those having trouble with 3.1 and 3g data settings. Would you mind publishing those 2 records? I'll have a closer look tonight. BTW you can copy the palmDB towards your PC there is no harm in copying it towards. Please publish both the provider network and the data record(s)
    Are you by any chance or any reader experienced in SQL? How would I delete a whole record in SQlite?
    Last edited by Dick99999; 11/30/2009 at 09:59 AM. Reason: Spelling
  8. #88  
    Do a

    SELECT COUNT(*) FROM tablename WHERE fieldname = value;

    first (replace tablename and fieldname = value with appropriate replacements, depending on what you want to delete), and check if it return the correct number of rows. If so, do

    DELETE FROM tablename WHERE field = value;

    which should delete the number of rows returned by the SELECT.
  9. #89  
    Thanks ozuzo. I have seen that you also have trouble with #G data connections and 3.1.1. And that you use a regular operator supplied SIM card in an unlocked Pre (to rule out any locking problems). Since amjz apparently can not publish the requested data, would you?
    It's data stored in a different database. The PalmDatabase.db3 is located in the same directory as the CarrierNetworkSettings.db3 is.
    The PalmDB will contain copies of some records of two tables from the carrier DB whenever the manual settings has successfully applied. The entries have the same name as the ones in the carrier DB:
    com_palm_data_carriernetworksettings_CarrierNetworkSettings
    com_palm_data_carriernetworksettings_CarrierNetworkSettings
    Those 2 have very a limited amount of records. Could you publish or mail them. Perhaps we can solve the problem by comparing them with a working system.
    Last edited by Dick99999; 12/02/2009 at 03:07 AM. Reason: regular sim/unlock
  10. amjz's Avatar
    Posts
    451 Posts
    Global Posts
    453 Global Posts
    #90  
    @Dick99999 sorry for the late but i was WebDoctored my Palm Pre recently.

    This is the info from the PalmDatabase.db3:

    com_palm_data_carriernetworksettings_CarrierNetworkSettings :

    "mcc","mnc","qOperatorShortName","useThisOverrideRecord","maxTransitUnit","maxSegmentSize","qOperato rLongName","gsmNumSimPDP","umtsNumSimPDP","smsEmailGateway","smsMessageSizeLimit","isSmscNumberOnSim Card","smscNumber","smsValidityPeriod","smsMaxPartsPerMessage","smsMaxRecipients","smsRequestDeliver yReceiptAvailable","smsCanSendBlank","smsHeaderSizeLimit","smsEncoding","smsTransportMethods","smsNu mberSecondsWaitForSegment","useVodaphoneVoicemail","voicemailNumber","useGpsSettingsInCarrierDb","gp sAllowed","msBasedAllowed","msAssistedAllowed","agpsServerAddr","msAllowedApps","msfpTimerMin","msfp TimerMax","msfpTimerDefault","msfpTimerInterval","mmsApnId","mmscWapGateway","mmscUrl","mmscPortNumb er","mmscMessageSizeLimit","mmsMaxVideoSize","mmsDefaultPageDuration","mmsMaxAudioSize","mmsMaxPictu reHeight","mmsMaxPictureWidth","mmsMaxRecipients","mmsProxy","mmsAckMessageRead","mmsEnableAutomatic DownloadWhenRoaming","mmsVersionNumber","mmsCanSendBlank","mmsCcBccSupported","mmsIsPictureResolutio nLimited","mmsIsWavSupported","mmsRequestDeliveryReceiptAvailable","mmsAcknowledgeMsgReceipt","id"," _class_id","_mod_num","_flags"
    "416","77","Orange Jo","0","0","0","Orange Jordan","1","1","","160","1","","173","10","20","1","1","7","","","0","0","144","1","1","1","1",""," ","0","0","0","0","4","","http://172.16.1.96/servlets/mms","9201","300","300","5000","307200","480","640","20","","1","1","11","0","1","1","1","1","1","10 3354093010945","94","103060",""



    com_palm_data_carriernetworksettings_DataConnectionSettings :

    "com_palm_data_carriernetworksettings_CarrierNetworkSettings_id","apn","apnid","cshnUserName","cshnP assword","supportedService","serviceDefault","regionName","id","_class_id","_mod_num","_flags"
    "103354093010945","net.orange.jo","1","net","net","1","1","","104453604638721","95","85472",""
    "103354093010945","mms.orange.jo","4","mms","mms","4","4","","104453604638722","95","20455",""
  11. #91  
    It looks like the working record example one and the non-working one are not to different.
    com_palm_data_carriernetworksettings_CarrierNetworkSettings_id apn apnid cshnUserName cshnPassword supportedService serviceDefault regionName id _class_id _mod_num _flags

    Mine - working. ( I have not set MMS)
    "com_palm_data_carriernetworksettings_CarrierNetworkSettings_id","apn","apnid","cshnUserName","cshnP assword","supportedService","serviceDefault","regionName","id","_class_id","_mod_num","_flags"
    "106652627894273","internet","1","tmobile","tmobile","1","1","","107752139522049","98","246870", ""
    "106652627894273","","4","","","4","4","","107752139522050","98","215889",""

    Yours - not working.
    "com_palm_data_carriernetworksettings_CarrierNetworkSettings_id","apn","apnid","cshnUserName","c shnP assword","supportedService","serviceDefault","regionName","id","_class_id","_mod_num","_flags"
    "103354093010945","net.orange.jo","1","net","net","1","1","","104453604638721","95","85472",""
    "103354093010945","mms.orange.jo","4","mms","mms","4","4","","104453604638722","95","20455",""

    The is some mentioning on the Internet of a capital O: net.Orange.jo
    Also my working record does not contain dots in the name.
    And I have not used MMS, so there is no entry for the names, perhaps ....

    Some more examples could help if the DB content is the source of the trouble

    BTW I found during experimenting that if you clear of change the Voicemail number in one of the DB's, you can see which record is being used when changing the manual data switch in Phone prefs. Just check the VM number in phone prefs.
    Last edited by Dick99999; 12/03/2009 at 12:56 AM. Reason: CSV format for records
  12. amjz's Avatar
    Posts
    451 Posts
    Global Posts
    453 Global Posts
    #92  
    @Dick99999 I think its all about the Dots in APN ..
    I tried another SIM for another Network Operator, The APN for this Network Operator contains no Dots and Data working!

    So This is a bug in the 1.3.1 and cant be solved or bypassed, right?
  13. #93  
    @ozuzo Does your APN have dots in the name?

    Anyone having 3G data working on 3.1.1. with dots in the name for the 3G data access point APN?
  14. bruba's Avatar
    Posts
    743 Posts
    Global Posts
    752 Global Posts
    #94  
    Quote Originally Posted by Dick99999 View Post
    @ozuzo Does your APN have dots in the name?

    Anyone having 3G data working on 3.1.1. with dots in the name for the 3G data access point APN?
    Other people have reported the dots are not the problem in my topic over here:

    http://forums.precentral.net/gsm-pre...-1-3-1-uk.html

    Also, Vodafone NL business users who use office.vodafone.nl (instead of live.vodafone.com) don't have any problems. Of course, those settings are already in the db and don't have to be changed.

    BTW, why do you keep calling it 3.1.1?
  15. #95  
    Quote Originally Posted by Dick99999 View Post
    @ozuzo Does your APN have dots in the name?

    Anyone having 3G data working on 3.1.1. with dots in the name for the 3G data access point APN?
    Yes it does, but no, I don't think the dots are the problem. I've looked around in the code, and will try to add some debugging stuff to the code used to update the database, and see what the real problem might be. The "Invalid APN" error is returned for a lot of possible error conditions.
  16. bruba's Avatar
    Posts
    743 Posts
    Global Posts
    752 Global Posts
    #96  
    Quote Originally Posted by ozuzo View Post
    Yes it does, but no, I don't think the dots are the problem. I've looked around in the code, and will try to add some debugging stuff to the code used to update the database, and see what the real problem might be. The "Invalid APN" error is returned for a lot of possible error conditions.
    In which file did you find the code?
  17. #97  
    Can't remember - it is at the computer at home... Will update later if I find something interesting :-)
  18. #98  
    Quote Originally Posted by bruba View Post
    Other people have reported the dots are not the problem ......Also, Vodafone NL business users who use office.vodafone.nl (instead of live.vodafone.com) don't have any problems......
    This is a long shot. Appearently office.vodafone.nl works. I looked at the settings there. The carriernetworksettings 'regular'-DB contains a field GSMnumSimPDP and one for UMTSnumSimPDP.
    If PDP means Packet Data Protocol, that field could define a data protocol. Perhaps support has changed (in 1.3.1 or operator) for IPV6?

    I found on a UMTS forum:
    <PDP_type>: (Packet Data Protocol type) a string parameter which specifies the type of packet data protocol
    X.25 ITU-T/CCITT X.25 layer 3 (Obsolete)
    IP Internet Protocol (IETF STD 5)
    IPV6 Internet Protocol, version 6 (IETF RFC 2460)
    OSPIH Internet Hosted Octect Stream Protocol (Obsolete)
    PPP Point to Point Protocol (IETF STD 51)

    So you could play with those values, I noticed values 1 2 and 3. Don't know the risk involved in those values though .......!! I found that the iPhone hacks mention PDP also.
    Perhaps someone more knowledgeable in this field cares to comment?

    ....BTW, why do you keep calling it 3.1.1?
    Wishful thinking!?

    edit: You have to switch off manual data setting in the phone prefs in order to get the changes in the regular carrier DB being used. To check: temporary change the Voicemail also and check that in phone prefs
    Last edited by Dick99999; 12/03/2009 at 03:20 PM. Reason: switch off manual settings
  19. bruba's Avatar
    Posts
    743 Posts
    Global Posts
    752 Global Posts
    #99  
    Quote Originally Posted by Dick99999 View Post
    So you could play with those values, I noticed values 1 2 and 3.
    I tried all three with rebooting and manual settings off. Since the db entry for Vodafone NL is exactly the same in 1.3.1, I think we might find the answer in the script that's calling the CarrierNetworkSettings.db3 file. Maybe compare the 1.3.1 script with 1.2.1 (if it's readable code). Do you know which file this might be?
  20. #100  
    There is no single script calling the DB, as far as I can see. A good start are the scripts in webosdoctorp100ewwsprint\resources\webOS\nova-cust-image-castle.rootfs.tar\nova-cust-image-castle.rootfs\usr\palm\applications\com.palm.app.phoneprefs

    If I am not mistaken you don't have an original operator supplied sim card. Just to rule out possible related problems, perhaps someone else would care to try the long shot?
Page 5 of 7 FirstFirst 1234567 LastLast

Posting Permissions