Page 2 of 7 FirstFirst 1234567 LastLast
Results 21 to 40 of 124
  1.    #21  
    Sure, that's possible. However, you would still have to replace the database file on your Pre.
    I might write up a short post on how to do that if you are interested. You would then just have to mail me your database file and I could make the changes for you.
  2. #22  
    That'd be great! First I need some hints on how to retrieve the database from the phone. So far I wasn't able to complete the Palm account creation, not sure if I can access the file system like this.
  3.    #23  
    Well, first you need root access and a working telnet client (e.g. Putty). I won't go into details on how to do that as
    a) I don't have a Pre myself
    and
    b) I am sure there are tons of threads on how to do that here or they can easily be found using Google

    Once you are connected to your Pre using Putty, type
    cp /usr/lib/luna/CarrierNetworkSettings.db3 /media/internal. This will copy the database file to the internal storage.
    Put your Pre into USB disk mode and copy the database file to your machine.

    Send me the file (i.e. attach it to a post here as a ZIP file) along with what changes you need. I will make the changes and send it back to you.

    Once you have the file, run WebOSQuickInstall on your machine. Click on Tools - Send File and point it to the amended database file. As the destination folder use /usr/lib/luna/ and click Send To Device!
    Repeat this, only this time use /var/luna/data/ as the destination folder.

    Reset your Pre. That should be it.

    Please keep in mind that I do not yet own a Pre myself and that whatever you do is 100% your responsibility. If you mess up somthing I cannot be held responsible. That said not much can go wrong and you can always WebOSDoctor your device back to normal.
  4. Andreas's Avatar
    Posts
    896 Posts
    Global Posts
    938 Global Posts
    #24  
    For some strange reason I get a roaming icon on the screen even though im connected to my operator. Due to this its not possible to activate the phone and I dont know how to bypass activation so for now its useless.

    Will give another operator a try in the morning.

    Ive compared the settings with the ones published here and all seems to be correct except the IP-number for MMS. The internet settings are correct so I dont know why it wont work. Maybe the settings actually differ between 1.1.3 and the 1.1.2 that is on the phone before updating?

    Btw, had a good laugh when the support asked me what phone it was.

    Me: "Palm Pre"
    Support: "Palmtree?"
    Last edited by Andreas; 10/21/2009 at 12:32 PM.
    Treo 180 270 600 650 Centro Pre Pr3 tPad tPad4G
  5. #25  
    Not sure where to post this so I will try here. I just brought a palm pre from o2 unlocked to the US for use on AT&T. I put in my SIM and it worked right out the bat. I also setup my palm profile fine from the US on AT&T for those interested. Internet and MMS (after 1.1.3) work fine. Here is the issue though 3G does not work just edge.

    I have been told the pre has the Qualcomm chipset MSM6260. This chipset supports GSM Quad Band and UMTS Tri Band

    QUALCOMM LAUNCHES MSM6260 MOBILE STATION MODEM CHIPSET. - Free Online Library

    However when I look at

    http://palm.cdnetworks.net/support/d...re_UG_enGB.pdf

    specifications I see

    Dualband WCDMA/HSDPA (850/1900 or 900/2100)

    So I am guessing that the German one has 900/2100... And the AT&T one will have 850/1900. Which is why I can only get edge on AT&T.

    So I am curious if anyone knows if this is a baseband/os issue that can be fixed or is this radio issue (it really only supports those 2 bands only)? hard to tell as I have conflicting info.

    Couple Interesting data points

    1. With an o2 sim in germany 3g worked fine how if I took the sim from my iphone 3g (which was roaming on 3g fine) and put it in it goes to AT&T roaming fine but never gets 3G which is strange as I know a 900/2100 network is there as it found it with the o2 SIM and my iPhone roams to it fine.
    2. If I force it to 3G only it cannot see AT&T anymore...

    It would blow my mind that the palm would ship in europe and be unable to roam in the US on 3G data services (just edge). I guess it might work on T-Mobile but a lot of their network is 1700 which is not supported (some is 1900).

    And if the AT&T one is also dual band as the pdf seems to point at that would be it would not roam on 3G in Europe.

    this seems really strange and dumb.

    Any ideas? The settings all look right in the carrier file.

    thanks for any ideas or any hope ;-)
  6. #26  
    Der Jens is a genius. Getting Swisscom SIM to work with the Palm Pre can be fixed using his simple method.

    Many thanks!
  7.    #27  
    Now we need someone to try and get 3g on AT&T to work.
    Type11 volunteered and I have sent him some additional info. Impatiently waiting for his results .
  8. #28  
    Dear Der Jens,

    looks like you've moved forward with fixing international APN settings.

    I'm owner of German Palm Pre in Ukraine, and tested it with different operators sim-cards. Listed in CarrierNetworkSettings.db3 Ukrainian operators work great (voice&data), but unfortunately the biggest (with best quality) local operator KyivStar GSM(KS UA) isnt in the list and doesnt wotk for data (voice is ok). Is it possible to add new operator to the list being KS user.

    Thank you in advance.
    Andrew. from Kiev)
    Last edited by dubiki; 10/22/2009 at 09:31 AM.
  9.    #29  
    In theory it is possible, yes. However, you would need both "normal" connection settings as well as data settings in th database.
    It might work if you add data setttings (with the correct KyivStar APN etc.) for the carrier it is using for voice.
    What carrier string is shown when you use your KyivStar SIM for voice?
  10. #30  
    KYIVSTAR is shown on left corner on top of the screen. But i didnt find anything that could be connected to the operator in the list of files attached by you to this thread.
  11.    #31  
    From what I can see the only two Ukrainian operators in the database are Life and MTS Ukraine if that makes any sense.
    Maybe you could try to amend the APN settings for one of those (or both) to match the KyivStar APN settings.
  12. #32  
    Is it make sense? I mean, how does the phone understand what APN to use from file? Is it operator's name, ID, mcc, other?

    p.s. i'l try, thank you )
  13. Andreas's Avatar
    Posts
    896 Posts
    Global Posts
    938 Global Posts
    #33  
    I had a hard time understanding and getting a grip of the database by just using SQLite3 so I if you like me are bit rusty with the SQL commands and want to have a graphical look of the fields and tables to double check the changes, try using SQLite Database Browser.

    I havent tried using it for editing but atleast it easier to browse the tables than with SQLite3.

    Can be downloaded at:
    http://sourceforge.net/projects/sqlitebrowser/
    Last edited by Andreas; 10/24/2009 at 06:13 AM.
    Treo 180 270 600 650 Centro Pre Pr3 tPad tPad4G
  14. #34  
    Browsing through the file CarrierNetworkSettings.db3 i found a few things that require clarification on my part.

    What do we enter for:
    1) MMS APN ID?
    2) Mod Number in MMS Settings?
    3) APN ID for GPRS?
    4) Mod Number in GPRS Settings?

    Im trying to add settings for carrier network that is not currently supported by the Palm Pre at the moment. All other fields are quite clear and I have the required settings for them but am unsure what to input for the above?

    I have a Germany Factory unlocked Pre with SSH installed.

    Any help will be greatly appreciated ! Thanks in Advance.
  15. Andreas's Avatar
    Posts
    896 Posts
    Global Posts
    938 Global Posts
    #35  
    I'm pretty sure the apnid's are just referring from table CarrierNetworkSettings to the correct line of DataConnectionSettings ie so you can have different settings for wap internet and mms.

    The others I know nothing about.
    Treo 180 270 600 650 Centro Pre Pr3 tPad tPad4G
  16. #36  
    I got VERY good news for you people out there!

    I have just got 3 Denmark to work on my Pre!! And am so happy..
    3 Denmark did not have any entry in the DB so could not just update the entry.

    What i did was:
    I took the 3 UK settings in CarrierNetworkSettings.db3.
    Changed the Name short and long to 3 DK. The APN settings and mms setting where changed to the Danish settings for 3.

    Now mms and data works!

    The interesting thing is that i did the same with another carrier and that did not work! So APNID or antoher ID must be used the get some other settings for the network..

    But 3 uk -> 3 DK = Succes :-)
  17. #37  
    My post about how I've modified the CarrierNetworkSettings.db3 to get EDGE, mms working.

    First of all, thanx to everyone who posted and shared his ideas.

    I use Palm Pre in Ukraine with KYIVSTAR provider that isn't included in carrier list of webos. So, my goal was to start working KYIVSTAR apn (data) and mms, as voice worked from the beginning.

    I installed bell 1.2.1 firmware (no nav, amazon, etc softs), took CarrierNetworkSettings.db3 from webos doctor, found three providers from Ukraine (no KYIVSTAR in the list), took one and modified the following fields:
    1) mcc and mnc (took from here for KYIVSTAR Complete list of MCC and MNC values)
    2) short and long name (i think it doesn't matter)
    3) voicemail number
    4) mmsc, proxy, ports...everything that I'd found on KYIVSTAR web about operator's settings
    5) in data part - apn, log and pass.

    Finally, sent the file by WebOSQuickInstall and it works!! even voicebox))

    My conclusion, mcc and mnc is the key for GSM provider to be recognize by Palm pre from arrierNetworkSettings.db3 file.

    Amdrew. from Kiev)
  18. #38  
    Can You bake ROM with built in custom APN ??
  19. #39  
    Just got my German Pre - I am on vodafone NL. Second attempt at getting 3G running was succesful: I needed to change the APN to live.vodafone.com for the row with ID 2199023255579 in the DataConnectionSettings. The previous value was (from memory) office.vodafone.nl, wich according to some sites might actually the correct APN for business users, I have a regular account.

    One minor thing: I think the 3G icon did initially not show, and after disabling Wifi and/or Bluetooth, a G icon appeared in that spot. Later on a 3G came on, and after enabling Wifi and Bluetooth, they where there all three, with 3G laterdisappearing again. Disabling Wifi re-enabled the 3G icon... Is this expected behaviour? On my previous phone (P1i) I always had an indicator showing 3G was on.
  20. #40  
    Quote Originally Posted by ozuzo View Post
    Just got my German Pre - I am on vodafone NL. Second attempt at getting 3G running was succesful: I needed to change the APN to live.vodafone.com for the row with ID 2199023255579 in the DataConnectionSettings. The previous value was (from memory) office.vodafone.nl, wich according to some sites might actually the correct APN for business users, I have a regular account.

    One minor thing: I think the 3G icon did initially not show, and after disabling Wifi and/or Bluetooth, a G icon appeared in that spot. Later on a 3G came on, and after enabling Wifi and Bluetooth, they where there all three, with 3G laterdisappearing again. Disabling Wifi re-enabled the 3G icon... Is this expected behaviour? On my previous phone (P1i) I always had an indicator showing 3G was on.
    Since I have Vodafone NL business account in the Netherlands: Thanks for this message. I am now good to go (and buy).
Page 2 of 7 FirstFirst 1234567 LastLast

Posting Permissions