Page 1 of 2 12 LastLast
Results 1 to 20 of 21
  1.    #1  
    I know this has been posted before but it's got to the point on my device I can not handle it anymore.

    A while back I started to notice that when I would google something from my Pre it would display the results in a different language. I tried everything to fix the issue but nothing worked. After finally visiting the doctor the issue still I noticed that the issue only happened when I was using WiFi. I figured for some reason Google must thing I am spain - even though a geo location check on my IP shows me deep in Idaho. Then I found the solution and actually posted it in another thread. I forced my ISP to provide me a new ISP and everything was well. Well until two days ago when I woke up and found my results going back to Spanish.

    So I did what fixed it last time - I changed the MAC address on my router which forced a IP address change. Things went from bad to worse - now my results are in either Japanese or Chinese. It was painful enough trying to decipher my search results in Spanish now it's impossible. I've forced my IP address changes and the results are still the same - completely usesless search results.

    As I've been writing this post I've started messing around and I am starting to think this is more of googles problem then the Pre's. Using firefox if I go to google.com/m the results are still the same. I've tried changing settings - which works until a new session is started even if I log in with my google account it's a no go.

    I am at a loss on what to do at this point to resolve the issue - if anyone has any bright ideas please post.
  2. #2  
    Quote Originally Posted by kennyidaho View Post
    I figured for some reason Google must thing I am spain - even though a geo location check on my IP shows me deep in Idaho. Then I found the solution and actually posted it in another thread. I forced my ISP to provide me a new ISP and everything was well. Well until two days ago when I woke up and found my results going back to Spanish.

    So I did what fixed it last time - I changed the MAC address on my router which forced a IP address change. Things went from bad to worse - now my results are in either Japanese or Chinese. It was painful enough trying to decipher my search results in Spanish now it's impossible. I've forced my IP address changes and the results are still the same - completely usesless search results.

    As I've been writing this post I've started messing around and I am starting to think this is more of googles problem then the Pre's. Using firefox if I go to google.com/m the results are still the same. I've tried changing settings - which works until a new session is started even if I log in with my google account it's a no go.

    I am at a loss on what to do at this point to resolve the issue - if anyone has any bright ideas please post.
    Have you tried good grammar & spelling?
    I find it sad/odd that people ask to be thanked. How genuine is it when you have to ask? It's like forcing your kid to call Grandma, to thank her for the new underwear she sent for their birthday.

    "To me, clowns aren't funny. In fact, they're kind of scary. I've wondered where this started and I think it goes back to the time I went to the circus, and a clown killed my dad.
    -Jack Handy, SNL-


  3.    #3  
    Yup it refused to load. Thanks for your insightful post.
  4. #4  
    you tried changing your language settings within Google?
  5. #5  
    I don't have a pre yet (755p diehard here because of bike or die )but I used to have this issue with google on a pc at work. our company was Swedish owned and the internet passed thru Swedish servers. Its not an isolated pre thing. I had to go and change the language settings to english in google preferences several times like the previous poster. then I had to bookmark it after I changed the preferences. if I just typed google into the search or address bar, pretty sure it would default to Swedish google.
  6. #6  
    I do have a permanent fix for this, but it will be an hour or two before I can test and post it. Also, it will require Linux access via Novaterm or SSH until someone turns it into a patch.
  7. #7  
    I don't know, root access fix seems a bit extreme... I deleted my cookies once, Google came up in Spanish, I changed language setting within Google, and it never happened again... Though I do agree, it probably never should happen and a permanent fix would be nice.
  8. #8  
    I had this happen to my home PCs. I simply switched the IP addresses of the DNS servers on my router from Comcasts to ones provided by OpenDNS. www.opendns .com . My guess was someone in Spain or in my case Korea was intercepting traffic and redirecting it to the host requested. Google was trying to serve the page based on where it received the request from, as the poster with the Swedish proxies alluded to.
  9. #9  
    Quote Originally Posted by DrHeathenScum View Post
    I don't know, root access fix seems a bit extreme
    A patch done through root access is exactly the same as a patch done through Preware. The only difference is the difficulty involved. And I do plan to make the patch available through Preware.
  10. #10  
    Fair enough. Does anyone know what the root (pun not intended) of the problem is?
  11.    #11  
    I suppose I wasn't very clear in my first post. All of these ideas are great ideas and ones that I have attempted many times. So I'll post exactly what I have done today to fix the issue.

    • Cleared cache and cookies
    • Reset Pre
    • Accessed Google settings and confirmed that the language settings are set at English.
    • Changed from English to another language saved and then went back in and saved to English and saved.
    • Log into my Google account which is set to English.
    • Changed DNS servers (I could be wrong but the problem might have resurfaced after changing back to OpenDNS - it was about that time that I noticed it again).
    • Changed my routers MAC Address multiple times to force multiple IP address changes from my cable provider.
    • Reset the cable modem.
    • Partial restored the Pre
    • Full restore of the Pre
    • Visited the Doc


    When I was writing my first post I decided to visit google.com/m from the web browser on my computer. It also showed in Chinese or Japanese. I checked on my Touch Pro with the same results. At that point I felt pretty helpless as it was clear the issue was not related to just the Pre.

    Also by changing the language settings it does fix it for that session; however once I close the browser and reopen the problem is back. Another interesting oddity is that if I open the browser and do a search it will show up in the foreign language if I turn off WiFi (Leaving the browser open) and connect via 1xRTT then hit the button to search again the results will come back in English.

    The IP's my ISP provide me do geolocate to my local area, and they do show being registered to a US company (my ISP). I don't see anything via traceroute which seems foreign but I have not exhaustively checked every IP.

    I am interested in what dallashigh is cooking up. I know there is a lot of people besides me that have this problem.
    Last edited by kennyidaho; 10/15/2009 at 11:46 PM.
  12. #12  
    Interesting... it sounds like the problem is related to you cable internet and not the Pre or Sprint.
  13. #13  
    It happens to me too, i'm almost always on EVDO and it happens about 20% of the time.
  14. #14  
    This happened to my Pre as well, but I actually found the solution to my problem. I noticed that the different language problem started only after applying the "iphone spoofing" patch through Quick Install. I uninstalled the patch, tried out google search and sure enough, it was in English! To test again, I reinstalled the patch and did another search, the results were in chinese. Once again, uninstalled and the results were then in English.

    I tried this solution on both wifi and sprint evdo, with the same results. I'm not saying this will work for everyone, but it did work for me.

    "We all follow the Chelsea!!!"
  15.    #15  
    Quote Originally Posted by DrHeathenScum View Post
    Interesting... it sounds like the problem is related to you cable internet and not the Pre or Sprint.
    That's what I have concluded. It's happened to me before on other devices (WinMo ) but the problem has never last this long with those devices. Normally just have to change the language settings and never worry about it again.

    A while after I got the Pre it happened again and I thought nothing of it and attempted to fix it using the typical settings - however it did not work. It eventually corrected itself but later it came back. That is what lead me to discover the trick of changing my IP address. So when it happened again today I figured it would be a easy fix. Spanish is one thing but Japanese/Chinese is a whole different ball game - it made it impossible to use Google.

    However it's now magically fixed itself.......for now. However I am excited to hear that there might have a fix in the works. I know from reading the forums that other people run into the problem; even when it's easily fixed it's still a massive annoyance.
  16. #16  
    OK, here's the fix for now:

    For reference only. Use the .patch file two posts down.

    1. Access Linux via Novaterm or SSH

    2. Make a backup copy of the original file

    Code:
    root@castle:/# mount -o remount,rw /
    root@castle:/# cd /usr/palm/applications/com.palm.app.browser/app/controllers
    root@castle:controllers# cp urlsearch-controller.jsjsjs $urlsearch$-$controller$.$orig$
    3. Open the file

    Code:
    vi urlsearch-controller.jsjsjs
    4. Go to line 64 (in webOS 1.2.1) Note: you can skip to this line by pressing 64G

    5. Place your cursor over the & in &channel and press 'i' to enter insert mode. Note: In Novaterm, use k j h l as up down left right, respectively.

    6. Type '&hl=en' and press escape to exit insert mode

    urlTemplate: $L('http://www.google.com/m/search?client=ms-palm-webOS&channel=bm&q=#{query}')

    Has been changed to

    urlTemplate: $L('http://www.google.com/m/search?client=ms-palm-webOS&hl=en&channel=bm&q=#{query}')

    7. Enter :wq then press enter to write the file and quit the editor.

    8. Remount the filesystem read-only and restart Luna

    Code:
    root@castle:controllers# mount -o remount,ro /
    root@castle:controllers# stop LunaSysMgr
    root@castle:controllers# start LunaSysMgr
    Notes:
    -If you make a mistake in the editor, don't panic! Press Escape three times, enter :q! and press enter to discard all changes and return to the command line.
    -This patch works on searches performed from the search bar and their children, but will not change anything if you navigate directly to Google from the address bar or a bookmark.

    I plan to have a patch to submit for inclusion in Preware within the next few days.
    Last edited by dallashigh; 10/16/2009 at 01:09 PM.
  17. #17  
    Nice... good thinking.
  18. #18  
    I've created a patch that can be applied via WOSQI. Simply unzip, click the + sign in WOSQI, open the patch, and click Install. Tested with webOS 1.2.1 and WOSQI 2.72.
    Attached Files Attached Files
  19. Casketman's Avatar
    Posts
    20 Posts
    Global Posts
    32 Global Posts
    #19  
    I now have the same issue but NOT when on wifi. When I use wifi,everything is normal.

    Will that patch work for me as well?
  20. #20  
    It forces Google into English regardless of connection method. So yes, try it out. It should work.
Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions