Results 1 to 4 of 4
  1. sidamos's Avatar
    Posts
    614 Posts
    Global Posts
    677 Global Posts
       #1  
    HI!

    The Pre (at least the german GSM version 1.1.3) prefers for Mail and Messenger always GSM, if the phone is active. Other programs (browser, Google Maps), prefer WIFI.

    Mail only uses WIFI, if GSM is off (airplane mode plus WIFI on).

    For testing, I always started downloading a mail attachment and stopped it after transfer of 50%, so that I could try again later. And since I have fast WIFI at the moment and slow GSM (GPRS), one could see a LARGE difference in speed:
    - GSM only: Slow
    - GSM+WIFI: Slow
    - WIFI only: Fast

    In both cases with WIFI on, other programs (browser, Google Maps), where fast as expected.

    So, only Mail (and Messenger) misbehave.

    I was able to proof my theory by logging into the Pre with novaterm and executing:

    watch netstat -i

    Google Maps transferred everything over eth0 and Mail/Messenger over ppp0, while GSM and WIFI is on.

    I never read about this anywhere, so I do not know, if this is a GSM-only bug. But it is a nasty one, IMHO.

    Thomas
  2. #2  
    Quote Originally Posted by sidamos View Post
    HI!

    The Pre (at least the german GSM version 1.1.3) prefers for Mail and Messenger always GSM, if the phone is active. Other programs (browser, Google Maps), prefer WIFI.

    Mail only uses WIFI, if GSM is off (airplane mode plus WIFI on).

    For testing, I always started downloading a mail attachment and stopped it after transfer of 50%, so that I could try again later. And since I have fast WIFI at the moment and slow GSM (GPRS), one could see a LARGE difference in speed:
    - GSM only: Slow
    - GSM+WIFI: Slow
    - WIFI only: Fast

    In both cases with WIFI on, other programs (browser, Google Maps), where fast as expected.

    So, only Mail (and Messenger) misbehave.

    I was able to proof my theory by logging into the Pre with novaterm and executing:

    watch netstat -i

    Google Maps transferred everything over eth0 and Mail/Messenger over ppp0, while GSM and WIFI is on.

    I never read about this anywhere, so I do not know, if this is a GSM-only bug. But it is a nasty one, IMHO.

    Thomas
    I wish the CDMA Pre was like that. I hate when I've got a WiFi connection, the screen turns off, WiFi turns off, and my messagers have to login again, if I've got AIM running on my PC I get the message saying I'm logged in elsewhere... If messaging preferred 3G, I'd be a happy camper.
  3. sidamos's Avatar
    Posts
    614 Posts
    Global Posts
    677 Global Posts
       #3  
    There is a homebrew program, that prevents WIFI from shutting down. I think, NoDoze.

    Maybe for Messenger, it is OK to prefer always GSM, so that you can stay logged in, when the display goes off and WIFI with it. But for Mail not, because the Mail app can easily login into the mail account again.

    Best would be an option.
  4. sidamos's Avatar
    Posts
    614 Posts
    Global Posts
    677 Global Posts
       #4  
    What, if you login the Messenger with your CDMA Pre while WIFI off and then switch on WIFI?

Posting Permissions