Page 1 of 3 123 LastLast
Results 1 to 20 of 44
  1.    #1  
    The clock on my Pre starts losing time throughout the day. After a few hours it may be 10 minutes slow. I've noticed sometimes it will fix itself, but usually I need to restart the phone. There are other posts on here about issues with the clock, but in all those cases the clock runs fast (and battery life is short. I presume that bug is caused by the CPU running too fast).

    This only started happening after I updated to 1.2.1.
  2. tonyv69's Avatar
    Posts
    29 Posts
    Global Posts
    36 Global Posts
    #2  
    have you checked your preferences in date&time
    to make sure network time is on. My time was off as welll
    some how network time was in the off position.
  3. Crimson's Avatar
    Posts
    156 Posts
    Global Posts
    367 Global Posts
    #3  
    Definiately check the network time setting. It should be getting the time from Sprint pretty regularly. I know when I drove through timezones the clock switched relatively quickly to the local time.

    I also seriously doubt that the PRE uses the CPU for time at all.
  4.    #4  
    yup. Network time is turned on. The first time it happened I tried toggling network time off then on again, thinking it would force it to check the time, but it didn't. The most I've noticed it behind by was a little more than 10 minutes.

    As for using the CPU to keep track of time, I just meant the system clock. On some embedded platforms, the system clock is used for time as well for ticks for CPU clock cycles (so an interrupt occurs every X ticks to keep track of time). I assume on the devices running fast that they had a defective clock that ticked too fast (say 700mhz instead of 600mhz for example), so their CPUs were running faster and draining the battery. But I'm not really sure if the Pre has a separate clock for time or not.
  5. reidme's Avatar
    Posts
    372 Posts
    Global Posts
    374 Global Posts
    #5  
    Quote Originally Posted by ingenium13 View Post
    The clock on my Pre starts losing time throughout the day. After a few hours it may be 10 minutes slow. I've noticed sometimes it will fix itself, but usually I need to restart the phone. There are other posts on here about issues with the clock, but in all those cases the clock runs fast (and battery life is short. I presume that bug is caused by the CPU running too fast).

    This only started happening after I updated to 1.2.1.
    This happened to me for the first time a couple of days ago. I noticed it was behind and was actually looking at the display when it jumped ahead about 12 minutes. I'm on 1.2.1 also.
  6. #6  
    This happens all the time. Are you using a touchstone? You can just restart it once a day and leave network time on. The Pre doesn't check network time enough.
  7. #7  
    i've got the same problem. around ten minutes slow. my network is set to on. annoying.
  8. #8  
    I've got the other problem. Mine is set to network time, but mine gains time. Seems to be a little better since the 1.2.1 but it still gains.
  9. #9  
    Quote Originally Posted by Roosterman View Post
    I've got the other problem. Mine is set to network time, but mine gains time. Seems to be a little better since the 1.2.1 but it still gains.
    Mine does that too, about 5 minutes fast.
    I go into airplane mode for a few seconds, then turn it off and it corrects it.
  10. #10  
    Have had this problem as well. My phone will fall behind by 10 minutes and I have to turn off the network time and then turn it on and it will reset in a few minutes.

    This is problematic since I use my Pre for an alarm from time to time.
  11. #11  
    This is driving me round the bend
    Since the WebOS 1.3 update that was released in the UK yesterday, my Pre is losing about 10 minutes an hour, and O2 apparently don't support network time updates, so I am screwed!
  12. #12  
    Funny thing is my wife's Pre was having this issue UNTIL 1.3.1 came out. Now her time seems to be rock solid. Go figure.
  13. #13  
    It's now 26 minutes slow. It was about 11 minutes slow when I made that last post above, and as I said, "Network time update" doesn't work here with o2 in the UK :-(

    there don't seem to be any ntp clients on Preware either
  14. #14  
    it's now 39 minutes slow
  15. #15  
    am gonna yank the battery, see if it makes a difference. Have already tried rebooting. Why the feck can't o2 support network/gsm time, and why can't Palm make a phone whose clock works
  16. #16  
    Hmm. It hasn't lost any time now in the last 40 minutes since I:
    1. Remove the "Sticker" theme that I had installed through PreWare.
    2. Powered Off, Removed Battery, Powered Back on.
    3. Went into Device Info -> Preferences (top left) -> Quick Tests and ran the tests.
  17. #17  
    Hmm... I've been lurking in these forums for a while in anticipation of my switch to WebOS (probably around January), but issues like this one really scares me - a phone that can't even keep time properly? And it seems its not an isolated case either...
  18. #18  
    My battery ran down to the point where my Pre shut off yesterday. As the battery approached ~20%, the clock started to drift MASSIVELY. At the time it shut off, the time was off by almost 90 minutes. Once my phone was recharged, time resynched properly. Still, I can't be having a phone that loses time as the battery runs down.
  19. #19  
    this is getting unacceptable. i have to restart my phone now twice a day just to keep the clock synced up.


    is anyone have problems with their clock sync who have a completed STOCK pre? that is, haven't installed any tweaks, patches, themes, or homebrew apps?
  20. #20  
    Quote Originally Posted by smashclash View Post
    this is getting unacceptable. i have to restart my phone now twice a day just to keep the clock synced up.


    is anyone have problems with their clock sync who have a completed STOCK pre? that is, haven't installed any tweaks, patches, themes, or homebrew apps?
    Mine is completely stock and time gets fast. When it gets a few minutes off, I'll just go and turn off the sync, set the clock and turn the sync back on. It's an annoyance but not that big of a deal to me.
    Last edited by Roosterman; 11/26/2009 at 11:02 PM.
Page 1 of 3 123 LastLast

Posting Permissions