webOS Nation Forums >  webOS Devices >  Palm Pre and Pre Plus > App store no longer working properly for me
App store no longer working properly for me
  Reply
 
Thread Tools Display Modes
Old 10/09/2009, 01:42 PM   #1 (permalink)
Member
 
Posts: 135
I can access the app store normally (when it is up) but whenever I try to update a program or download a program, the Pre freezes up. I can't do anything with it for about 30 seconds and then it gives a Memory full error. It doesn't matter how many apps I remove, I still have this issue. Previously when I ran out of space, it would immediately give a "memory full" warning without locking up my Pre.

Using Preware, I added various patches/theme, but I removed it all when I had this problem. However, it did not help. Also, Newsroom had stopped updating properly, but when I removed all my patches/theme, it started to work normally again.

Do I have to resort to WebOS Doctor? I don't want to loose my text messages, nor set up all my apps again.
jrcbandit is offline   Reply With Quote
Old 10/09/2009, 01:45 PM   #2 (permalink)
Member
 
Posts: 838
i'm having the same issue but i just added some apps last night. i deleted a few apps and i am still getting the error. i'm guessing (hoping) its a prob with the App store as I'm pretty sure I should have room for at least one.

Last edited by KJ78; 10/09/2009 at 01:51 PM.
KJ78 is offline   Reply With Quote
Old 10/09/2009, 03:02 PM   #3 (permalink)
Member
 
Posts: 14
I have the same problem
iofer is offline   Reply With Quote
Old 10/10/2009, 05:39 AM   #4 (permalink)
Member
 
rlanza1054's Avatar
 
Posts: 1,786
Quote:
Originally Posted by jrcbandit View Post
I can access the app store normally (when it is up) but whenever I try to update a program or download a program, the Pre freezes up. I can't do anything with it for about 30 seconds and then it gives a Memory full error. It doesn't matter how many apps I remove, I still have this issue. Previously when I ran out of space, it would immediately give a "memory full" warning without locking up my Pre.

Using Preware, I added various patches/theme, but I removed it all when I had this problem. However, it did not help. Also, Newsroom had stopped updating properly, but when I removed all my patches/theme, it started to work normally again.

Do I have to resort to WebOS Doctor? I don't want to loose my text messages, nor set up all my apps again.
I've been running around all night raving mad over Newsroom. How could they post an app that is in beta and then charge me for it.

And now I can't get a refund.

The app is clearly not ready for prime-time. And he even states that he is fixing thngs.

It's one thing to add features, it's another to be fixing it to make it work.

That means it was never fully beta tested.

Now I paid to be a beta tester for this guy! That's not what I signed up for.

I am going to raise helll with Palm review process. How could they let an app get into the store and be a fee app and the app itself is just in beta.

It would be one thing to release it free and then people can try it out.

But to charge for an app that doesn't work AT ALL!

I am thinking of filling a major complaint.

And Palm keeps tell me to go to the developer. What is that going to do.

He is admitting that he need to fix things.

Why did he allow it to be posted, greed I guess. He doesn't care about the end users.

I wonder how I can get Precentral to post this as a major story. I did save teh conversation with Palm's support team which just lies. And I kept the conversation so you can see how they lie to your face.

I am not happy!

Rob

PS So you can it will work if I remove my tweaks, what tweak could possible interfere with this app. Email in Landscape. That has nothing to do with his app.

What did you install to get it to work?

Thanks!

Rob

Cooking with gas, and about to explode.
__________________
Robert L
Astoria Queens, N.Y.C
- Palm Pre (Sprint) - formally Palm Treo 650
Version 1.4.1.1
Sprint Configuration 2.3
Model: P100EWW
Hardware Version: A
Firmware: CC1.4(510)

rlanza1054 is offline   Reply With Quote
Old 10/10/2009, 06:46 AM   #5 (permalink)
Member
 
Posts: 47
^ what does that post have to do with the previous posters exactly?

BTW, I'm having the same problem with the app catalogue, wondering if it has anything to do with webos-internals and preware's upgrade or if there is something new to do with the app catalogue itself, 2 apps have installed fine but they sure do lock up trying to download them... so much so that I don't even know if they are going to work or if I have to reboot the phone.
ungenius is offline   Reply With Quote
Old 10/10/2009, 11:33 AM   #6 (permalink)
Member
 
Posts: 279
same issue with not being able to update existing apps or to install new ones from the app catalog. Sucks!
gjlowe is offline   Reply With Quote
Old 10/10/2009, 10:16 PM   #7 (permalink)
Member
 
Posts: 447
I'm having the same issue. I deleted a few apps and not able to install any applications. I can install apps from Preware but not catalogue.
Tikerz is offline   Reply With Quote
Old 10/10/2009, 10:21 PM   #8 (permalink)
Member
 
midmofan's Avatar
 
Posts: 1,622
Quote:
Originally Posted by jrcbandit View Post
I can't do anything with it for about 30 seconds and then it gives a Memory full error. It doesn't matter how many apps I remove, I still have this issue.
Been trying to download the classic update and have the same problem. No matter how many apps deleted it tells me to delete and app.
midmofan is offline   Reply With Quote
Old 10/11/2009, 12:47 AM   #9 (permalink)
Member
 
Posts: 5
Like everyone else here, I am also having the same problem. I've deleted ~10 MB worth of apps to try making room for a 500 kB app, but no luck.
sainttravis is offline   Reply With Quote
Old 10/11/2009, 02:54 AM   #10 (permalink)
Member
 
Posts: 135
I fixed my issue. It was Preware causing the issue, specifically the Package Manager service. I had to use Webos Quick Install to remove the Package Manager. I previously only tried removing Preware and I didn't realize Package Manager was still running.

Once Package Manager was removed, the phone no longer freezes while trying to download an app and I no longer get memory full (I deleted a good number of apps so there was no way previously that the app memory was truly full ;p).
jrcbandit is offline   Reply With Quote
Thanked By: KJ78
Old 10/11/2009, 06:53 AM   #11 (permalink)
Member
 
Posts: 279
I tried removing Preware and the Package manager service, and that long hang is indeed gone now...so it only takes a second for the Pre to tell me I don't have enough memory

I should have plenty of space after deleting some apps, but I don't.

Last edited by gjlowe; 10/11/2009 at 07:04 AM.
gjlowe is offline   Reply With Quote
Old 10/11/2009, 07:01 AM   #12 (permalink)
Member
 
Posts: 10
Nice
promtber is offline   Reply With Quote
Old 10/11/2009, 07:31 AM   #13 (permalink)
Member
 
quietstorm21a's Avatar
 
Posts: 230
Quote:
Originally Posted by jrcbandit View Post
I fixed my issue. It was Preware causing the issue, specifically the Package Manager service. I had to use Webos Quick Install to remove the Package Manager. I previously only tried removing Preware and I didn't realize Package Manager was still running.

Once Package Manager was removed, the phone no longer freezes while trying to download an app and I no longer get memory full (I deleted a good number of apps so there was no way previously that the app memory was truly full ;p).

Question did you have the latest version of preware and package manager or try to reinstall preware and see if you had same results?
__________________

quietstorm21a is offline   Reply With Quote
Old 10/11/2009, 08:06 AM   #14 (permalink)
Banned
 
Posts: 3,609
Quote:
Originally Posted by rlanza1054 View Post
I've been running around all night raving mad over Newsroom. How could they post an app that is in beta and then charge me for it.

And now I can't get a refund.

The app is clearly not ready for prime-time. And he even states that he is fixing thngs.

It's one thing to add features, it's another to be fixing it to make it work.

That means it was never fully beta tested.

Now I paid to be a beta tester for this guy! That's not what I signed up for.

I am going to raise helll with Palm review process. How could they let an app get into the store and be a fee app and the app itself is just in beta.

It would be one thing to release it free and then people can try it out.

But to charge for an app that doesn't work AT ALL!

I am thinking of filling a major complaint.

And Palm keeps tell me to go to the developer. What is that going to do.

He is admitting that he need to fix things.

Why did he allow it to be posted, greed I guess. He doesn't care about the end users.

I wonder how I can get Precentral to post this as a major story. I did save teh conversation with Palm's support team which just lies. And I kept the conversation so you can see how they lie to your face.

I am not happy!

Rob

PS So you can it will work if I remove my tweaks, what tweak could possible interfere with this app. Email in Landscape. That has nothing to do with his app.

What did you install to get it to work?

Thanks!

Rob

Cooking with gas, and about to explode.
I think you have to get over this "i paid for it and its still in beta" stuff. Welcome to 2009 and the land of $5 and under apps.

Heck, the app catalog is in beta. Many of Palm's core apps are in beta even if they don't come out and tell you.

But paid or not, any app (with decent support) usually receives updates or fixes.
cardfan is offline   Reply With Quote
Old 10/11/2009, 08:10 AM   #15 (permalink)
Member
 
quietstorm21a's Avatar
 
Posts: 230
It Works!
-I tested it by removing all tweaks i had first to see if that was the cause i got the same effect freezing.
-Then i removed package manger service & preware and that seems to be it because now i get no major freeze at all.

This is great/bad news. Great because i was able to stop the freezing. Bad because i love preware so much i will make sure to report to the guys in the preware thread.
__________________

quietstorm21a is offline   Reply With Quote
Old 10/11/2009, 10:39 AM   #16 (permalink)
Member
 
Posts: 838
i am having a problem. if i install package manager then i can't use the app store. i get the out of memory error despite nowhere near enough apps installed to get this. if i uninstall package manager then i can't use preware. is there something i'm missing?
KJ78 is offline   Reply With Quote
Old 10/11/2009, 11:05 AM   #17 (permalink)
Member
 
quietstorm21a's Avatar
 
Posts: 230
Quote:
Originally Posted by KJ78 View Post
i am having a problem. if i install package manager then i can't use the app store. i get the out of memory error despite nowhere near enough apps installed to get this. if i uninstall package manager then i can't use preware. is there something i'm missing?
Not sure about the memory error as i dont get that message just the freezing issue. But basically yes it seems its one or the other which is why i am hoping it is something that can be fixed.
__________________

quietstorm21a is offline   Reply With Quote
Old 10/11/2009, 11:14 AM   #18 (permalink)
Member
 
Posts: 279
Quote:
Originally Posted by KJ78 View Post
i am having a problem. if i install package manager then i can't use the app store. i get the out of memory error despite nowhere near enough apps installed to get this. if i uninstall package manager then i can't use preware. is there something i'm missing?
Uhh...the last dozen posts? Sorry...that was too good to pass up. Seriously though...this is what many of us are seeing as well.
gjlowe is offline   Reply With Quote
Old 10/11/2009, 11:43 AM   #19 (permalink)
Member
 
Posts: 838
Quote:
Originally Posted by gjlowe View Post
Uhh...the last dozen posts? Sorry...that was too good to pass up. Seriously though...this is what many of us are seeing as well.
*****
KJ78 is offline   Reply With Quote
Old 10/11/2009, 01:17 PM   #20 (permalink)
Member
 
Posts: 447
It's definitely the package manager service. I removed all my tweaks, Preware, and the Package Manager Service. Then I was able to download an application from the App Catalog with no freezing and no "No more memory" message.

I then just installed the Package Manager Service only using WebOSQuickInstall and it broke the App Catalog.
Tikerz is offline   Reply With Quote
Thanked By: gabe2gg
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0