Page 1 of 3 123 LastLast
Results 1 to 20 of 52
  1.    #1  
    It seems the Palm Pre GPS was never tested in the southern hemisphere – my new Pre’s GPS reports Lat: 394.6, Long: 138.6

    Code:
    24926.609       PUB     call    460             :1.26   com.palm.location       //getCurrentPosition  «string=“{}”, string=“com.sfmpllc.sendmylocation 1058”»
    24926.920       PUB     return  460             com.palm.location       com.palm.luna        «string=“{”errorCode”:0,”timestamp”:1.254820510841E12,”latitude”:394.xxxxxx,”longitude”:138.xxxxxx,”horizAccuracy”:150,”heading”:0,”velocity”:0,”altitude”:0,”vertAccuracy”:0}”»
    The latitude value should be 34.6 degrees South (or -34.6 degrees).

    See my blog post at rwhitby.net : Palm Pre GPS doesn’t like my hemisphere for more details.

    Has anyone else used a Pre in the Southern Hemisphere yet?

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  2. #2  
    Quote Originally Posted by rwhitby View Post
    It seems the Palm Pre GPS was never tested in the southern hemisphere – my new Pre’s GPS reports Lat: 394.6, Long: 138.6

    Code:
    24926.609       PUB     call    460             :1.26   com.palm.location       //getCurrentPosition  «string=“{}”, string=“com.sfmpllc.sendmylocation 1058”»
    24926.920       PUB     return  460             com.palm.location       com.palm.luna        «string=“{”errorCode”:0,”timestamp”:1.254820510841E12,”latitude”:394.xxxxxx,”longitude”:138.xxxxxx,”horizAccuracy”:150,”heading”:0,”velocity”:0,”altitude”:0,”vertAccuracy”:0}”»
    The latitude value should be 34.6 degrees South (or -34.6 degrees).

    See my blog post at rwhitby.net : Palm Pre GPS doesn’t like my hemisphere for more details.

    Has anyone else used a Pre in the Southern Hemisphere yet?

    -- Rod
    Have you tried applying the GPS hack by ebag333 yet? Just curious.

    http://forums.precentral.net/palm-pr...ed-cached.html
  3.    #3  
    Quote Originally Posted by bpdamas View Post
    Have you tried applying the GPS hack by ebag333 yet? Just curious.

    http://forums.precentral.net/palm-pr...ed-cached.html
    No I have not.

    It seems I need an SPC/MSL code for the phone to perform that procedure. Since the phone and I are permanently in Australia, that's going to be non-trivial

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  4. #4  
    Quote Originally Posted by rwhitby View Post
    No I have not.

    It seems I need an SPC/MSL code for the phone to perform that procedure. Since the phone and I are permanently in Australia, that's going to be non-trivial

    -- Rod
    Ahh. Good point. I wonder if there is a way around that.
  5. dr3wster's Avatar
    Posts
    92 Posts
    Global Posts
    96 Global Posts
    #5  
    hi all! Did anyone find a solution to using the Pre's GPS in the Southern Hemisphere :S
  6.    #6  
    Quote Originally Posted by dr3wster View Post
    hi all! Did anyone find a solution to using the Pre's GPS in the Southern Hemisphere :S
    No, but I did get contacted by Palm to gather more information, so they do know about it now.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  7. #7  
    Should be an easy fix since Latitude = 360 - Pre latitude. Next update maybe. (NE suburbs I see. )
    Last edited by johncc; 10/14/2009 at 09:45 PM.
  8. dr3wster's Avatar
    Posts
    92 Posts
    Global Posts
    96 Global Posts
    #8  
    Hahaha, careful Rod, you may have gotten a stalker

    At least you didn't put down your entire log!!!
  9.    #9  
    Quote Originally Posted by dr3wster View Post
    Hahaha, careful Rod, you may have gotten a stalker

    At least you didn't put down your entire log!!!
    I rounded the numbers - they would be 50km away from me.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  10. #10  
    Rod,

    Have you tried the following post to get your MSL code? It looks like it worked for one.

    http://forums.precentral.net/palm-pr...ml#post1972080

    Let us know if it works.
  11. #11  
    how do you go about getting lat. and lon. aon the pre?
    ĦṔ-ḶøØṫ-ŦḯØη
    Here is a direct link to webOS Doc for all carriers
    http://www.webos-internals.org/wiki/...octor_Versions
    P.S. if i have helped you and you are thankful please hit the thanks button to the right---->
  12. #12  
    Quote Originally Posted by Shadavis08 View Post
    how do you go about getting lat. and lon. aon the pre?
    Call ##GPS# in the phone application.
    Last edited by johncc; 10/15/2009 at 09:35 PM.
  13. #13  
    Quote Originally Posted by rwhitby View Post
    I rounded the numbers - they would be 50km away from me.

    -- Rod
    Rounded to 1/10 degree should be within 6-7nms.
  14. mlai's Avatar
    Posts
    4 Posts
    #14  
    Hi,
    I acquired one off ebay from one of the members on the forum. Google maps works just fine in terms of locating me, so I'm not sure why you guys think its not working? I'm in Sydney.
  15.    #15  
    Quote Originally Posted by mlai View Post
    Hi,
    I acquired one off ebay from one of the members on the forum. Google maps works just fine in terms of locating me, so I'm not sure why you guys think its not working? I'm in Sydney.
    Can you get a fix in airplane mode after a full reset and no mobile or wifi connection since the full reset?

    BTW, my testing was done with a CDMA Pre, your is a GSM. So it seems that tower assistance is working for you, but what results do you get with the GSM connection turned off?

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  16. Modular's Avatar
    Posts
    71 Posts
    Global Posts
    74 Global Posts
    #16  
    Quote Originally Posted by rwhitby View Post
    Can you get a fix in airplane mode after a full reset and no mobile or wifi connection since the full reset?

    BTW, my testing was done with a CDMA Pre, your is a GSM. So it seems that tower assistance is working for you, but what results do you get with the GSM connection turned off?

    -- Rod
    Are you able to get a tower assistance fix using Google Maps with a CDMA Pre by roaming on the CDMA network there? Or is your testing being done all without any network connection? How about when Wifi is connected?
  17.    #17  
    Quote Originally Posted by Modular View Post
    Are you able to get a tower assistance fix using Google Maps with a CDMA Pre by roaming on the CDMA network there? Or is your testing being done all without any network connection? How about when Wifi is connected?
    A CDMA Pre does not have any way to get a cellular connection in Australia, period. My GSM Pre is still in transit from Germany.

    GPS on a Sprint CDMA Pre running stand-alone or on wifi does not work, as detailed in this thread.

    It seems now that GPS on a GSM Pre works with tower assistance (as you would expect). Still waiting to hear about stand-alone and wifi modes.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  18. mlai's Avatar
    Posts
    4 Posts
    #18  
    I'd love to give you a quick response, but Google Maps isn't really going to work if its in Aeroplane mode and wifi is off - if you give me instructions on what you want to me to, I'm happy to do it
  19.    #19  
    Quote Originally Posted by mlai View Post
    I'd love to give you a quick response, but Google Maps isn't really going to work if its in Aeroplane mode and wifi is off - if you give me instructions on what you want to me to, I'm happy to do it
    ##GPS# in the dialer gives the GPS screen on a CDMA Pre.

    I assumed #*GPS# does the same on yours.

    Try getting a fix on that screen in airplane mode then reset, or with just wifi on. No cellular connection since reset (otherwise you just get the cache of the last cellular position).

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  20. mlai's Avatar
    Posts
    4 Posts
    #20  
    Those numbers dont seem to dial... ##GPS# dials to ## #*GPS# dials to #*
Page 1 of 3 123 LastLast

Posting Permissions