Page 15 of 19 FirstFirst ... 510111213141516171819 LastLast
Results 281 to 300 of 371
  1. n8cook's Avatar
    Posts
    14 Posts
    Global Posts
    33 Global Posts
    #281  
    If anybody can help with this... I will press the thumbs at "Thanks!" button on their message... I'd push it twice, it won't let me.

    I thanked the two other posters ahead of me... c'mon - you KNOW you want one!!
    Last edited by n8cook; 10/26/2009 at 01:43 PM. Reason: I wanted to
  2. #282  
    I have a question. If it is updating itself again to fix problems, how come it doesn't?
    Why are the bad files not cleared out?

    I have now updated 3 times. I do NOT want to have to restore my Pre to factory. As a matter of fact I will say now that I am NOT going to do it so we need a fix.

    I am a huge Pre Fan_boy but man, this is now getting ridiculous. Okay I understand that we are the ones modifying the Pre in ways it was not intended and we are responsible for our own problems. I understand all of that but still, the app install memory space limitation, the sluggishness and now this. I am just not feeling the love!

    Can some add a patch or application to Preware so we can toggle that update on/off please!
    Systems Analyst by trade, Drummer by desire and Music Lover by birth. A self proclaimed Geek and gadget nut. ii

    Did you know: The Pittsburgh Steelers have more championships than 21 other NFL teams combined!
    Pittsburgh Steelers-6 Time Super Bowl Champions!

    Pittsburgh Penguins-3 Time Stanley Cup Champions!
  3. n8cook's Avatar
    Posts
    14 Posts
    Global Posts
    33 Global Posts
    #283  
    That would also be great - but it looks pretty easy to fix up with the command line if anybody knows how to make it work.

    ___________________________

    Did you know: The Detroit Lions have more loses than every professional sports team in the country. Maybe it's time for a new king of the jungle.
  4. #284  
    I am suspecting the LED notification patch myself. It still works after the patch is applied so makes me wonder if it keeps seeing that code enabled thinking there is a problem that needs patched again. I am just guessing here of course
    Systems Analyst by trade, Drummer by desire and Music Lover by birth. A self proclaimed Geek and gadget nut. ii

    Did you know: The Pittsburgh Steelers have more championships than 21 other NFL teams combined!
    Pittsburgh Steelers-6 Time Super Bowl Champions!

    Pittsburgh Penguins-3 Time Stanley Cup Champions!
  5. n8cook's Avatar
    Posts
    14 Posts
    Global Posts
    33 Global Posts
    #285  
    I had it happen and I wasn't using the LED notification patch
  6. #286  
    So i had just been ignoring the messages. Sure enough, one night my phone goes ahead and reinstalls the update itself (though i probably hit "Install" instead of the snooze on my alarm clock or something). Of course, I had patches installed, so i was worried i'd have to doctor the phone. I fired everything back up, and of course my system was boned because of all the patches. However, I went ahead and tried the emergency patch remover on Preware, and it worked. I was able to then reload the patches without flashing the phone.

    I took care and only added a very small number of patches over a period, including: LED notification, "Add Date", "4x4 Icons v3, and Battery Icon and Percent.

    I had been cruising along for nearly 2 weeks when I fired up Preware and noticed that the "Browser MultiMod" was updated. I had always tried doing this patch so I could download music streams, but I always got an install error. I figured the reinstall program had resolved itself, so I tried to patch to add the browser mod. Same install error. Oh well, no biggie, right?

    About 3 minutes later, I get the dreaded install threat.

  7. #287  
    This is what I did:

    The original instructions can be found in post 111 in this thread: http://forums.precentral.net/palm-pr...ml#post1966987

    I used the Terminal application to type these commands right from my Pre. You can download Terminal (and the Terminal service, which now downloads automatically before Terminal) through Preware: http://forums.precentral.net/webos-i...0-preware.html

    Once you have Terminal installed on your pre, put your pre into developer mode: just start typing upupdowndownleftrightleftrightbastart from the main screen. You'll see a toggle for Developer Mode, switch it to on and your pre will restart.

    The next part you must do very carefully. Open the Terminal app and type (*note the spaces between letters and symbols**without the word "Code:"*) from post #111:

    Code:
    cd /usr/bin
    mount -o remount,rw /
    chmod -x UpdateDaemon
    mount -o remount,ro /

    Then reset your phone or just type
    Code:
    killall UpdateDaemon
    --

    To re enable, use:
    Code:
    cd /usr/bin
    mount -o remount,rw /
    chmod +x UpdateDaemon
    mount -o remount,ro /
    and then reset your phone.

    Remember to take your phone out of developer mode afterward, and keep the instructions for re-enabling the UpdateDaemon handy. HTH.

    Quote Originally Posted by n8cook View Post
    That would also be great - but it looks pretty easy to fix up with the command line if anybody knows how to make it work.

    ___________________________

    Did you know: The Detroit Lions have more loses than every professional sports team in the country. Maybe it's time for a new king of the jungle.
  8. #288  
    I'm not using preware or any other type of tweaks, the only thing I have on my phone is filecoaster, some apps from that, and my tether, and I recently got the notification to update to 1.2.1 for the third time, that's got to be it.
  9. #289  
    urghh this just happened to me for the 4th time!!!!!!!!!
  10. #290  
    Quote Originally Posted by rjcc View Post
    I'm not using preware or any other type of tweaks, the only thing I have on my phone is filecoaster, some apps from that, and my tether, and I recently got the notification to update to 1.2.1 for the third time, that's got to be it.
    fileCoaster, and any applications that it installs, are not able to modify the root filesystem or root ipkg database in any way - that's a hard technical fact.

    If you really have nothing else installed, then you may have a smoking gun ...

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  11. #291  
    After I type in this info in the TERMINAL APP:

    Code:
    cd /usr/bin
    mount -o remount,rw /
    chmod -x UpdateDaemon
    mount -o remount,ro /

    Then reset your phone or just type
    Code:
    killall UpdateDaemon

    Do I hit enter or just restart? I'm thinking just restart, but wanting to make sure.

    I just got asked to "update" again.
  12. #292  
    After you exit out of Terminal and if you type upupdowndown etc. and switch development mode off, it will restart anyway.
  13. #293  
    Much thanks, I got it.
  14. #294  
    Quote Originally Posted by rwhitby View Post
    fileCoaster, and any applications that it installs, are not able to modify the root filesystem or root ipkg database in any way - that's a hard technical fact.

    If you really have nothing else installed, then you may have a smoking gun ...

    -- Rod
    that's the only way i've loaded homebrew on my pre, used webosdoctor to put filecoaster on and that was it, plus the installer for mytether.
  15. #295  
    Quote Originally Posted by rwhitby View Post
    If you really have nothing else installed, then you may have a smoking gun ...
    Quote Originally Posted by rjcc View Post
    that's the only way i've loaded homebrew on my pre, used webosdoctor to put filecoaster on and that was it, plus the installer for mytether.
    I see smoke!!
  16. #296  
    Quote Originally Posted by rjcc View Post
    that's the only way i've loaded homebrew on my pre, used webosdoctor to put filecoaster on and that was it, plus the installer for mytether.
    Which specific installer for which specific version of MyTether did you use. Please give us exact URLs and an exact recount of how you installed it.

    Thanks,

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  17. drnull's Avatar
    Posts
    570 Posts
    Global Posts
    571 Global Posts
    #297  
    Just for the record, I still have the mytether service installed in the root as specified in the mytether instructions (http://vz.aonic.net/pre/my.tether.install), but have not had an update notification since I did the following:
    Code:
    cd /var/lib/software
    mount -o remount,rw /
    mv DmTree.xml DmTree.xml.corrupt
    echo -n 0 > state
    mount -o remount,ro /
    Reboot, and try checking for updates again, if that fixes your problem, great. If not, then at least we will have another data point.

    In the interest of full disclosure, I did remove the my.tether service via
    Code:
    ipkg remove net.aonic.tether
    But I then installed it again after the first code block fixed the problem, in an attempt to reproduce the Endless Update issue. Since then, I've gone approximately 36 hours with no updates being forced, and I have checked for updates numerous times.
  18. Daemon's Avatar
    Posts
    796 Posts
    Global Posts
    809 Global Posts
    #298  
    Care to explain what the first set of commands actually does?
    There's a lot of stuff in DmTree.xml and my impression is
    that renaming it, will simply disable the update service,
    but in a lot less simple way than we've been doing it up till now.

    ian
  19. #299  
    Quote Originally Posted by drnull View Post
    Just for the record, I still have the mytether service installed in the root as specified in the mytether instructions (http://vz.aonic.net/pre/my.tether.install), but have not had an update notification since I did the following:
    Code:
    cd /var/lib/software
    mount -o remount,rw /
    mv DmTree.xml DmTree.xml.corrupt
    echo -n 0 > state
    mount -o remount,ro /
    Reboot, and try checking for updates again, if that fixes your problem, great. If not, then at least we will have another data point.

    In the interest of full disclosure, I did remove the my.tether service via
    Code:
    ipkg remove net.aonic.tether
    But I then installed it again after the first code block fixed the problem, in an attempt to reproduce the Endless Update issue. Since then, I've gone approximately 36 hours with no updates being forced, and I have checked for updates numerous times.
    I had removed everything, updated for the second time, reinstalled everything, and went for three weeks when WHAM...another reinstall. I have no idea how frequently they probe your phone, but several of us got the update demand at around the same time last week.
  20. drnull's Avatar
    Posts
    570 Posts
    Global Posts
    571 Global Posts
    #300  
    Quote Originally Posted by Daemon View Post
    Care to explain what the first set of commands actually does?
    There's a lot of stuff in DmTree.xml and my impression is
    that renaming it, will simply disable the update service,
    but in a lot less simple way than we've been doing it up till now.

    ian
    I obviously don't have the source code to the update service - these are just my observations.

    The DmTree.xml file is updated by the update process if it is not there. "mv" simply renames it to a backup so a new version can be downloaded the next time you try to update.

    The state file is for the "finite state machine" that controls the update process. Once it is in state 4, the update service believes that it needs an update, so it doesn't even check the DmTree.xml file anymore. Resetting the state to 0 causes the update process to start over again and actually determine if an update is necessary.

    I am sure the update service is still running, otherwise I would be receiving an error, and not the message "your phone is up to date".
    Last edited by drnull; 10/29/2009 at 08:44 AM.

Posting Permissions