Results 1 to 5 of 5
  1.    #1  
    Okay, so as you may or may not know, the newer builds of the Pre have a center button with a more silverish finish to them instead of the more pearlescent button that the older models had; and also, the hardware overall had been greatly improved, or so I hear.

    Well, I find it weird that the Pre that I got at launch (06/06), with a manufacture date of 05/27, actually had the build that the newer models have right now. The slider was VERY tight; little to no play at all. Before PreCentral even pointed out the differences between the more newer builds and the older ones, I actually had no clue that Pres had a pearlescent center button.

    And, of course, as you may have guessed, something had to go wrong with my Pre. After about a month, there was a visible metal liquid of some sort leaking from underneath the screen, and so I had to swap it for a refurbished unit. Now, I'm cycling from refurbished Pre to refurbished Pre with units having the oreo-effect. And aside from the difference in appearance of the center button, I also noticed that the LED lights of the refurbished Pres I've been getting aren't even complete circles anymore, as if there's something wrong with the lighting.

    As I find myself in an unfortunate situation of having to cycle from one Pre to another trying to find one that actually has decent hardware, now I'm just wondering whether or not I was just lucky to get the Pre that I got at launch, or just unlucky to keep getting bad refurbs now. Has anyone else got the Pre with the silver button at launch?
  2. #2  
    I had one and the exact same thing is going on with me. Has some bubbles under my screen so decided to replace it and now I can't get a solid one. My original one had a build date of 5/30.
  3. awrnsmn's Avatar
    Posts
    646 Posts
    Global Posts
    689 Global Posts
    #3  
    My Pre I got at launch with 6/6 with the build date of 5/27, pearl color button and it is still absolutely perfect. I guess I was lucky!!
  4.    #4  
    Quote Originally Posted by GuessWho727 View Post
    I had one and the exact same thing is going on with me. Has some bubbles under my screen so decided to replace it and now I can't get a solid one. My original one had a build date of 5/30.
    I guess we're in the same boat then. I'm actually surprised to hear that someone else has had the silver button Pre at launch like I did. My only problem now is how to keep convincing Sprint to swap my Pre. The current refurb that I've got now has play on the slider like crazy, but I don't think they'd exchange it just for that reason. Hassle, hassle, hassle...

    Quote Originally Posted by awrnsmn View Post
    My Pre I got at launch with 6/6 with the build date of 5/27, pearl color button and it is still absolutely perfect. I guess I was lucky!!
    I guess you are lucky! But one thing that I noticed between the pearl and silver button is that the silver button never let any light out through the cracks the way the pearl button does. The silver button sat perfectly snug in the socket too, and none of the Pres that I cycled through that had the pearl button did that.
  5. #5  
    Damn.

    I just got a refurbished replacement and it arrived with a serious oreo effect, the pearlish button, a dead pixel, and a good squeak to the left side of the keyboard. I'm getting another replacement, but it's doesn't sound like you guys were having much luck with that.

    From what you were saying above am do I understand you correctly when you say that the early launch Pres (most) didn't have a silver button!? And the refurb I just got (almost a year past launch) is a launch Pre?

    Wow. Well, if the next one doesn't work right I'm going to push really hard to just get a different device. I like webos, but I can't handle putting something in my pocket that feels like its going to break.

Posting Permissions