Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 47
  1. #21  
    Wow, I had the exact same two problems and the same results with Sprint service. It was refreshing, for sure.
  2. aglide's Avatar
    Posts
    39 Posts
    Global Posts
    66 Global Posts
    #22  
    Welcome to the wild west that is the Sprint in-store customer experience. It's good you're lucky enough to have a store that does things in a logical way. I have three of them around me that are nothing short of a nightmare to work with.
  3. loupy's Avatar
    Posts
    70 Posts
    Global Posts
    78 Global Posts
    #23  
    Quote Originally Posted by aglide View Post
    Welcome to the wild west that is the Sprint in-store customer experience. It's good you're lucky enough to have a store that does things in a logical way. I have three of them around me that are nothing short of a nightmare to work with.
    I've had nothing but great experiences from the Sprint store close to me. I am quite happy, how many in-store horror stories are out there re: the Pre - I'd love to know.
  4. #24  
    Quote Originally Posted by loupy View Post
    I've had nothing but great experiences from the Sprint store close to me. I am quite happy, how many in-store horror stories are out there re: the Pre - I'd love to know.
    +1
    ĦṔ-Ḷṫ-Ŧḯη
    Here is a direct link to webOS Doc for all carriers
    http://www.webos-internals.org/wiki/...octor_Versions
    P.S. if i have helped you and you are thankful please hit the thanks button to the right---->
  5. Tcub's Avatar
    Posts
    406 Posts
    Global Posts
    419 Global Posts
       #25  
    Quote Originally Posted by Success100 View Post
    check that out, a fellow OHIOAN!! Im a lead rep in the Mentor, OH store!

    Oh wow! I was just in Mentor on Saturday at Altas Cinema seeing a movie with my friend. My Pre actually started acting up while I was there and I thought about visiting a Sprint store in Mentor! I could have run into you!

    As for people saying I'm trolling... how? I had an iPhone for over a year before I got the Pre... I won't share my opinions as it seems some people here aren't mature enough... I did mention iPhone OS 3.1 because from what I've heard it's coming out Sept 25th.. when it really comes out, I couldn't care less. If I got it's release date wrong, I'm sorry but I'm not making any claims.

    Ironically enough I'm watching PalmCast Live and they just mentioned how Palm enveiled the Pixie the day before Apples Press Conference.. Are they trolling too? Didn't think so.

    Let's keep this discussion going in a positive direction please.
    Need help with your webOS device? PM me for help!
  6. #26  
    Quote Originally Posted by Tcub View Post
    So over the weekend my Pre fell victim to the dreaded "My Pre is stuck in I've got head phones plugged in and I'm disabling the earpiece" issue. So far I've had a great experience with Sprint all around so I didn't hesitate going up my local Sprint Store to see what they could do. A replacement was ordered and arrived this afternoon. I promptly headed up the Sprint Store to pick up my replacement. Everything was going smooth until...

    So just today my replacement Pre fell victim to the dreaded "I'm refurbished so the bottom left hand corner of my screen won't respond to your touch! Muhahaha!". I said "Girl please." So I headed back to the Sprint Store for round number 2. A Sprint Rep greeted me and I explained the situation. He tried a "master reset" but that didn't work. He took the phone to the back and come out a few minutes later with...

    A brand spanking new Pre. He said "Okay, now this is a one time thing but I'm going to give you a brand new one. Don't break break it! " I was highly impressed with Sprint and their customer service! He told me to stick around and sign into my Palm Profile and make sure everything works. While we were waiting he said "Here, you can have this." and proceeded to hand me the box with wall charger! I have a Touchstone but this is certainly handy having a spare. After I got everything set up he looked over everything to ensure it was in working order. So I just got home with my new Pre, it's box, and my love for Sprint has grown tremendously.

    I used to have an iPhone 3G and I was enslaved.. I mean serviced by AT&T and I found their "service" to be an absolute joke. Sprint... Keep on keepin on!

    So here I am now at home in front of my laptop and my iMac needing to do school work, wanting to play with my Pre, and eating egg rolls! Oh wait... there was another part to that story wasn't there?

    Hmm.. Oh yeah.. webOS 1.2! (The only reason 90% of you clicked on this thread! )

    So during all that commotion I was talking with one of the Reps who's also a Pre user (lover?). We were going over some of the new features in webOS 1.2 and according to him "the Palm guy was just here and..." webOS is slated for a September 23rd release! He also mentioned the App Catalog and basically told me that the "flood gate would be released soon". I take it soon as in when 1.2 comes out. Nothing new really, except it was interesting to here an actual date.

    So hopefully Sept. 23rd is our day and we'll all be enjoying webOS 1.2, a slew of new apps on our App Catalog, and we'll all be able to sync with iTunes!

    Last but not least... Huge Thanks and Kudos to the staff at the North Olmsted Sprint Store on Lorain in Great Northern. You all ROCK! As well as Sprint!

    Cheers!

    edit: Sorry bout that!
    Isn't it strange that OPs like these ARE ALWAYS WRAPPED AROUND -- THE PALM GUY WAS JUST THERE? He's ALWAYS amazingly there and gone right before they arrive at the store. Truly amazing.
  7. Tcub's Avatar
    Posts
    406 Posts
    Global Posts
    419 Global Posts
       #27  
    Quote Originally Posted by BScheu18 View Post
    Wow, I had the exact same two problems and the same results with Sprint service. It was refreshing, for sure.
    Strange indeed! I'm glad you had a good experience. I too fealt refreshed leaving the store, I have issues with other devices and was certainly not treated as well as I was today at Sprint. Or with Sprint in general. Hopefully the news he gave me was accurate. Either way, I'm looking forward to 1.2 and new App Catalog!
    Need help with your webOS device? PM me for help!
  8. Tcub's Avatar
    Posts
    406 Posts
    Global Posts
    419 Global Posts
       #28  
    Quote Originally Posted by dbd View Post
    Isn't it strange that OPs like these ARE ALWAYS WRAPPED AROUND -- THE PALM GUY WAS JUST THERE? He's ALWAYS amazingly there and gone right before they arrive at the store. Truly amazing.
    I quoted it the way I did because I've heard this from other posts. As soon as the Sprint Rep said I thought "that sounds familiar..." hence the quotation marks.
    Need help with your webOS device? PM me for help!
  9. aglide's Avatar
    Posts
    39 Posts
    Global Posts
    66 Global Posts
    #29  
    Here's the detailed account of the problems I had with Sprint stores in my area back in June-July.

    EDIT: For some reason none of my links are working? Remove the spaces from this URL if you're interested in reading it.

    http:// forums.precentral.net/palm-pre/ 190645-wow-im-shocked-how-hard-try-get-my-oreo-pre-replaced.html
  10. #30  
    I can confirm the same thing. I went to the North Olmstead store just today, and one of the reps was saying that it will most probably come out the 23rd. Another tidbit he let drop: flash support! When I pressed him about it, he just said the he saw that on precentral but I am fairly sure that I haven't seen any news of flash being on webos 1.2
  11. #31  
    Quote Originally Posted by dmglouis View Post
    I can confirm the same thing. I went to the North Olmstead store just today, and one of the reps was saying that it will most probably come out the 23rd. Another tidbit he let drop: flash support! When I pressed him about it, he just said the he saw that on precentral but I am fairly sure that I haven't seen any news of flash being on webos 1.2
    flash will come in october as beta....but if it comes out in 1.2....amazing!!!
  12. Tcub's Avatar
    Posts
    406 Posts
    Global Posts
    419 Global Posts
       #32  
    Quote Originally Posted by dmglouis View Post
    I can confirm the same thing. I went to the North Olmstead store just today, and one of the reps was saying that it will most probably come out the 23rd. Another tidbit he let drop: flash support! When I pressed him about it, he just said the he saw that on precentral but I am fairly sure that I haven't seen any news of flash being on webos 1.2
    Wow! That'd be funny if I saw you. My avatar is a picture of me.

    That was the other thing I forgot to mention! I was pretty surpised when he said "Flash". I was going to write that in the original post but I was too excited about my egg rolls and brand new replacement Pre... Thanks for bringing that up.

    BTW, It was the guy sitting at the front of the store with short blond hair right?
    Need help with your webOS device? PM me for help!
  13. #33  
    Quote Originally Posted by Tcub View Post
    Wow! That'd be funny if I saw you. My avatar is a picture of me.

    That was the other thing I forgot to mention! I was pretty surpised when he said "Flash". I was going to write that in the original post but I was too excited about my egg rolls and brand new replacement Pre... Thanks for bringing that up.

    BTW, It was the guy sitting at the front of the store with short blond hair right?
    This whole thing smells very fishy.
  14. #34  
    Quote Originally Posted by Tcub View Post
    Wow! That'd be funny if I saw you. My avatar is a picture of me.

    That was the other thing I forgot to mention! I was pretty surpised when he said "Flash". I was going to write that in the original post but I was too excited about my egg rolls and brand new replacement Pre... Thanks for bringing that up.

    BTW, It was the guy sitting at the front of the store with short blond hair right?
    Yea, the one sitting at the desk right in front, with a sign in front of the desk detailing discounts for credit unions, etc.

    I was there around 1:30 to 2ish today. Incidentally, I'm also getting a replacement, but I doubt mine will be brand new.
  15. Tcub's Avatar
    Posts
    406 Posts
    Global Posts
    419 Global Posts
       #35  
    Quote Originally Posted by dbd View Post
    This whole thing smells very fishy.
    Then don't read it. And certainly don't reply with comments that don't promote discussion. I posted this information because I figured people would like to hear it.
    Need help with your webOS device? PM me for help!
  16. Tcub's Avatar
    Posts
    406 Posts
    Global Posts
    419 Global Posts
       #36  
    Quote Originally Posted by dmglouis View Post
    Yea, the one sitting at the desk right in front, with a sign in front of the desk detailing discounts for credit unions, etc.

    I was there around 1:30 to 2ish today. Incidentally, I'm also getting a replacement, but I doubt mine will be brand new.
    LOL, too funny! Some advice, my first replacement didn't work as you read. If you find anything wrong with the refurb they give you... take it back!! And I take it they ordered you a replacement? If you asked them for it today, go back up there tomorrow. I showed them mine on Saturday and the replacement came in today. They never did call me.. I was there around 5pm and went back at about 6pm. Good luck!
    Need help with your webOS device? PM me for help!
  17. jaman71's Avatar
    Posts
    127 Posts
    Global Posts
    134 Global Posts
    #37  
    as for the earphone issue -
    i had the earphone issue twice and this is how i fixed it.
    Plug in headphones and dial voicemail. Hit the mute button in the dialer twice then hang up voicemail and pull out headphones. Speaker should work thereafter.

    i found this solution on another site and posted it here a while ago. the problem happens when you shut down the phone with earphones plugged in.

    hope this helps
  18. Tcub's Avatar
    Posts
    406 Posts
    Global Posts
    419 Global Posts
       #38  
    Quote Originally Posted by jabou View Post
    as for the earphone issue -
    i had the earphone issue twice and this is how i fixed it.
    Plug in headphones and dial voicemail. Hit the mute button in the dialer twice then hang up voicemail and pull out headphones. Speaker should work thereafter.

    i found this solution on another site and posted it here a while ago. the problem happens when you shut down the phone with earphones plugged in.

    hope this helps
    I did search for solutions to the issue here and while that one is different than what I had read, it's the same premise as the others. I think that may work for some but I think mine was more a hardware issue than anything. Almost as if something got stuck inside the headphone jack. The Sprint Rep told me he knew someone who used a stylus to poke around and it worked after that. I had a few other minor issues with my first Pre so I decided why not take it in. Thanks for the tip though!
    Need help with your webOS device? PM me for help!
  19. #39  
    Tcub,

    I hope they treat me the same way. I"m going to be heading up to the North Olmstead sprint store within the next couple of days with the same problem you started with.
  20. #40  
    aw i kinda miss cleveland (sometimes)
Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions