Results 1 to 4 of 4
  1. vjdup's Avatar
    Posts
    130 Posts
    Global Posts
    239 Global Posts
       #1  
    The volume up button went soft, the on off button did too.
    Went through 2 hours of testing, resetting device, losing all my logs and texts, to show that its not a software issue, yay.

    Im not using Spint, nor am I in a Sprint area.

    Im going back to my Storm for the time being, hope I dont get too used to it!

    Heres my questions for yous guys:

    Has anyonone sent their Pre in?
    How long did it take to get back?
    Any issues with the repair/service people?
    Ive added the Zagg shield, should I remove it?, Since its a repair issue not a replacement issue I should get the same screen back, right?
  2. #2  
    Before I send it in, I'd call Zagg about the shield. They're pretty good about replacements, but the usually want you send the old one back.
  3. #3  
    Sending to palm for repair warranty?

    From experience, palm calls it a repair, but they will just swap you out for a refurb.

    My bet it you will get a different unit and lose your zagg
  4. vjdup's Avatar
    Posts
    130 Posts
    Global Posts
    239 Global Posts
       #4  
    Quote Originally Posted by trim81 View Post
    Sending to palm for repair warranty?

    From experience, palm calls it a repair, but they will just swap you out for a refurb.

    My bet it you will get a different unit and lose your zagg
    Ahhhhh, I see.

    So now I call Zagg!

    BTW, I havent been impressed with my Pre build quality.
    I ordered another for a friend, the whole unit is better. Keyboard and all hardware buttons are..... crisper! Maybe Ill get lucky and get a crisper unit sent back.

Posting Permissions