If I have an all day event scheduled in google cal and I then change that event from all day to a specific time on my computer it will still show as an all day event on the pre (after synch, of course). If I look at that event on the pre and uncheck the "all day" event box, it will then show the the exact time that I had set for the event on my computer. So, the pre appears to be getting the change in event timing but it will not "uncheck" the all day box. So you have to manually update that event in the pre to match google cal. Annoying bug, but should be a simple fix.

Has anyone noticed this?