Page 1 of 2 12 LastLast
Results 1 to 20 of 25
  1.    #1  
    Background:
    I have a blocked cel # I use for business and personal. This way I can control where people call me back. For personal contacts I simply put *82 before their number in my Contacts app and my number is unblocked... ok,..no problem..old news right? Add text messaging to the mix and with *82 in the number your msg goes to S. Korea, (82 is their country code). On my Treo you simply removed the *82 in the Messaging app and it was good from then on. Not so on the Pre.

    Current:
    The Pre it is "smart" so if you initiate a NEW text message you ARE able to change the number before sending, but after the chat thread has started the Pre "pulls" the number again from the Contact App and inserts their current number WITH the *82, so anothter International text message that Sprint kindly charges me $.20 for. (ouch!)

    Firmware 1.04 solution:
    I was able to get around this "limitation" by duplicating a person's cel number in their contact page WITHOUT the *82 using the same label "Mobile". (NOTE: When you choose "DONE", you will see the number WTHOUT the *82, BUT if you universal search in the phone application, the number with *82 WILL show up so you can use the phone as usual and your number will be unblocked, ie no extra steps to call.) I then open the Messaging App and click on the "TEXT" button (top right) and made sure the number WITHOUT the *82 was selected (sometimes I had to close the contacts app AND Messaging app for changes to show) ...Voila...my contact now has a number without *82 I can text to.
    (If you upgraded to firmware 1.1 (and who didn't upgrade right??)... WAIT..... it broke...

    Firmware 1.1
    After upgrading to 1.1 firmware and realizing that the Contacts app changed a bit in how it dealt with duplicate numbers with & without *82... I was again faced with lots of texts to S. Korea and having to choose "NEW TEXT-Select contact-edit number-remove *82 then write text" everytime....I HAD to find a solution. The 1.04 method didn't work anymore.

    **Here is what I found....(and I tried EVERYTHING -every combination) - finally I found that if you created another mobile number for your contact (with same "mobile label"), and put a "1" before the number, entered a 10 digit number (area code-number) AND added some text AFTER the number (i just used "tx") the Pre would NOT see this entry as a duplicate of your *82 version of your contact's number and now lists it in the "TEXT" menu (top right) of the Messaging App!! (sometimes I had to close the contacts app AND Messaging app for changes to show) You can now choose this number and send texts as normal! So the number would look like this in your contact app: 1(555)555-1212tx. So just add this to all the contacts you text to and you are good to go.

    UPDATE:: (for certain numbers that will not "stick" (ie keep the number you choose for texting)
    It seems for some reason certain numbers will not keep the NON-*82 number you choose in the messaging app and revert to another number. This reverted number is usually the FIRST in the messaging app's list of "textable" numbers (but NOT always). In any case, no matter what number it reverts to it seems that if you REVERSE the numbers with the TEXT-AT-THE-END in the Contact App...then in the messaging app your NON-*82 numbers will appear first in the list and thus be chosen.
    (Thanks to "insane42" for the tip to the solution")

    Example ...In the CONTACT app your numbers appear are as follows
    *82-222-333-4444
    1-222-333-4444tx
    but the messaging app STILL chooses the *82 number

    Change to this: (DON'T DELETE and re-enter numbers just EDIT THEM)
    *82-222-333-4444 becomes *82-222-333-4444tx (ie ADD "tx" at the end)
    1-222-333-4444tx becomes 222-333-4444 (REMOVE the "1" and the "tx)


    Not elegant but it is better than having to manually edit your text's number before each text and you couldn't use the threaded message area of the messaging app! If someone has found another method I am all ears.

    (Speaking of ears) NOTE TO PALM: Please address how the contact app and messaging app handles *82 numbers, this would simplify all this. Basically either a global ignore *82 in the messaging app (and all "*" prefixes actually) OR have changes to the number STICK when in the messaging app. I understand the Pre is trying to be seamless, ie if you change a person's contact Mobile# the Messaging app will auto update too...very cool... however this is a loophole that effects a heavily used application.

    Hope this helps at least one person.... I'm happy again, my wife is happy again....well until the next firmware update.

    Thanks

    DT
    Last edited by DarkTreo; 11/05/2010 at 03:01 AM. Reason: Edited title to reflect not "FIXED" but temp "workaround" found
  2. #2  
    Interesting, thank you!! I resorted to removing my *82 entries altogether, and manually dialing on those! After all my frustration w/ this, I'm going to leave it as is and hope the next FW fixes it. I'm surprise the 1 and tx don't mess w/ it. What about incoming call recognition? Does it still recognize the incoming caller?

    What about incoming texts? Doesn't it switch to the "incoming" number?
  3.    #3  
    There are no adverse effects I have found so far. Incoming calls are recognized, Caller ID and pictures show up. You are basically just creating "another" mobile number the Messaging application can use,.. and then you choose that number to text your contact with. No other numbers in your Contact app are affected.

    Incoming texts are treated the same as they normally are, because the incoming texts are coming from the SAME mobile number! So once you choose the number in the Messaging App it sticks, not because you changed it by temporarily removing the *82, but because you CHOSE a number from the available numbers the Messaging App sees as valid "text-to" numbers. (you put a check mark next to it)

    Also...I am not so confident that it is high on the palm radar to be fixed since this might be a small subset of users and given the fact that this issue has been around since my Treo 600 days, what was that 2003?

    Hope this helps
  4. #4  
    Thanks for the followup. I just tried it out on a few of my contacts, and I *think* it's working. Thank you very much!!! Weird, tho!
  5. #5  
    Well, turns it this isn't foolproof. =( One of my contacts it works fine one. Another, it does not. Every time I get a text from them, it switches back to the *82 number. I have to re-select the other one each time.

    Interesting thing is that on the contact where it DOES work, the 1...tx is the TOP item in the list. On the contact where it does NOT work, the 1...tx is the middle item on the list.

    No matter which order I enter the numbers in on the contact, it comes out that way. They're not appearing in the same order whatsoever...
  6.    #6  
    I have not experienced this yet. I'll keep an eye out and see what might be triggering the reset. Does the contact that resets have the same number associated to it through multiple profiles?

    DT
  7. #7  
    No, the contact that moves is a single profile (Palm).

    I think I found a workaraound. New numbers added to the contact, appeared at the top of the list. So, I added the number again, only putting "aa" instead of "tx" at the end. THAT number then showed up on top of the list. I deleted the number with the "tx" at the end, and the aa number stayed on top.

    Freaking weird. Wouldn't have to worry about this if it would just ignore *## prefixes!

    LOL
  8. marwp's Avatar
    Posts
    8 Posts
    Global Posts
    9 Global Posts
    #8  
    Thanks DarkTreo,

    You just saved me tones of time trying to figure this out....i use my phone the same way as you and could not figure out a way around it.

    Thanks
  9. #9  
    Yes! Thank you, I was having the same issue and could not understand why people were not replying to me...turns out they were not getting my texts for this exact reason. Very frustrating to say the least...I do hope there is a fix in the works very soon, but at least this is a very easy workaround. Thank you!!
  10.    #10  
    I updated my OP with a work-around for numbers the don't seem to "stick" after you change them in the Messaging app. So far so good...but I'll keep testing. Let me know your findings.....

    I too just wish the messaging app simply IGNORED the "*" prefixes!

    DT
  11. #11  
    DH...thank you again..I will try your solution in the OP, see if the number "sticks" and let you know.
  12. #12  
    Wow, all advice greatly appreciated. This bug has been making me NUTS for weeks now. I used a combo of all advice given above and it works fine now, no matter who starts the thread. Here is what I did:

    ERASED all phone numbers from the contacts I wanted to be able to text (did this by deleting phone #s from google contacts, then syncing to Pre).

    REPLACED all these phone numbers, entering the bare, un-prefixed mobile numbers that I wanted to be able to text FIRST, followed by the same number with *82 prefixed and the letters ph postfixed, followed by any other (home, work) etc. numbers for that contact. Did this by retyping them into my google contacts, then syncing to Pre.
    Example:
    FIRST: 888-888-8888 (mobile to text)
    SECOND: *82-888-888-8888ph (mobile to call)

    The funny thing is, when I open one of the contacts in the Contacts function, the numbers are NOT in the same order in which i entered them in Google. BUT if I open the contact for editing, they CHANGE order of appearance to be the same as in google. Another of the many little annoying inconsistencies about the Pre. My old Treo, which I am seriously wishing I could go back to, didn't have ANY trouble clipping the *82 from numbers when I texted--shouldn't the Pre be as "smart" as the older smartphones?

    Now, I sure as hell hope the next OS update doesn't mess it all up again. 99.99% of my tolerance for this kind of technical b.s. is USED UP with this phone--this isn't the first issue I have had by a long shot. I like the form factor, ability to autosync wirelessly etc., but I think they did a CRAP job with the basics. I have had over 10 Palm devices since 1997 and NEVER had a bit of trouble transferring info from one to the next--until the Pre, which after hours on the phone with tech support ended up requiring me to transfer it all essentially by hand. Also, the calendar function is significantly harder to use (on the phone itself) than was the one on my old Handspring Visor from the late 90s--more clicks required to do a single function, less useful features. NOT impressed.
  13. #13  
    Quote Originally Posted by agrow View Post
    ...Now, I sure as hell hope the next OS update doesn't mess it all up again. 99.99% of my tolerance for this kind of technical b.s. is USED UP with this phone...
    That's my fear as well.... That after this next update things will go haywire again...
  14. #14  
    Hi. I just wanted to say THANKS for the suggestion. I have a blocked phone number and had become rather frustrated with the inability to text without the need to re-start a new text EACH & EVERY time. I took your suggestion & improvised it. Under my contacts, I stored the *82 number with the letter "c" at the end of it. Example: *82619-999-9999c . The "texting" number is just stored as a regular phone number Example: 619-999-9999. So far in the past 2 days I've been able to send texts without any problem and when needing to call people, the "c" at the end of the number doesn't affect the call.
    So, thanks a bunch for the help!!!
  15. #15  
    A quick update on the *82 workaround...

    With the latest update to WebOS, you may have found that the workaround noted in this thread is no longer possible, if you are attempting to post-pend "TX" to the sms number or post-pend "mob" to the mobile number. Palm has changed the business rules with respect to the valid values one can enter in a phone number field. In particular, text entered in that field must be numeric, or of a limited set of telephony-recognized codes. The characters M, O, B, T, & X are not valid. So, you may notice that you can't add those character on new contacts. (the existing ones will keep their characters, however).

    P, however, is a valid telephony character, which is normally used to indicate "pause" in the dialing string. Therefore, for the time being, you can add a "p" to the dialing string (post-pended on the end of the string) and it will "trick" the app effectively, as per the original concept.

    Please note as well...to get the letter "p", you must disengage the number lock, which is on, by default. If you neglect to do this, you're not going to get anything when you hit "p" because it registers as the equal sign once the num lock is engaged.

    This business rule is only enforced upon the edit field on your handset. If you happen to be hooked up w/ google contacts, you are free to use whatever text you want if you enter it through google contacts on your pc. If you're using palm profile, though, you must use the handset for data entry, and therefore must adhere to valid telephony characters.

    The second comment to note is that there is a palm service request on this issue, and if you are interested in tracking whether it has been fixed in a new release, the service request tracking ID is: 1-51722555731
    Last edited by roygbiv; 12/06/2009 at 03:17 PM.
  16. #16  
    Thanks for the update! I haven't needed to add any new ones since the first few, so haven't noticed it. Good to know though, and I'm glad there is an actual case number on it.
  17. #17  
    Quote Originally Posted by insane42 View Post
    Thanks for the update! I haven't needed to add any new ones since the first few, so haven't noticed it. Good to know though, and I'm glad there is an actual case number on it.
    Since the privacy options are required by the FCC to operate & interoperate w/ the service provider's services, personally, I decided to file an FCC complaint about it too. Consumers aren't supposed to have to choose between having their SMS messaging service work or privacy. If it's something that bothers you, imo, it's worth the effort to do the same. It's simple & quick, and doesn't hurt to at least have it on the radar, bcs it's such a complicated issue that it's highly unlikely to get movement w/o someone looking at the bigger picture. IMO, the stripping of *XX prepended codes passed between the contact app to the messaging app is simply a missed requirement that Palm should've had implemented for Sprint. IMO it's easy to patch in an update too. When you enter in the dialing string, it's obvious that *some* intelligence has been programmed into how the field is handled (auto-formats the numbers into the 1 (XXX) XXX-XXXX format, and it knows to strip other telephony codes like "p" or "," for example). They just didn't consider the fact that the SMS service doesn't understand them.

    To get to the right form on the FCC website (FCC Consumer Complaints) you just click over to the "wireless telephone" complaint type, and pick the "Billing Service Privacy & Number Portability" category.

    FYI, the text of my complaint:

    The *82 feature does not interoperate with Sprint's SMS messaging service on their Palm handsets (currently the Palm Pre & Palm Pixi handsets) forcing customers to choose between having a properly operating messaging service, or privacy, but not both.

    The root of the problem lies in the logic employed in Palm's WebOS contact application, in combination with how Sprint's SMS service operates. The SMS service does not recognize pre or post-pended codes like *82. Therefore messages sent to contacts stored with the prepended code in the dialing string either returns an error, or forwards a text inadvertantly to South Korea (the international dialing code for S Korea = 82), leading to inadvertent charges for international texting. If Palm's applications were updated to strip the *XX codes from the dialing strings passed between the contact application and the messaging application, the applications FCC requirements would be sufficiently met. Software updates are routine for Palm.
    Last edited by roygbiv; 12/07/2009 at 11:55 AM.
  18.    #18  
    Quote Originally Posted by roygbiv View Post
    A quick update on the *82 workaround...

    With the latest update to WebOS, you may have found that the workaround noted in this thread is no longer possible, if you are attempting to post-pend "TX" to the sms number or post-pend "mob" to the mobile number. Palm has changed the business rules with respect to the valid values one can enter in a phone number field...
    Great info. I found this out too as I was entering new information into my Pre. What I DID find is that if you have previous numbers with letters in the number, you can copy "tx" (or whatever you use) from your older number and after you input the new number paste it into the new entry.

    Also as noted and mentioned in another thread here.... if you use an outside data entry method (google, MissingSync etc....) you can enter these letters without issue AND what I find cool is you are able to REFORMAT how the numbers are seen on your Pre. If you enter a *82 number on your Pre it shows up as *822125551212 which makes looking at numbers at a glance difficult, if you use an outside entry method and sync to your Pre those numbers show up as *82.212.555-1212 which is what we are more accustomed to seeing.

    So here is what I did: (in WebOS 1.3.1)
    1) I spent weekend checking/fixing all my text messaging numbers in the Contacts app on my Pre and verified they show up correctly and work in the messaging app.
    2) I then sync'd the Pre to my Mac
    3) I then changed ALL numbers with *82 in them to this *82.212-555-1212 format.
    4) I resync'd all my numbers and I now see all numbers in a familiar format on the Pre in contacts and Phone App, and checked the messaging app and verified the changed format does not affect the *82 workaround.


    DT
  19. #19  
    Quote Originally Posted by roygbiv View Post
    Since the privacy options are required by the FCC to operate & interoperate w/ the service provider's services, personally, I decided to file an FCC complaint about it too. Consumers aren't supposed to have to choose between having their SMS messaging service work or privacy. :
    Thanks for posting the link and instructions. It's sad that we have to engage the federal government(!) of all people to force Palm (a supposedly innovative company) to simply make our devices function at a minimal level.

    I've been fighting with my Pre daily for 6 months now with this issue, starting all over again with each OS update. It's infuriating that, several updates later, Palm still hasn't fixed this very simple issue and chooses to update non-essential features (like video capture) and ignores the idea of making this device simply work as well as any "dumb" phone would.

    Yes, video/themes/apps are lovely additions, but if you can't use the device to perform the very basic essentials of calling and texting, as I've been able to do with every other device I've owned in 10 years, what in the world is the point? Hey Palm, are you listening or are you too busy telling us how you've killed the iphone?
  20. RPFTW's Avatar
    Posts
    11 Posts
    Global Posts
    13 Global Posts
    #20  
    //
Page 1 of 2 12 LastLast

Posting Permissions