Results 1 to 2 of 2
  1.    #1  
    It's been two and a half weeks since I got my pre and I am now on webOS 1.1. I'm starting to believe that my battery is defective, I have the brightness on the lowest setting and all location services off, gps off, wifi off, bluetooth off, and when my phone is just sitting idle I still lose about 10-12% battery an hour (I use wifi if I've no service though). My pre drained like this before and after 1.1, so it's not 1.1's "calibration reset" and I heard that conditioning makes the battery better over time but it's been nearly 3 weeks and I would like to know if my phone is defective before the 30 day grace period. Should I take this phone back to the store or will another week of conditioning give me the desired battery life I want? Not sure if it helps the answer but the clock on my phone also frequently runs fast by about 20 minutes. Please help, I love my pre but this sucks
  2. #2  
    Quote Originally Posted by brandoncjr View Post
    It's been two and a half weeks since I got my pre and I am now on webOS 1.1. I'm starting to believe that my battery is defective, I have the brightness on the lowest setting and all location services off, gps off, wifi off, bluetooth off, and when my phone is just sitting idle I still lose about 10-12% battery an hour (I use wifi if I've no service though). My pre drained like this before and after 1.1, so it's not 1.1's "calibration reset" and I heard that conditioning makes the battery better over time but it's been nearly 3 weeks and I would like to know if my phone is defective before the 30 day grace period. Should I take this phone back to the store or will another week of conditioning give me the desired battery life I want? Not sure if it helps the answer but the clock on my phone also frequently runs fast by about 20 minutes. Please help, I love my pre but this sucks
    I had the same issue with my 1st Pre. It had to be something wrong with the phone itself. Sprint checked my battery and it was fine. My second Pre and I now have no problems. I would demand them to exchange. I was the same way. Love my Pre just wanted it to work correctly. Now I loose about 2 to 3% an hour on idle.

Posting Permissions