Page 2 of 2 FirstFirst 12
Results 21 to 27 of 27
  1.    #21  
    Quote Originally Posted by wprater View Post
    Just tried it and it did not fix it yet. The stuck pixel is the least of my worries. Im more concerned about the distortion and light leakage. Perhaps I'll deal with and and exchange through TEP (with no deductible) at a later date.
    This phone has that bottom "light leakage problem" but I only noticed it when I was charging, using the phone heavily for video or other such things, AND had the back light turned all the way up.
  2. roor's Avatar
    Posts
    137 Posts
    Global Posts
    142 Global Posts
    #22  
    Quote Originally Posted by Sharkims View Post
    Well I checked 3 of them, and they were identical in every way. Kind of disappointing but, I told him I would try again and he said fine.

    i would recommend trying a cooperate store rather than a retail store. i went to 5 retail stores and opened multiple boxes with no luck, then i walked into the cooperate repair center and they guy behind the counter was like 'gimme 15 mins and ill fix this for you', and sure enough he found me a solid device.
  3. Xyg
    Xyg is offline
    Xyg's Avatar
    Posts
    1,104 Posts
    Global Posts
    1,113 Global Posts
    #23  
    Quote Originally Posted by Sharkims View Post
    My Pre had the Oreo issue going on, some sever scraping on the keyboard and a dead pixel. So I took it in, and they swapped it out again without a question.
    The only bad news is, this Pre seems to have the identical Oreo problem my previous Pre had. This was new enough to have firmware 1.03 on it.
    That's fine, I have no dead pixels, no stuck pixels, no other issues. I put my Invisible Shield on it today, and figured SCREW IT, I am fixing it myself.

    I told my friend who works for Sprint I was going to do this and he asked me how so he could fix his. :P

    All in all, a not too shabby replacement trip. Considering this one isn't scraping and again no dead pixels.
    Your friend who works for Sprint? I thought Sprint employees weren't able to purchase a Pre for 60 days after launch...
  4. roor's Avatar
    Posts
    137 Posts
    Global Posts
    142 Global Posts
    #24  
    i don't think so, cause when i went in to buy mine, a few employees were playing around with theirs.
  5. GenX's Avatar
    Posts
    11 Posts
    Global Posts
    12 Global Posts
    #25  
    I have no dead pixels, no light leaking, Warranty date is 06/24. I do not know what the oreo is.
  6.    #26  
    Quote Originally Posted by Xyg View Post
    Your friend who works for Sprint? I thought Sprint employees weren't able to purchase a Pre for 60 days after launch...
    See a few posts up by an apparent sprint rep about getting a Pre.
  7.    #27  
    Quote Originally Posted by roor View Post
    i would recommend trying a cooperate store rather than a retail store. i went to 5 retail stores and opened multiple boxes with no luck, then i walked into the cooperate repair center and they guy behind the counter was like 'gimme 15 mins and ill fix this for you', and sure enough he found me a solid device.
    This is what I did.
    For me it's this one store or a 75mile drive to Seattle unfortunately. He did say I could bring it back in and check again in a week and see if their new shipment is better. Honestly I couldn't ask for more. The Oreo issue only gets worse over time, and it's not too terrible for me to deal with atm.
Page 2 of 2 FirstFirst 12

Posting Permissions