Results 1 to 15 of 15
  1.    #1  
    Hi all. Let me just say that everyone on this forum (except the whiners) is awesome- I've had a TON of questions answered quickly and effectively, and feel like I'm getting the most possible out of my Pre.

    On to my question. I looked around assiduously for the answer on the Pre Dev and the forums, but no luck.

    How can I SSH into my Pre over the internet? I have already done all the prerequisites that I think should allow it to work:

    1. rooted the pre
    2. enable optware package feed
    3. installed dropbear
    4. installed sftp client
    5. installed dynamic dns updater (so i don't have to know the ip address every time i connect)

    Everything works just fine when using SSH via the LAN or bluetooth or USB.

    With all of that done, from my limited knowledge, it seems like I should just be able to punch my dyndns address ( my-pre-site-name.homeip.net ) into WinSCP or Putty and connect to the Pre over the internet remotely on port 222. However, it's not working. It just times out.

    Is there something else I need to do? I turned developer mode back on to make sure it wasn't a port problem on the Pre end, and that didn't help. Do I need to adjust my firewall/router settings on the client terminal? This should just work right?
  2. #2  
    Quote Originally Posted by Ricyteach View Post
    Hi all. Let me just say that everyone on this forum (except the whiners) is awesome- I've had a TON of questions answered quickly and effectively, and feel like I'm getting the most possible out of my Pre.

    On to my question. I looked around assiduously for the answer on the Pre Dev and the forums, but no luck.

    How can I SSH into my Pre over the internet? I have already done all the prerequisites that I think should allow it to work:

    1. rooted the pre
    2. enable optware package feed
    3. installed dropbear
    4. installed sftp client
    5. installed dynamic dns updater (so i don't have to know the ip address every time i connect)

    Everything works just fine when using SSH via the LAN or bluetooth or USB.

    With all of that done, from my limited knowledge, it seems like I should just be able to punch my dyndns address ( my-pre-site-name.homeip.net ) into WinSCP or Putty and connect to the Pre over the internet remotely on port 222. However, it's not working. It just times out.

    Is there something else I need to do? I turned developer mode back on to make sure it wasn't a port problem on the Pre end, and that didn't help. Do I need to adjust my firewall/router settings on the client terminal? This should just work right?
    For security reasons, access from evdo is disabled by default.

    The wiki has instructions on how to change the iptables line in the upstart script to change this.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  3.    #3  
    hi rod- can you tell me in which wiki is that info located? i've followed all of them and must be missing the part you are referring to. i'm happy to hear that this has already been addressed.
  4. #4  
    If you go to USB mode when connected to a computer, the computer reads it as a hard drive. Can you set that Pre hard drive to be shared on the network? Would be a fast way to transfer files to and from the Pre from any computer on the network.
  5. #5  
    Quote Originally Posted by Ricyteach View Post
    hi rod- can you tell me in which wiki is that info located? i've followed all of them and must be missing the part you are referring to. i'm happy to hear that this has already been addressed.
    On the Developer's WIKI, they talk about enabling SSH. There are two methods they mention, installing Dropbear, and installing OpenSSH. On the page for both methods, step 4 talks about how to disable the EVDO blocking on the firewall.
  6. wprater's Avatar
    Posts
    240 Posts
    Global Posts
    251 Global Posts
    #6  
    You need to enable a new firewall rule in your iptables. Why do you wish to enable remote ssh access? This sounds like a bad idea.
  7. #7  
    Quote Originally Posted by wprater View Post
    You need to enable a new firewall rule in your iptables. Why do you wish to enable remote ssh access? This sounds like a bad idea.
    lmfao. seriously? you obviously have no clue what ssh is
  8.    #8  
    Quote Originally Posted by wprater View Post
    Why do you wish to enable remote ssh access? This sounds like a bad idea.
    are you kidding?

    Quote Originally Posted by hparsons View Post
    On the Developer's WIKI, they talk about enabling SSH. There are two methods they mention, installing Dropbear, and installing OpenSSH. On the page for both methods, step 4 talks about how to disable the EVDO blocking on the firewall.
    i'm so retarded. THANK you. i was looking on the first page, i wasn't clicking through to the dropbear/openssh pages.
  9. gigaorg's Avatar
    Posts
    132 Posts
    Global Posts
    136 Global Posts
    #9  
    Can someone post what they did for dyamic IP? Is there a free option or do you have to pay for it?
  10. #10  
    Quote Originally Posted by gigaorg View Post
    Can someone post what they did for dyamic IP? Is there a free option or do you have to pay for it?
    DynDNS.com: Free DNS Hosting, E-mail Delivery, and VPS Hosting is free. I used it for mine, and had no problems with setup, or with use.
  11. #11  
    Quote Originally Posted by hparsons View Post
    On the Developer's WIKI, they talk about enabling SSH. There are two methods they mention. On the page for both methods, step 4 talks about how to disable the EVDO blocking on the firewall.
    I have looked at Step 4, but the iptables statement already didn't contain anything about eth0.

    I can ssh over wifi, but the operation times out when I try over EVDO.

    Anyone get this working?
  12. #12  
    Quote Originally Posted by Ubuntite View Post
    I have looked at Step 4, but the iptables statement already didn't contain anything about eth0.

    I can ssh over wifi, but the operation times out when I try over EVDO.

    Anyone get this working?
    The instructions earlier in this thread are a bit off now, since the web pages have changed.

    Go to this link:
    OpenSSH Install - WebOS Internals.

    Go to the section that says:
    [Optional] If you want to connect to the pre over EVDO as well as over wifi, do this step.
    You have to follow the instructions. You will be looking in the provided script (cat optware-openssh) for instructions. The script enables SSH over eth0 (wifi). You need to enable it over ppp as well.
  13. #13  
    Quote Originally Posted by hparsons View Post
    The instructions earlier in this thread are a bit off now, since the web pages have changed.

    Go to this link:
    OpenSSH Install - WebOS Internals.

    Go to the section that says:
    [Optional] If you want to connect to the pre over EVDO as well as over wifi, do this step.
    You have to follow the instructions. You will be looking in the provided script (cat optware-openssh) for instructions. The script enables SSH over eth0 (wifi). You need to enable it over ppp as well.

    My problem is that I've already run the install script and gone all the way through, but originally I chose WiFi only. Now I would like to change it, and re-running the script doesn't give me the option anymore because I already have a user all set up, and I don't want to just add another user.

    Can anyone please explain how to enable ssh over EVDO AFTER you have already followed the wiki and chosen to set it up for WiFi only?

    Thanks.
  14. #14  
    Quote Originally Posted by VeeDubb65 View Post
    My problem is that I've already run the install script and gone all the way through, but originally I chose WiFi only. Now I would like to change it, and re-running the script doesn't give me the option anymore because I already have a user all set up, and I don't want to just add another user.

    Can anyone please explain how to enable ssh over EVDO AFTER you have already followed the wiki and chosen to set it up for WiFi only?

    Thanks.
    your /etc/event.d/optware-openssh file probably has a couple lines that look like:
    /usr/sbin/iptables -D INPUT -i eth0 -p tcp --dport 222 -j ACCEPT || /bin/true
    /usr/sbin/iptables -I INPUT -i eth0 -p tcp --dport 222 -j ACCEPT


    if you remove the -i eth0 parts, it'll enable a connection over any interface.

    be sure to mount the file system writable first.
  15. #15  
    I somehow got it working over EVDO by installing DropBear, and then OpenSSH itself via PreWare. I didn't have to edit any files at all...

    I hope that helps...

Posting Permissions