Results 1 to 18 of 18
  1. joelvds's Avatar
    Posts
    24 Posts
    Global Posts
    31 Global Posts
       #1  
    Has anyone else noticed that WiFi is shut off every time you turn off the screen, if you are not actively using the connection. When I unlock my screen I am on EVDO and reconnects to wifi but it takes time to do so. Kind of annoying and sometimes the wifi will reconnect but data won't come across I have to turn it off and back on. It isn't my router which is a WRT54G running DD-WRT, it has happened other routers. But if you are streaming stuff like pandora when you turn off the screen the wifi connection will stay up.
  2. #2  
    I have the same router and I don't have the issue, wifi turns off to conserve battery. I don't have an issue with this because when I turn it on wifi comes on within a few seconds but in the meantime EVDO takes over. If I need wifi to be on because I am using ssh I just plug it in to my usb.
  3. #3  
    I am sometimes having the same problems, I have a netgear router supplied by the cable company, verizon I think...

    I do not know why it does this, but I agree, it is pretty annoying
  4. #4  
    This is by design. Leaving the WiFi radio up all the time would drain the battery quickly as the WiFi radio uses a lot of power when it's on, even when the link is idle.

    The EVDO link uses more power than WiFi when actually moving data, but it uses almost no power when idle.

    This is why the IM and Mail apps use EVDO even when WiFi is available; your push mail and IMs can still arrive without keeping the WiFi radio on wasting power.
  5. #5  
    BTW if you get a touchstone and leave your pre on that the radio stays on while it's charging.
  6. xGORDOx's Avatar
    Posts
    68 Posts
    Global Posts
    74 Global Posts
    #6  
    It literally takes 2 seconds for my wifi to connect when I open my keyboard and the screen turns on.
  7. eesucks's Avatar
    Posts
    62 Posts
    Global Posts
    66 Global Posts
    #7  
    I think this is a power savings technique. Most WiFi chips tend to be power hungry, so it goes into a sleep state when the screen turns off.

    The WiFi protocol states that any connection on the network needs to be polled at certain intervals and send acknowledgements to the AP. So if the WiFi stayed on, it would drain the battery much quicker. I think 2 seconds isn't too bad of a wakeup time.
  8. #8  
    I had this freak out my router last night. So many connect and unconnects. I decided to put in a static IP for my home wireless connection. It now hooks up to wifi in about 20% of the time.
  9. #9  
    Quote Originally Posted by sacherjj View Post
    I had this freak out my router last night. So many connect and unconnects. I decided to put in a static IP for my home wireless connection. It now hooks up to wifi in about 20% of the time.

    If this is happening then you either need to configure your router to give out from a larger pool of IPs, shrink the amount of time any device can hold an IP, or both. If your router can't do this then you have a cheap crappy router and probably should replace it anyway.
  10. #10  
    It was giving the pre the same IP address each time. Just stopped giving anyone full connections. Hadn't been rebooted in a while, so I just power cycled. It is unfortunately the only router that can't flash to DRT or Tomato yet. So the firmware could be better. But I havenLt wired the new to us old house yet, so the other good firmware routers are busy being bridges.
  11. #11  
    Actually...this is a problem not too!...WiFi keeps doing the samething after 1.4 update!..1.3.5 fixed that issue, but 1.4 brought it back!..Gezz..WHAT GIVES?..
  12. #12  
    doesnt that setting in the wifi sleep preferences take care of this issue? the one where you can choose to leave wifi on all the time or put it to sleep when idle?
    THE CHAMP IS HERE!!
  13. #13  
    Quote Originally Posted by mksand28 View Post
    doesnt that setting in the wifi sleep preferences take care of this issue? the one where you can choose to leave wifi on all the time or put it to sleep when idle?
    No! I thought it does.
    I have that setting on and my WiFi use to stay on before 1.4, but now,it doesnt stay on anymore. It turns off by itself!
  14. Daemon's Avatar
    Posts
    796 Posts
    Global Posts
    809 Global Posts
    #14  
    Set that sleep setting to Wifi always on, and Wifi will absolutely stay on when the phone sleeps.
    It does for everyone else. In fact the default behavior of 1.4 matches
    1.3.5 and that setting is normally used to set it back to pre-1.3.5 behavior.

    ian
  15. #15  
    Quote Originally Posted by Daemon View Post
    Set that sleep setting to Wifi always on, and Wifi will absolutely stay on when the phone sleeps.
    It does for everyone else. In fact the default behavior of 1.4 matches
    1.3.5 and that setting is normally used to set it back to pre-1.3.5 behavior.

    ian
    mine doesnt stay on.....i guess there's something wrong with my phone. I'll doctor and see what happens.
  16. #16  
    Quote Originally Posted by Jason Black View Post
    mine doesnt stay on.....i guess there's something wrong with my phone. I'll doctor and see what happens.
    yea it must be your phone cuz mines working perfectly.
  17. #17  
    I believe the intended behavior of Wifi IS TO SHUT OFF when the screen shuts off.
    This is to help preserve battery life.

    There was a problem a number of users had with 1.3.5.1 whereby WIFI always remained on and resulted in 15-20% battery drain per hour.

    Palms solution to this problem was the option to force wifi off when the screen is off.

    This option solved the problem for me and wifi works great now and doesn't drain my battery.
  18. #18  
    All devices do this really. My iPod Touch turns the wi-fi off when it's on standby or when the screen goes off. It's to conserve battery life.

Posting Permissions