Results 1 to 14 of 14
  1.    #1  
    Ok guys listen to this. I been waiting for the pre just like all of us. I get up ealry on saturday the 6th and show up at the sprint store at 5:30am to get my pre im the 4th person in line. awesome. i get my pre then after a few hours i notice 3 dead pixels which wasn't that big of a deal but the main problem was that is doesn't ring. as in there is no sound coming out when it rings. the display shows someone calling but none of the ringtones work. so i take it back in the same day(6th) they sold the last one of 80 when i walked in and no one has brought theres back for any hardware issues. so i have the dud of 80 units? wow.. So now im stuck with a broken pre till wednesday(yesterday) got my new one its perfect it rings and it has no dead pixels. I install my screen protector (bodyguardz) let it sit for 3 hours come back and there is a discolor on the screen. a perfect straight line down the screen. are you kidding me? first i thought it was a discolor in the protector but i ripped off the protector and here is the pictures i got....now i have to order another set of screen protectors cuz palm and sprint **** me again. the pre just does not like me.
    Attached Images Attached Images
  2. #2  
    well you know what they say - third time's a charm! the clock is ticking!
  3. mosdl's Avatar
    Posts
    781 Posts
    Global Posts
    787 Global Posts
    #3  
    ouch.
  4. #4  
    Quote Originally Posted by c4sper View Post
    Ok guys listen to this. I been waiting for the pre just like all of us. I get up ealry on saturday the 6th and show up at the sprint store at 5:30am to get my pre im the 4th person in line. awesome. i get my pre then after a few hours i notice 3 dead pixels which wasn't that big of a deal but the main problem was that is doesn't ring. as in there is no sound coming out when it rings. the display shows someone calling but none of the ringtones work. so i take it back in the same day(6th) they sold the last one of 80 when i walked in and no one has brought theres back for any hardware issues. so i have the dud of 80 units? wow.. So now im stuck with a broken pre till wednesday(yesterday) got my new one its perfect it rings and it has no dead pixels. I install my screen protector (bodyguardz) let it sit for 3 hours come back and there is a discolor on the screen. a perfect straight line down the screen. are you kidding me? first i thought it was a discolor in the protector but i ripped off the protector and here is the pictures i got....now i have to order another set of screen protectors cuz palm and sprint **** me again. the pre just does not like me.
    I've got a 2nd lemon too. The phone is shutting off when slid open/close because of a faulty battery/battery compartment. Exchanged it today and have the exact same problem. I will call the store tomorrow and guess I have to make yet another trip.
  5. santos's Avatar
    Posts
    578 Posts
    Global Posts
    627 Global Posts
    #5  
    Was this screen problem present before you put on the screen protector?

    If not, then I blame you.
  6. shadrap's Avatar
    Posts
    161 Posts
    Global Posts
    308 Global Posts
    #6  
    Dang, did ya look at it before you put the protector on? I just wondered if that could have caused it. Go get another one, complain to retentions and get something for your time also.
  7. #7  
    That's grim
  8. #8  
    that would make me mad
    Palm V-->Visor Deluxe-->Visor Prism-->Visorphone-->Treo 180-->Treo 600-->Treo 650 on Sprint-->Treo 700p-->Centro-->Diamond-->Pre-->HTC EVO 4g???!
  9.    #9  
    no it definitely wasn't there because i was checking it for dead pixels when the lady was activating it lol.
  10. shadrap's Avatar
    Posts
    161 Posts
    Global Posts
    308 Global Posts
    #10  
    Go get another one. I know it has to be frustrating, but it isn't the Pre's fault. Just the little Chinamen that put it together or the ups guy that threw the box.
  11. NBENZ's Avatar
    Posts
    79 Posts
    Global Posts
    81 Global Posts
    #11  
    Wow that sucks, and makes me nervous because I am going to try and get a replacement pre myself. If my luck is as bad as yours i think i'll go for a touch pro 2.
  12. #12  
    Quote Originally Posted by c4sper View Post
    Ok guys listen to this. I been waiting for the pre just like all of us. I get up ealry on saturday the 6th and show up at the sprint store at 5:30am to get my pre im the 4th person in line. awesome. i get my pre then after a few hours i notice 3 dead pixels which wasn't that big of a deal but the main problem was that is doesn't ring. as in there is no sound coming out when it rings. the display shows someone calling but none of the ringtones work. so i take it back in the same day(6th) they sold the last one of 80 when i walked in and no one has brought theres back for any hardware issues. so i have the dud of 80 units? wow.. So now im stuck with a broken pre till wednesday(yesterday) got my new one its perfect it rings and it has no dead pixels. I install my screen protector (bodyguardz) let it sit for 3 hours come back and there is a discolor on the screen. a perfect straight line down the screen. are you kidding me? first i thought it was a discolor in the protector but i ripped off the protector and here is the pictures i got....now i have to order another set of screen protectors cuz palm and sprint **** me again. the pre just does not like me.
    I'm sure a Sprint sales rep told you that.

    You weren't the only return, trust me.
  13.    #13  
    yea i would think there would be alot more.
  14. #14  
    Shudder. Palm really botched the launch with whomever is doing the shoddy manufacturing.

Posting Permissions