Page 2 of 2 FirstFirst 12
Results 21 to 28 of 28
  1. bugking's Avatar
    Posts
    46 Posts
    Global Posts
    48 Global Posts
    #21  
    Quote Originally Posted by Irix View Post
    That's what I was discussing... Everything is in place but AdHoc WiFi mode isn't working at the moment. Can't make the Computer -> Pre connection without it.

    I'm sure it'll be working soon though...
    That's great!!!!! One question, why AdHoc and not AP mode?
  2. #22  
    Quote Originally Posted by ronnienyc View Post
    eddieroger, like I said above, I spend weekends in a summer house where there is no net access. Thus tethering is a must. (I am tethered through my BB right now.) For example, I update my web site, blog, etc. on weekends. Does not work on the phone's browser. And anyway the phone's screen is too small for this type of work. Not to mention the tiny keyboard...
    Fair enough. Thanks for honestly answering the question (without flaming me). And like I said, I just don't have that use for it, so I didn't understand the need. I completely appreciate it now, though.
  3.    #23  
    Looks like they've got something working over here:

    http://forums.precentral.net/web-os-...rk-around.html
  4. Irix's Avatar
    Posts
    17 Posts
    Global Posts
    23 Global Posts
    #24  
    Quote Originally Posted by ronnienyc View Post
    Looks like they've got something working over here:
    Eh, I'd just do what I said earlier that I tested. Way less work, and no proxy needed.

    The 2 IPtables commands
    Then change default route on your AP router to the pre's internal IP... then any device that connected to your AP will route through the Pre for internet.


    Or if you want a permanent Wifi AdHoc connection that intermittently dies you can try the script in the post further down.

    Just know you won't be able to connect to any other WiFi AP until you disable that script.
    Last edited by Irix; 06/11/2009 at 05:25 PM.
  5. #25  
    Could you use classic to run PDANET and get tethering to work? Just a shot.?
    treo 90 > treo 300 > treo 600 > treo 650 > motorola Q > instinct > treo pro > Whats next???? PRE?
  6.    #26  
    Irix, I didn't see a description of how to accomplish what you have working??
  7. Irix's Avatar
    Posts
    17 Posts
    Global Posts
    23 Global Posts
    #27  
    Quote Originally Posted by ronnienyc View Post
    Irix, I didn't see a description of how to accomplish what you have working??
    I haven't given out much information besides a few iptables commands. Which anyone could google and find anyway if they knew what to look for...

    If I get an elegant solution using the WebOS GUI working I'll post it, I have no intentions of posting some hack like a proxy server on the pre. Or a script that forces your wifi to only be connected to one place permanently. Not to mention other faults I've seen in some of the "solutions".

    I've been trying to fix the Wifi app to work with AdHoc connections but I haven't had a lot of time to work on it. Probably won't until next week.

    Another solution would be patching the TelephonyInterfaceCdma as a few other people have mentioned. Which I'm positive will work for BT PAM, and USB PAM.

    Time vs $$ I should probably spend the time on the TelephonyInterfaceCdma disassembly I did. Palm will eventually fix the ADHOC stuff themselves anyway.

    Also, I'm pretty new to the object oriented ways of JSON. Like an object having reference to data and a function in the same structure. So It's been a bit of a learning curve for me until I get my head wrapped around it.
  8. bugking's Avatar
    Posts
    46 Posts
    Global Posts
    48 Global Posts
    #28  
    Any news?
Page 2 of 2 FirstFirst 12

Posting Permissions