Results 1 to 13 of 13
  1. #2  
    i am able to see it too!
  2. JRBTempe's Avatar
    Posts
    53 Posts
    Global Posts
    71 Global Posts
    #3  
    Grrrr... didn't see anything yesterday, but this morning when I logged into MyReward Zone, there it was! Eagerly clicked the submit button, and waited and waited and waited... and got an error message. Went back to the main page to try again, and the giveaway was gone! WTF, Best Buy...?!
  3. DDD
    DDD is offline
    DDD's Avatar
    Posts
    60 Posts
    #4  
    Same thing happened to me.
    Also Known as 3_D
  4. #5  
    entered on first try.
    spam incoming to my wife's email account. hehe.
    I see pandas.
  5. #6  
    I got it to show up once yesterday. Then I tried to enter, got an error message. And haven't seen it yet.
  6. joelpalm
    joelpalm's Avatar
    #7  
    I signed up for it this AM with no problem. Just became a new rewards zone customer. I thought you had to open the credit card, but you don't which is nice.
  7. #8  
    I finally got it to show up again. And this is the msg I get hen I try to join the contest.
    We're Sorry!
    We're sorry. We are not able to process your request at this time. Please try again later.
  8. #9  
    Signed up no problem this morning. I wonder if it helps that I was already a Reward Zone member.
  9. #10  
    What do I do with my two month old Treo Pro when I win one of these Pres from BB?
  10. #11  
    Quote Originally Posted by lopezpm View Post
    Signed up no problem this morning. I wonder if it helps that I was already a Reward Zone member.
    I've been a Reward Zone member for a month now. So it didn't help me. I sent an email to them to see what's up with it.
  11. wessock's Avatar
    Posts
    124 Posts
    Global Posts
    238 Global Posts
    #12  
    Get a response from them? I still haven't been able to get it to work. I guess the one guy who got it to work will have 10 Pre's
  12. #13  
    It would be really cool to win this!

Posting Permissions