Results 1 to 18 of 18
Like Tree2Likes
  • 1 Post By John Steffes
  • 1 Post By laingman
  1.    #1  
    Hi guys

    Yes, i'm making a "frankepre" in 2014. I love my palm so much I did the com board swap successfully from a Palm Pre on Sprint into a Verizon cdma Pre 2. I can make phone calls and receive them, and the phone charges. I've tried for 3 days now to follow the webos internals guide, user guides, and a variety of online forum posts. Alot of the info is obsolete and the building of Webdoctor fails. Also, the scripts dont seem to work anymore, they wont download the files they need! Very frusrating and I really need my profile back up as I have no contacts or acess to web or sms.

    So please, anyone out here I have done with hardware part, I have meta doctor, git, novacom drivers installed. I just cant for the life of me figure out how to do a build with metadoctor (it always fails somehow) and the scripts from the most recent step by step guide dont work. What do I do? Its very confusing for someone that doesnt know how metadoctor and or webos works. I cant get any webdoctor to work and i'm not sure if i'm supposed to use the verizon palm2 doctor or the original doctor for the palm pre sprint? Please help guys i need this phone working I dont want to got to Android or IOs.

    TIA
  2. #2  
    A few things...

    If this is a Sprint Comm board make sure you activate and have full data working in Sprint Pre before swapping...

    (There is a theory to make the provisioner work in webOS 2.0.1 or webOS 2.1.0, but it will not work in webOS 2.2.4)

    If you used a Verizon Pre2, then any Verizon Doctor will work (WebOS Doctor Versions - WebOS Internals) version 2.0.1 or version 2.1.0.

    However to use webOS 2.2.4 you need to use meta doctor to create a Verizon Pre2 webOS 2.2.4 build as the existing HP/Palm doctor will not work on a Verizon tokened device.

    I created two scripts for Verizon for the Pre2, Test Script which is the WR doctor to work on a Verizon device and a Super Script for you I would recommend you use the Test Script version as you do not need the Verizon Carrier apps.

    Also make sure your Comm Board is at Version RC1.8(595) for full functionality to work with webOS 2.x, my Test Script handles this by removing the zero stub file and replaces it with the Verizon Pre2 file and includes the Verizon Pre2 CDMA modem firmware...

    When you are done do not forget the Certificate issue: HP App Catalog Download Failed
  3. #3  
    Quote Originally Posted by John Steffes View Post
    However to use webOS 2.2.4 you need to use meta doctor to create a Verizon Pre2 webOS 2.2.4 build as the existing HP/Palm doctor will not work on a Verizon tokened device.
    John, it sounds like the OP followed all of this already, but is saying the meta-doctor scripts aren't able to retrieve files from the web. Have links in any old meta-scripts gone dead? Maybe you can link through to some of your newer scripts if they're not posted to the WOSI wiki?
  4. #4  
    Quote Originally Posted by ananimus View Post
    John, it sounds like the OP followed all of this already, but is saying the meta-doctor scripts aren't able to retrieve files from the web. Have links in any old meta-scripts gone dead? Maybe you can link through to some of your newer scripts if they're not posted to the WOSI wiki?
    I will check tonight but as far as I know, my scripts still work?
  5. #5  
    http://pivotce.com/2013/11/20/how-to...efile-editing/ This is updated and working as recently as 2 weeks ago. The webOS internals site is pretty outdated now.
    Follow me on Twitter
    For the latest webOS news check out pivotCE
  6.    #6  
    Quote Originally Posted by Alan Morford View Post
    How-to: Meta-Doctor Part 1 – No Makefile editing | pivotCE This is updated and working as recently as 2 weeks ago. The webOS internals site is pretty outdated now.
    Alan
    Thanks I'll try your script tomorrow and see if it works. yes the webos interanls guide is way out of date. I'm pretty technical ( i had a quad boot x86 box already with ubuntu) and the old instructions are outdated and confusing. I checked out your link and guide and will follow that and report back.
  7.    #7  
    Quote Originally Posted by ananimus View Post
    John, it sounds like the OP followed all of this already, but is saying the meta-doctor scripts aren't able to retrieve files from the web. Have links in any old meta-scripts gone dead? Maybe you can link through to some of your newer scripts if they're not posted to the WOSI wiki?
    Ananimus

    you got it! the old scripts dont work anymore which led me to think i had done something wrong and following these old guides 2 days of hell! But i see the light at the end of the tunnel now I think
  8.    #8  
    Quote Originally Posted by John Steffes View Post
    A few things...

    If this is a Sprint Comm board make sure you activate and have full data working in Sprint Pre before swapping...


    I created two scripts for Verizon for the Pre2, Test Script which is the WR doctor to work on a Verizon device and a Super Script for you I would recommend you use the Test Script version as you do not need the Verizon Carrier apps.

    Also make sure your Comm Board is at Version RC1.8(595) for full functionality to work with webOS 2.x, my Test Script handles this by removing the zero stub file and replaces it with the Verizon Pre2 file and includes the Verizon Pre2 CDMA modem firmware...

    When you are done do not forget the Certificate issue: HP App Catalog Download Failed
    Hi John, thanks for the verbose response. Yes, the comboard was fully operational it was my phone.

    Also I DO want to use verizon apps mainly the Hotspot which is one of the pros of using the Frankenpre over a new android or iphone.

    So i'm still alittle confused As I really dont know how meta doctor and all this stuff works. So what script should I use please?
  9. #9  
    What errors are you getting? I had some trouble with installing some of the required software (I believe git was the offender) the last time I created a metadoctor environment (months ago), but when I ran it a couple weeks ago to create a Vzw 2.2.4 meta-doctor, it had no trouble downloading the required jar files or executing the script. I believe I re-ran the git pull to make sure I had the newest scripts first.

    The correct metadoctor script to run for your combination is documented on the webosinternals Wiki - it should be ./scripts/meta-sprint-franken-verizon-pre2-2.2.4
  10. #10  
    Quote Originally Posted by westcoaster#WN View Post
    Hi John, thanks for the verbose response. Yes, the comboard was fully operational it was my phone.

    Also I DO want to use verizon apps mainly the Hotspot which is one of the pros of using the Frankenpre over a new android or iphone.

    So i'm still alittle confused As I really dont know how meta doctor and all this stuff works. So what script should I use please?
    i highly recommend the freetether app in Preware vs the vzn hotspot app.
  11.    #11  
    Quote Originally Posted by Grabber5.0 View Post
    What errors are you getting? I had some trouble with installing some of the required software (I believe git was the offender) the last time I created a metadoctor environment (months ago), but when I ran it a couple weeks ago to create a Vzw 2.2.4 meta-doctor, it had no trouble downloading the required jar files or executing the script. I believe I re-ran the git pull to make sure I had the newest scripts first.

    The correct metadoctor script to run for your combination is documented on the webosinternals Wiki - it should be ./scripts/meta-sprint-franken-verizon-pre2-2.2.4

    Git is installed fine. Meta-doctor is installed fine. Java is installed fine.

    The script you quote from the wiki (which is outdated) fails to download needed files.
  12.    #12  
    Hey guys the script comes up with errors for me here are some:


    Your custom doctor file will be created at build/super-verizon-pre2-2.2.4/webosdoctorp224pre2-verizon-2.2.4.jar

    Error parsing proxy URL http://localhost:4001 : Bad port number.
    ./scripts/super-verizon-pre2-2.2.4: line 125: [: !=: unary operator expected
    cut: the delimiter must be a single character
  13.    #13  
    and also this at the end


    unzip: cannot find zipfile directory in one of webosdoctorp224pre2-wr-2.2.4.jar or
    webosdoctorp224pre2-wr-2.2.4.jar.zip, and cannot find webosdoctorp224pre2-wr-2.2.4.jar.ZIP, period.
    make: *** [build/pre2-p224pre2-wr-2.2.4/.unpacked] Error 9
  14.    #14  
    Quote Originally Posted by Grabber5.0 View Post
    What errors are you getting? I had some trouble with installing some of the required software (I believe git was the offender) the last time I created a metadoctor environment (months ago), but when I ran it a couple weeks ago to create a Vzw 2.2.4 meta-doctor, it had no trouble downloading the required jar files or executing the script. I believe I re-ran the git pull to make sure I had the newest scripts first.

    The correct metadoctor script to run for your combination is documented on the webosinternals Wiki - it should be ./scripts/meta-sprint-franken-verizon-pre2-2.2.4
    Then i tried this script: ./scripts/meta-sprint-franken-verizon-pre2-2.2.4

    and got this error:
    Your custom doctor file will be created at build/meta-sprint-franken-verizon-pre2-2.2.4/webosdoctorp224pre2-wr-2.2.4.jar

    Error parsing proxy URL Mobile Nations - NO. 1 FOR ALL THINGS MOBILE : Bad port number.
    webosdoctorp102verizonwireless-2.1.0.jar did not download properly. Please run this script again.
    running it again gives same results. This really sux
  15. #15  
    Quote Originally Posted by John Steffes View Post
    I will check tonight but as far as I know, my scripts still work?
    Tested the git pull (fresh copy), worked, tested my script, worked, pulled JAR file down from HP/Palm then the script built the Super Doctor as it should...

    Quote Originally Posted by Grabber5.0 View Post
    What errors are you getting? I had some trouble with installing some of the required software (I believe git was the offender) the last time I created a metadoctor environment (months ago), but when I ran it a couple weeks ago to create a Vzw 2.2.4 meta-doctor, it had no trouble downloading the required jar files or executing the script. I believe I re-ran the git pull to make sure I had the newest scripts first.

    The correct metadoctor script to run for your combination is documented on the webosinternals Wiki - it should be ./scripts/meta-sprint-franken-verizon-pre2-2.2.4
    I can not speak if this one works or not, I am not the author of this script...

    Quote Originally Posted by westcoaster#WN View Post
    Hey guys the script comes up with errors for me here are some:
    Quote Originally Posted by westcoaster#WN View Post
    and also this at the end
    Looking at these errors makes me think your Linux/Mac system does not work with the existing scripts?

    My Super Script worked fine, tested 3/15/2014 and again tonight 3/16/2014, however on my MAC OS X, with a fresh meta doctor git pull. (I did not update MACPORTS, or any other component, YMMV).

    If the script is having issues downloading the files go to webos internals and download the JAR's files one by one and put them in the downloads directory: http://www.webos-internals.org/wiki/...octor_Versions

    These are the public doctors the Super Script for the Pre2 will attempt to download from HP/Palm:
    webosdoctorp101ewwverizonwireless-1.4.5.1.jar
    webosdoctorp102verizonwireless-2.0.1.jar
    webosdoctorp102verizonwireless-2.1.0.jar
    webosdoctorp224mantaverizon-2.2.4.jar
    webosdoctorp224pre2-wr-2.2.4.jar

    Quote Originally Posted by westcoaster#WN View Post
    Hi John, thanks for the verbose response. Yes, the comboard was fully operational it was my phone.

    Also I DO want to use verizon apps mainly the Hotspot which is one of the pros of using the Frankenpre over a new android or iphone.

    So i'm still alittle confused As I really dont know how meta doctor and all this stuff works. So what script should I use please?

    FYI The WR Doctor includes the HP/Palm Mobile Hotspot as part of the WR carrier Apps, so if you wanted to use the Test Script, that will not need so many doctors...

    These are the public doctors the Test Script for the Pre2 will attempt to download from HP/Palm:
    webosdoctorp102verizonwireless-2.1.0.jar
    webosdoctorp224pre2-wr-2.2.4.jar
    Last edited by John Steffes; 03/16/2014 at 08:12 PM.
    TJs11thPre likes this.
  16. #16  
    Quote Originally Posted by westcoaster#WN View Post
    Hey guys the script comes up with errors for me here are some:

    Error parsing proxy URL http://localhost:4001 : Bad port number.
    This error may be the root of your problem, preventing the metadoctor script from downloading various doctor files it needs to build a metadoctor as John Steffles mentioned above.

    It looks like an issue with something installed on your ubuntu system, so to fix it, try these commands:

    Code:
    apt-get purge anon-proxy
    
    export HTTP_PROXY=
    
    export http_proxy=
    
    (note that there is intentionally nothing after the '=' signs in the last two commands)
    Then give the metadoctor script another try.
    Last edited by ArchonAdvisors; 03/17/2014 at 07:34 AM.
  17.    #17  
    Thanks ill try that.

    I did manage to have success with the Webdoctor verizon pre2 jar file. This enabled me to restore my profile and get back SMS and my contacts and gmail and all so i'm thrilled. I dont know if i want to update to latest webos as it might break things?

    i have few questions

    1. I dont think the app catalogue is working for me is there something special I need to do to enable it?

    2. Can I enable Sprint navigation somehow? Also is there a free google maps or map app I can install?

    3. can I use apps from webos 1.4.5?

    4. How do I install Flash?

    any other recommendations please let me know guys and thanks
  18. #18  
    Quote Originally Posted by westcoaster#WN View Post
    Thanks ill try that.

    I did manage to have success with the Webdoctor verizon pre2 jar file. This enabled me to restore my profile and get back SMS and my contacts and gmail and all so i'm thrilled. I dont know if i want to update to latest webos as it might break things?

    i have few questions

    1. I dont think the app catalogue is working for me is there something special I need to do to enable it?

    2. Can I enable Sprint navigation somehow? Also is there a free google maps or map app I can install?

    3. can I use apps from webos 1.4.5?

    4. How do I install Flash?

    any other recommendations please let me know guys and thanks
    Hello

    There are many app catalog fix threads, this is the one that worked for me, (thanks grabber) NEW in Box Pre3 - Last years app catalog certificate failing - URGENT Help please! ( post #17)

    You can install sprint navigation but it wont work anymore because sprint discontinued it. Your best bet is navit, see post #41 here Navit 0.5.0.5287-1: new stable release

    Most apps from the app catalog should work

    You enable flash by opening the browser and selecting preferences from the drop down menu and you'll see enable flash or something like that.

    What version of webos are you running? I like 2.1 myself, just seems like the best 2x version and no video pause patch didn't work out too good for me on 2.4 but I don't know if it works now. Among other things.

    If you don't want to go to 2.4 you better stop it from updating now or you will soon start getting automatic notification messages and the only way to stop it is like this Preventing Automatic WebOS update (post #10)

    Once it updates you would have to doctor your phone to go back

    Browser no flash pause patch here: [Patch] Disable flash player pause when browser minimized for webOS 2.1.1 / 2.2.3
    Last edited by laingman; 03/18/2014 at 01:12 AM.
    TJs11thPre likes this.

Similar Threads

  1. I'm confused...Palm profile
    By alpine335 in forum HP TouchPad
    Replies: 51
    Last Post: 07/05/2011, 05:12 PM
  2. Going from Iphone to Palm2
    By akon in forum Palm Pre 2
    Replies: 90
    Last Post: 06/19/2011, 07:25 PM
  3. Confused - Palm pre Plus from O2 Germany update to 2.1.0???
    By ymalool in forum Palm Pre and Pre Plus
    Replies: 2
    Last Post: 04/12/2011, 04:41 AM
  4. Confused on Verizon Update...
    By serijules in forum Palm OS Devices & Apps
    Replies: 2
    Last Post: 07/12/2007, 11:20 PM
  5. Internet with Verizon (Im totally confused)
    By rawfish in forum North American Carriers (CDMA)
    Replies: 7
    Last Post: 07/31/2005, 08:06 PM

Posting Permissions