webOS Nation Forums >  webOS Devices >  Palm Pre 2 > Can't remove vibrate patch
Can't remove vibrate patch
  Reply
 
Thread Tools Display Modes
Old 01/20/2013, 05:17 AM   #1 (permalink)
Member
 
Babywipez's Avatar
 
Posts: 6
Some time ago I installed the "SMS vibrate to Two Seconds" patch from Preware and since then the phone always vibrates when a message is received, even when I disable vibration in the options, it can't be turned off and I tried everything.

Does anyone have an idea how to remove the stuck 2 second patch? I want to be able to put my phone in silent mode, drives me crazy when the buzzing wakes me up in the middle of the night

If I try to install any of the other vibrating patches (half or one second) I get the following error:

Code:
begin
Nothing Interesting.
verify
Nothing Interesting.
download
% Total % Received % Xferd Average Speed Time Time Time Current
10 11036 10 1107 0 0 1210 0 0:00:09 --:--:-- 0:00:09 1708
100 11036 100 11036 0 0 10233 0 0:00:01 0:00:01 --:--:-- 13574
identify
org.webosinternals.patches.messaging-sms-vibrate-to-half-second
install
{"returnValue":true , "ticket":1, "subscribed":true}
{ "ticket":1 , "status":"STARTING" }
{ "ticket":1 , "status":"CREATE_TMP" }
{ "ticket":1 , "status":"VERIFYING" }
{ "ticket":1 , "status":"IPKG_INSTALL" }
{ "ticket":1 , "status":"SUCCESS" }
mkdir-prerm
Nothing Interesting.
install-prerm
Nothing Interesting.
postinst
-1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.messaging-sms-vibrate-to-half-second.postinst 2>&1
1 out of 1 hunk FAILED -- saving rejects to file usr/palm/applications/com.palm.app.messaging/app/controllers/notification-assistant.js.rej
remove
Removing package org.webosinternals.patches.messaging-sms-vibrate-to-half-second from root...
(offline root mode: not running org.webosinternals.patches.messaging-sms-vibrate-to-half-second.prerm)
delete
Nothing Interesting.
failed
Nothing Interesting.

Last edited by Babywipez; 02/17/2013 at 10:25 AM.
Babywipez is offline   Reply With Quote
Old 01/24/2013, 10:48 PM   #2 (permalink)
Member
 
TJs11thPre's Avatar
 
Posts: 972
have you tried uninstalling with webOS quick installer?

just in case you haven't, download/install WOSQI and see if it's still listed as an installed patch. you should be able to check the box and click uninstall. good luck
TJs11thPre is offline   Reply With Quote
Old 02/17/2013, 10:02 AM   #3 (permalink)
Member
 
Babywipez's Avatar
 
Posts: 6
Unfortunately this didn't help.. First I couldn't find the patch in the installed patches list, so I installed and uninstalled it with WOSQI, but the issue still remains. If I try to install another vibrate patch using Preware I get the same error.

Very annoying because I can't mute my phone, the two second buzzing is pretty loud. And often I will not receive texts or get mixed up texts with previous ones that have been deleted. Trying not to smash it against my head

Quote:
Originally Posted by TJs11thPre View Post
have you tried uninstalling with webOS quick installer?

just in case you haven't, download/install WOSQI and see if it's still listed as an installed patch. you should be able to check the box and click uninstall. good luck
Babywipez is offline   Reply With Quote
Old 02/17/2013, 10:23 AM   #4 (permalink)
Member
 
Babywipez's Avatar
 
Posts: 6
I found a solution and posting here in case someone else ever needs it

Quote:
Originally Posted by WoodyTrain View Post

STEPS:

1. In Preware, choose dropdown menu in upper left corner, choose "Saved Package List". Then press "Update" button.

2. In Preware, download/run "Emergency Patch Recovery (EPR) and follow instructions. (To locate EPR, search Preware's list of everything on keyword "emergency").

3. Reboot device.

4. In Preware, choose "Saved Package List" once again. Press "Install All" button.

5. Then I was able to install Muffle System Logging 3.0.2-23 patch
Found here:
Muffle System Logging - stuck patch! How to remove a single patch?
Babywipez is offline   Reply With Quote
Old 02/17/2013, 10:41 AM   #5 (permalink)
Member
 
GMMan's Avatar
 
Posts: 2,136
You could have just copied the .webosinternals.orig file back into the patched file.
__________________
Contact: @GMMan_BZFlag (me on Twitter)
webOS Releases: Change your App Catalog country: TouchPad/PC | TouchPad/webOS Resources | Search suggestion patch for browser | Cycling Email Notifications | Don't Doctor! Make a good support request. | How to post logs | webOS Charge Monitor
GMMan is offline   Reply With Quote
Old 02/17/2013, 10:52 AM   #6 (permalink)
Member
 
Babywipez's Avatar
 
Posts: 6
Quote:
Originally Posted by GMMan View Post
You could have just copied the .webosinternals.orig file back into the patched file.
Didn't know that but thanks, I'm just happy it's solved now
Babywipez is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0