Results 1 to 8 of 8
  1. Aganar's Avatar
    Posts
    102 Posts
    Global Posts
    105 Global Posts
       #1  
    In the process of trying to put my Sprint Pre 2 back together, but this volume bezel does not want to get into place.



    You can see the wire seems a little bent. I didn't do that, but at the same time I don't know how else it's supposed to work, because it's connected to the phone face-down, yet the volume rocker sits perpendicular to the board.



    You can see that I can't close the thing because the phone is pinching the rocker somewhere. I've tried poking it in eighty different directions with a screwdriver, the thing just will not sit comfortably. Even if I get the wire under the hood so it's not (or at least shouldn't be) getting pinched, it doesn't fully stretch so that it's horizontal over the nub.

    I have no idea what to do. Can't close the phone, can't screw it back in, and I've got screwdrivers from the Pre 2 and the Pre- sitting here, waiting to be inadvertently knocked over while I desperately try to figure out how to get this damn thing into place.
  2. #2  
    It can take some finagling, but there's a slot that you need to work the cable through. I've done it a dozen times and I always forget about it.

    Try undoing the screws you've already put in, getting the cable in place, and then screwing it back down.
    "'Form follows function' that has been misunderstood. Form and function should be one, joined in a spiritual union."
    Frank Lloyd Wright
  3. Aganar's Avatar
    Posts
    102 Posts
    Global Posts
    105 Global Posts
       #3  
    I don't have any screws in place.

    And again, it's just catching somewhere and I cannot get it to get there comfortably. Even if I pull the thing gently so that I know it's going through the "slot", it's still catching somewhere. I've manipulated the wire now more times than I can count; I'm afraid of damaging it.

    Of course it would be the Pre 2 that has this problem. Not the ****ty Pre- that I'm never going to use after this. #!*&^

    EDIT: It wasn't staying because something else is bulging somewhere. I figured that out once I got about two screws in. Unscrewed, tried to reseat everything. Now the left keyboard tab (the one nearest the GPS and other wire) will not slide into place. Even when I do the slide motion, and the opposite tab goes in, this one just won't. I have just spent the last hour, based on the timestamp, trying to get it to go in. I am five seconds away from hurling this phone at a wall. If I can't get the damn thing back in I can't even return it, so it's money down the drain anyway.
    Last edited by Aganar; 02/02/2012 at 09:27 PM.
  4. Aganar's Avatar
    Posts
    102 Posts
    Global Posts
    105 Global Posts
       #4  
    Update: All that and it didn't even fix the wifi problem. LOL!

    Righto, I'm done. Pre 2 is getting returned tomorrow and the Pre- is geting a sledgehammer to the face.
  5. #5  
    Quote Originally Posted by Aganar View Post
    Update: All that and it didn't even fix the wifi problem. LOL!

    Righto, I'm done. Pre 2 is getting returned tomorrow and the Pre- is geting a sledgehammer to the face.
    Wow, that's a big surprise, and a huge bummer! At least you gave it your best shot and know for sure that you got sold a bum phone.
    Last edited by sq5; 02/03/2012 at 08:24 AM.
  6. #6  
    I couldnt get the key tabs to slide back into place either, but decided that it didn't matter because the Pre 2 closed up just fine anyway. It is a little bit looser than it should be, but I've always been careful with my toys so l'm ok with it.
  7. giggles's Avatar
    Posts
    677 Posts
    Global Posts
    690 Global Posts
    #7  
    Lol wow.... Seriously all you had to do was just calm down and chill and put the wire in. Took me awhile back it worked. And there's nothing wrong with the tabs they're just super tricky to get in you just gotta stay with it.
  8. Aganar's Avatar
    Posts
    102 Posts
    Global Posts
    105 Global Posts
       #8  
    Except for, ya know, the part where the wifi still didn't work, which was the whole reason for the comm board swap in the first place.

Posting Permissions