Results 1 to 14 of 14
Like Tree1Likes
  • 1 Post By Hernie
  1.    #1  
    Is the GPS on anybody else's Pre 2 really weak? On my old Pixi Plus, I could get a fix anywhere including in a building. With my Pre 2, I can only get a fix outside. This gets annoying when I try to check into somewhere on Foursquare. I try inside the place but I can't get a signal and then I forget later (I have a horrible memory). I just found out today that I can use Google Location Services and that seems to have helped inside my house, but It would be nice to be able to use the GPS.
  2. #2  
    I can't really suggest anything for this. Is this a recurring issue or just a day or so thing?


    If I helped you or you have downloaded one of my files,
    then least you could do is click the "Thanks" button.
  3.    #3  
    Recurring. It's always been like this. Could my phone possibly have a bad GPS antenna?
  4. #4  
    I had the same problem with my Sprint Frankenpre 2...I figured it out. I just took off the battery cover and removed the battery...just below the battery, to the left of the two little charging prongs. You can pull back that cover and there are two little plugs that connect to the Comm board. Ones GPS and they other is wifi (i think). Check to see if those are both pressed down and securely locked into place.
    Jonnie likes this.
  5. #5  
    Quote Originally Posted by Hernie View Post
    I had the same problem with my Sprint Frankenpre 2...I figured it out. I just took off the battery cover and removed the battery...just below the battery, to the left of the two little charging prongs. You can pull back that cover and there are two little plugs that connect to the Comm board. Ones GPS and they other is wifi (i think). Check to see if those are both pressed down and securely locked into place.Click to view quoted image
    Actually, both of those wires go to the GPS located at the top of the back bezel. The white is the power wire and black is for ground. The pluggs only detach for Verizon Pre2's while the GSM Pre2 has the wires soldered in. The wifi is attached to the comm board.

    If you have a Verizon based Pre2, it wouldn't hurt to look and make sure they are hooked in properly.


    If I helped you or you have downloaded one of my files,
    then least you could do is click the "Thanks" button.
  6.    #6  
    I have a GSM Pre 2.
  7. #7  
    Quote Originally Posted by friskies64 View Post
    I have a GSM Pre 2.
    I don't know what to tell you.


    If I helped you or you have downloaded one of my files,
    then least you could do is click the "Thanks" button.
  8. #8  
    Yep, I had the same problem, and it turned out to be the two wires that had come loose after my commboard swap.
  9.    #9  
    Quote Originally Posted by tobias funke View Post
    Yep, I had the same problem, and it turned out to be the two wires that had come loose after my commboard swap.
    That wouldn't apply to GSM Pre 2's though, right?
  10. #10  
    Even soldered connections can break. It doesn't hurt anything to check, just in case.
  11. #11  
    Quote Originally Posted by Abyssul View Post
    Actually, both of those wires go to the GPS located at the top of the back bezel. The white is the power wire and black is for ground. The pluggs only detach for Verizon Pre2's while the GSM Pre2 has the wires soldered in. The wifi is attached to the comm board.

    If you have a Verizon based Pre2, it wouldn't hurt to look and make sure they are hooked in properly.
    This is not true. I have a GSM Pre 2 that I converted to a Sprint FrankenPre 2. Take a look! I'm almost sure that'll be your problem.
  12.    #12  
    Mine didn't have any plugs, just two wires that went under the metal part. I think mine are soldered in.

    And on a minor side note, that flap won't stay down after checking for the plugs and it's bugging me now. :P
    Last edited by friskies64; 11/08/2011 at 07:21 PM.
  13. #13  
    Quote Originally Posted by Hernie View Post
    This is not true. I have a GSM Pre 2 that I converted to a Sprint FrankenPre 2. Take a look! I'm almost sure that'll be your problem.
    Yes it is true. The reason you have the prongs there is because you have the Sprint comm board. I have a Sprint FrankenPre2 from a GSM as well. The prongs are there from the ONLY part that you took out of your old Sprint Pre-.


    If I helped you or you have downloaded one of my files,
    then least you could do is click the "Thanks" button.
  14. TimBoch's Avatar
    Posts
    312 Posts
    Global Posts
    318 Global Posts
    #14  
    Since Bing Maps, my GPS has been terrible on my Verizon Pre2. I have lost one of the most useful features of my phone.
    Tim Boche

    Palm IIIe, IIIx, IIIxe, IIIc, ClieT615, ClieTJ25, ClieTJ37(2), Treo600, Treo650, Centro(AT&T & Verizon),
    Pre Plus(6 replacements), TouchPads(1-16gb,2-32gb), Pre2 (and a spare)

Posting Permissions